aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-03-27 15:02:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-03-27 21:27:40 +0000
commit768a948f0ca4bf987c88798c92611e4ec6a0b66d (patch)
tree2a3dff40f7f2a00e0b4bf825245c1d929dc174d1
parent36282a180ba110d49d04fac997d4e11bd23726fc (diff)
graphics/art: Add LTO option enabled by default
Users particularly care about the performance of ART, so it makes sense to enable the LTO option.
-rw-r--r--graphics/art/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/graphics/art/Makefile b/graphics/art/Makefile
index bfd712f29d6d..914b7a061af4 100644
--- a/graphics/art/Makefile
+++ b/graphics/art/Makefile
@@ -1,6 +1,6 @@
PORTNAME= art
DISTVERSION= 1.19.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/agriggio/art/downloads/
PKGNAMESUFFIX= -raw-image-editor
@@ -39,9 +39,14 @@ EXTRACT_CMD= gtar
LDFLAGS+= -lpthread # otherwise build breaks on some systems: error: undefined symbol: pthread_create
+OPTIONS_DEFINE= LTO
+OPTIONS_DEFAULT= LTO
+
+LTO_CMAKE_BOOL= WITH_LTO
+
.if exists(/usr/include/omp.h)
-OPTIONS_DEFINE= OPENMP
-OPTIONS_DEFAULT= OPENMP
+OPTIONS_DEFINE+= OPENMP
+OPTIONS_DEFAULT+= OPENMP
OPENMP_CMAKE_BOOL= OPTION_OMP
.else