aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-21 16:51:54 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-21 17:01:58 +0000
commit7b98bdd020b1fa27dd7273303461332eb3010682 (patch)
tree3143d146f5bc1e5f9990c9a1d4184277845d4d38
parent664ad19ced52ff61f57992d6e661a807e60b6a69 (diff)
downloadports-7b98bdd020b1fa27dd7273303461332eb3010682.tar.gz
ports-7b98bdd020b1fa27dd7273303461332eb3010682.zip
devel/py-pykdtree: Add py-pykdtree 1.3.7.post0
pykdtree is a kd-tree implementation for fast nearest neighbour search in Python. The aim is to be the fastest implementation around for common use cases (low dimensions and low number of neighbours) for both tree construction and queries. The implementation is based on scipy.spatial.cKDTree and libANN by combining the best features from both and focus on implementation efficiency. The interface is similar to that of scipy.spatial.cKDTree except only Euclidean distance measure is supported. Queries are optionally multithreaded using OpenMP.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pykdtree/Makefile23
-rw-r--r--devel/py-pykdtree/distinfo3
-rw-r--r--devel/py-pykdtree/pkg-descr12
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 998961787754..8ed8329ce0d4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5282,6 +5282,7 @@
SUBDIR += py-pyintelowl
SUBDIR += py-pyjq
SUBDIR += py-pyjsparser
+ SUBDIR += py-pykdtree
SUBDIR += py-pylama
SUBDIR += py-pylev
SUBDIR += py-pylibsrtp
diff --git a/devel/py-pykdtree/Makefile b/devel/py-pykdtree/Makefile
new file mode 100644
index 000000000000..152d9fb520d2
--- /dev/null
+++ b/devel/py-pykdtree/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= pykdtree
+PORTVERSION= 1.3.7.post0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Fast kd-tree implementation with OpenMP-enabled queries
+WWW= https://github.com/storpipfugl/pykdtree
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/devel/py-pykdtree/distinfo b/devel/py-pykdtree/distinfo
new file mode 100644
index 000000000000..16b8c479e9fc
--- /dev/null
+++ b/devel/py-pykdtree/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1692211615
+SHA256 (pykdtree-1.3.7.post0.tar.gz) = eca1d61d33db621ef8027eb691ae88db9c65d196aba4b2cc90c190cb90bb508e
+SIZE (pykdtree-1.3.7.post0.tar.gz) = 84509
diff --git a/devel/py-pykdtree/pkg-descr b/devel/py-pykdtree/pkg-descr
new file mode 100644
index 000000000000..aaae7459c719
--- /dev/null
+++ b/devel/py-pykdtree/pkg-descr
@@ -0,0 +1,12 @@
+pykdtree is a kd-tree implementation for fast nearest neighbour search in
+Python. The aim is to be the fastest implementation around for common use cases
+(low dimensions and low number of neighbours) for both tree construction and
+queries.
+
+The implementation is based on scipy.spatial.cKDTree and libANN by combining the
+best features from both and focus on implementation efficiency.
+
+The interface is similar to that of scipy.spatial.cKDTree except only Euclidean
+distance measure is supported.
+
+Queries are optionally multithreaded using OpenMP.