aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-12-04 20:08:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-12-04 20:12:41 +0000
commit7ef5092b042777477c3c181a9dd9376181e2d82a (patch)
treed9ee6caa7fdad129968eb119622820f73333f07e
parentee394fe3b6b9614ef77351530ed5188d6bf45b94 (diff)
downloadports-7ef5092b042777477c3c181a9dd9376181e2d82a.tar.gz
ports-7ef5092b042777477c3c181a9dd9376181e2d82a.zip
math/freefem++: update 4.13 → 4.14
Reported by: portscout
-rw-r--r--math/freefem++/Makefile10
-rw-r--r--math/freefem++/distinfo6
-rw-r--r--math/freefem++/files/patch-plugin_seq_metis.cpp31
-rw-r--r--math/freefem++/pkg-plist2
4 files changed, 10 insertions, 39 deletions
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 879d2051df2e..342803365596 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -1,7 +1,6 @@
PORTNAME= freefem++
DISTVERSIONPREFIX= v
-DISTVERSION= 4.13
-PORTREVISION= 5
+DISTVERSION= 4.14
CATEGORIES= math science
MAINTAINER= yuri@FreeBSD.org
@@ -27,12 +26,11 @@ LIB_DEPENDS= libhdf5.so:science/hdf5 \
libscotch.so:cad/scotch \
libcmumps.so:math/mumps \
libnlopt.so:math/nlopt \
- libsuperlu.so:math/superlu \
- libsz.so:science/libaec
+ libsuperlu.so:math/superlu
RUN_DEPENDS= bash:shells/bash \
pipe:misc/pipe
-USES= autoreconf bison blaslapack:openblas compiler:c++14-lang fortran \
+USES= autoreconf bison blaslapack:openblas compiler:c++14-lang fortran \
gl gmake localbase perl5 pkgconfig shebangfix xorg
USE_GITHUB= yes
@@ -47,6 +45,8 @@ CPPFLAGS+= -I${LOCALBASE}/include/superlu
LDFLAGS+= -s
.endif
+LDFLAGS+= -pthread # workaround for https://github.com/FreeFem/FreeFem-sources/issues/296#issuecomment-1839198380
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= CNOFLAGS="${CFLAGS}" LIBS=-lz
CONFIGURE_ARGS= --disable-download \
diff --git a/math/freefem++/distinfo b/math/freefem++/distinfo
index c36323c140a4..7eec9e571860 100644
--- a/math/freefem++/distinfo
+++ b/math/freefem++/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1687080379
-SHA256 (FreeFem-FreeFem-sources-v4.13_GH0.tar.gz) = d296adc42c6b0cc5f148c44b00bea15939d6c0dbe391613dea8a0693c2c0e3b7
-SIZE (FreeFem-FreeFem-sources-v4.13_GH0.tar.gz) = 12966789
+TIMESTAMP = 1701684800
+SHA256 (FreeFem-FreeFem-sources-v4.14_GH0.tar.gz) = 931cbfe9ef6f6530756c300c5ae47bfdaca21c560a5407cb33325a376a3b6af8
+SIZE (FreeFem-FreeFem-sources-v4.14_GH0.tar.gz) = 12987355
diff --git a/math/freefem++/files/patch-plugin_seq_metis.cpp b/math/freefem++/files/patch-plugin_seq_metis.cpp
deleted file mode 100644
index c9c1bc9f8915..000000000000
--- a/math/freefem++/files/patch-plugin_seq_metis.cpp
+++ /dev/null
@@ -1,31 +0,0 @@
-- from https://github.com/FreeFem/FreeFem-sources/issues/280#issuecomment-1596025016
-
---- plugin/seq/metis.cpp.orig 2023-06-18 09:28:12 UTC
-+++ plugin/seq/metis.cpp
-@@ -97,7 +97,7 @@ KN< R > *partmetis( KN< R > *const &part, FESPACE *con
- }
-
- #endif
-- } else epart = 0;
-+ } else epart = static_cast<idx_t>(0);
- part->resize(nv);
- *part = npart;
- return part;
-@@ -154,7 +154,7 @@ KN< R > *partmetis(Stack s, KN< R > *const &part, Mesh
- }
-
- #endif
-- } else epart = 0;
-+ } else epart = static_cast<idx_t>(0);
- part->resize(nt);
- *part = epart;
- return part;
-@@ -184,7 +184,7 @@ KN< long > *partmetisd(Stack s, KN< long > *const &par
- printf(" %d-way Edge-Cut: %7d, Balance: %5.2f\n", nparts, nve,
- ComputeElementBalance(nt, nparts, epart));
- #endif
-- } else epart = 0;
-+ } else epart = static_cast<idx_t>(0);
- part->resize(nt);
- *part = epart;
- return part;
diff --git a/math/freefem++/pkg-plist b/math/freefem++/pkg-plist
index f78e5d12e8ef..39116857a289 100644
--- a/math/freefem++/pkg-plist
+++ b/math/freefem++/pkg-plist
@@ -181,6 +181,8 @@ lib/ff++/%%VER%%/lib/Element_QF.so
lib/ff++/%%VER%%/lib/FreeFemQA.so
lib/ff++/%%VER%%/lib/Helmholtz_FD.so
lib/ff++/%%VER%%/lib/IncompleteCholesky.so
+lib/ff++/%%VER%%/lib/MUMPS.so
+lib/ff++/%%VER%%/lib/MUMPS_seq.so
lib/ff++/%%VER%%/lib/MatD-VFP0.so
lib/ff++/%%VER%%/lib/MatrixMarket.so
lib/ff++/%%VER%%/lib/MetricKuate.so