aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2023-11-06 21:12:59 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2023-11-06 21:12:59 +0000
commit80656e393399a82da0db224a847b221034748cc3 (patch)
tree5a57fef8d2608da1938e4a1f2f87d91e11ecb7f6
parent089da4a7a764183a8d63d22dedc12537f90b50db (diff)
downloadports-80656e393399a82da0db224a847b221034748cc3.tar.gz
ports-80656e393399a82da0db224a847b221034748cc3.zip
net/ntopng: Fix OpenSSL support in embedded webserver
PR: 274925
-rw-r--r--net/ntopng/Makefile1
-rw-r--r--net/ntopng/files/patch-configure.ac.in18
2 files changed, 10 insertions, 9 deletions
diff --git a/net/ntopng/Makefile b/net/ntopng/Makefile
index 4abb1dff0402..3123823a03f5 100644
--- a/net/ntopng/Makefile
+++ b/net/ntopng/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ntopng
PORTVERSION= 6.0.d20231103
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net
diff --git a/net/ntopng/files/patch-configure.ac.in b/net/ntopng/files/patch-configure.ac.in
index 2efdccd10217..ccb3bc112353 100644
--- a/net/ntopng/files/patch-configure.ac.in
+++ b/net/ntopng/files/patch-configure.ac.in
@@ -90,15 +90,13 @@
if test ! -z "$NDPI_CUST_INC" ; then :
NDPI_INC=$NDPI_CUST_INC
fi
-@@ -339,46 +295,9 @@ AC_ARG_WITH(json-c-static,
+@@ -339,45 +295,10 @@ AC_ARG_WITH(json-c-static,
[PKG_CHECK_MODULES(JSON, json-c, [], [AC_MSG_ERROR(Please install libjson-c-dev package prerequisite)])]
)
-if test -x /bin/freebsd-version; then
- FREEBSD_VERSION=`freebsd-version | cut -f 1 -d '.'`
-fi
-+SSL_INC="-I%%SSL_INC%%"
-+SSL_LIB="-L%%SSL_LIB%% -lssl -lcrypto"
-if test "${FREEBSD_VERSION}" != "14"; then
-pkg-config --exists libssl
@@ -135,11 +133,13 @@
- fi
-fi
-fi
--
++AC_DEFINE_UNQUOTED(NO_SSL_DL, 1, [has openssl])
++SSL_INC="-I%%SSL_INC%%"
++SSL_LIB="-L%%SSL_LIB%% -lssl -lcrypto"
+
AC_MSG_CHECKING([PF_RING nBPF])
NBPF_HOME=${PWD}/../PF_RING/userland/nbpf
- LIBNBPF=${NBPF_HOME}/libnbpf.a
-@@ -510,12 +429,8 @@ AS_VAR_IF(with_hiredis, yes, [
+@@ -510,12 +431,8 @@ AS_VAR_IF(with_hiredis, yes, [
pkg-config --exists hiredis
if test "$?" -ne 1; then
HIREDIS_INC="`pkg-config --cflags hiredis` -I/usr/include/hiredis"
@@ -153,7 +153,7 @@
echo "Please install hiredis package prerequisite"
exit -1
fi
-@@ -533,14 +448,14 @@ if test "${with_nedge+set}" != set; then
+@@ -533,14 +450,14 @@ if test "${with_nedge+set}" != set; then
fi
if test $SYSTEM = "FreeBSD"; then
@@ -170,7 +170,7 @@
AC_DEFINE_UNQUOTED(HAVE_PF_RING, 1, [Native PF_RING support])
if test -f "${PF_RING_HOME}/userland/lib/libpfring.a"; then
echo "${PF_RING_HOME}/userland/libpcap/libpcap.a"
-@@ -560,18 +475,18 @@ if test "${with_nedge+set}" != set; then
+@@ -560,18 +477,18 @@ if test "${with_nedge+set}" != set; then
CXXFLAGS="${CXXFLAGS} -I/opt/pfring/include"
echo "Using PF_RING installed in /opt/pfring"
else
@@ -195,7 +195,7 @@
echo "Please make sure you have installed your PF_RING libraries and try again"
exit 1
fi
-@@ -756,14 +671,12 @@ else
+@@ -756,14 +673,12 @@ else
echo "Building without support for MySQL libraries."
fi
else