aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-26 20:36:41 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-26 20:36:41 +0000
commit89d71d7e16cebde85f652d366147496e171148e8 (patch)
treee42d922614229f73a54c2fd51fe8229ce3eed431
parentdaeb071983c97ccd81a791178e1476a75d5f9581 (diff)
downloadports-89d71d7e16cebde85f652d366147496e171148e8.tar.gz
ports-89d71d7e16cebde85f652d366147496e171148e8.zip
x11/py-pyscreeze: New port: cross-platform screenshot module for python
PyScreeze can take screenshots, save them to files, and locate images within the screen. This is useful if you have a small image of, say, a button that needs to be clicked and want to locate it on the screen. Screenshot functionality requires the Pillow module. OS X uses the screencapture command, which comes with the operating system. Linux/FreeBSD uses the scrot command.
-rw-r--r--x11/Makefile1
-rw-r--r--x11/py-pyscreeze/Makefile23
-rw-r--r--x11/py-pyscreeze/distinfo3
-rw-r--r--x11/py-pyscreeze/pkg-descr7
4 files changed, 34 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index bdc7ab03f1fe..d948980fb968 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -314,6 +314,7 @@
SUBDIR += py-mouseinfo
SUBDIR += py-pynput
SUBDIR += py-pyscreenshot
+ SUBDIR += py-pyscreeze
SUBDIR += py-python-xapp
SUBDIR += py-pyvirtualdisplay
SUBDIR += py-screeninfo
diff --git a/x11/py-pyscreeze/Makefile b/x11/py-pyscreeze/Makefile
new file mode 100644
index 000000000000..5594119b63c4
--- /dev/null
+++ b/x11/py-pyscreeze/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= pyscreeze
+DISTVERSION= 0.1.28
+CATEGORIES= x11 python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyScreeze-${DISTVERSION}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= cross-platform screenshot module for python
+WWW= https://github.com/asweigart/pyscreeze
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+
+USES= dos2unix python:3.6+
+USE_PYTHON= autoplist distutils
+
+DOS2UNIX_GLOB= *.py
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/x11/py-pyscreeze/distinfo b/x11/py-pyscreeze/distinfo
new file mode 100644
index 000000000000..42a1959fc685
--- /dev/null
+++ b/x11/py-pyscreeze/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1682524999
+SHA256 (PyScreeze-0.1.28.tar.gz) = 4428600ed19b30cd3f4b5d83767d198fc1dbae7439eecf9bd795445c009b67ae
+SIZE (PyScreeze-0.1.28.tar.gz) = 25547
diff --git a/x11/py-pyscreeze/pkg-descr b/x11/py-pyscreeze/pkg-descr
new file mode 100644
index 000000000000..d8b29a89c44b
--- /dev/null
+++ b/x11/py-pyscreeze/pkg-descr
@@ -0,0 +1,7 @@
+PyScreeze can take screenshots, save them to files, and locate images within
+the screen. This is useful if you have a small image of, say, a button that
+needs to be clicked and want to locate it on the screen.
+
+Screenshot functionality requires the Pillow module. OS X uses the
+screencapture command, which comes with the operating system. Linux/FreeBSD
+uses the scrot command.