aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@utahime.org>2021-05-15 06:50:22 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-05-15 07:14:04 +0000
commit9671981826f7ef8b1e7fb0a430ee24d4a1f0acf2 (patch)
treefe4be6c86d5ebad1e08ad79d5ed6ba427147cd8e
parent4032ece1e981d7f4f214aeebb25dfcf22a625d2b (diff)
downloadports-9671981826f7ef8b1e7fb0a430ee24d4a1f0acf2.tar.gz
ports-9671981826f7ef8b1e7fb0a430ee24d4a1f0acf2.zip
*: Remove unnecessary 'port' argument from USES=readline
PR: 248459 Exp-run by: antoine
-rw-r--r--audio/ardour6/Makefile2
-rw-r--r--audio/ecasound/Makefile2
-rw-r--r--audio/libsmf/Makefile2
-rw-r--r--audio/yoshimi/Makefile2
-rw-r--r--biology/mrbayes/Makefile2
-rw-r--r--devel/gdb/Makefile2
-rw-r--r--devel/grv/Makefile2
-rw-r--r--devel/opendht/Makefile2
-rw-r--r--devel/tclreadline/Makefile2
-rw-r--r--devel/tig/Makefile2
-rw-r--r--games/wesnoth/Makefile2
-rw-r--r--lang/io/Makefile.addons2
-rw-r--r--lang/mdk/Makefile2
-rw-r--r--lang/newlisp/Makefile2
-rw-r--r--lang/python27/Makefile2
-rw-r--r--lang/python36/Makefile2
-rw-r--r--lang/python37/Makefile2
-rw-r--r--lang/python38/Makefile2
-rw-r--r--lang/python39/Makefile2
-rw-r--r--lang/ruby26/Makefile2
-rw-r--r--lang/ruby27/Makefile2
-rw-r--r--lang/scm/Makefile4
-rw-r--r--lang/sdcc/Makefile2
-rw-r--r--lang/tauthon/Makefile2
-rw-r--r--math/R/Makefile2
-rw-r--r--math/asymptote/Makefile2
-rw-r--r--math/cvc4/Makefile2
-rw-r--r--math/eukleides/Makefile2
-rw-r--r--math/libqalculate/Makefile2
-rw-r--r--math/units/Makefile2
-rw-r--r--print/fontforge/Makefile2
-rw-r--r--security/krb5-117/Makefile12
-rw-r--r--security/krb5-118/Makefile12
-rw-r--r--security/krb5-119/Makefile12
-rw-r--r--security/krb5-devel/Makefile12
-rw-r--r--sysutils/bareos-server/Makefile2
-rw-r--r--sysutils/bareos17-server/Makefile2
-rw-r--r--sysutils/bareos18-server/Makefile2
-rw-r--r--sysutils/bareos19-server/Makefile2
-rw-r--r--sysutils/slurm-wlm/Makefile2
40 files changed, 43 insertions, 79 deletions
diff --git a/audio/ardour6/Makefile b/audio/ardour6/Makefile
index fdce24c7b399..7b79edd21da5 100644
--- a/audio/ardour6/Makefile
+++ b/audio/ardour6/Makefile
@@ -43,7 +43,7 @@ LIB_DEPENDS= libserd-0.so:devel/serd \
libwebsockets.so:net/libwebsockets
USES= compiler:c++11-lang desktop-file-utils gettext gnome \
- libarchive pkgconfig python:3.7,build readline:port tar:bzip2 \
+ libarchive pkgconfig python:3.7,build readline tar:bzip2 \
waf xorg
USE_CXXSTD= c++11
USE_XORG= x11
diff --git a/audio/ecasound/Makefile b/audio/ecasound/Makefile
index e902a6e4951e..5b56d028ce71 100644
--- a/audio/ecasound/Makefile
+++ b/audio/ecasound/Makefile
@@ -16,7 +16,7 @@ LICENSE_COMB= multi
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:audio/ladspa
USES= gmake libtool localbase:ldflags ncurses pkgconfig \
- readline:port shebangfix
+ readline shebangfix
SHEBANG_FILES= ecatools/ecamonitor
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-liblilv \
diff --git a/audio/libsmf/Makefile b/audio/libsmf/Makefile
index fc2b4de06ed5..e35a07ac9811 100644
--- a/audio/libsmf/Makefile
+++ b/audio/libsmf/Makefile
@@ -12,7 +12,7 @@ COMMENT= Standard MIDI File format library
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gnome libtool pathfix pkgconfig readline:port
+USES= gnome libtool pathfix pkgconfig readline
USE_GNOME= glib20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/audio/yoshimi/Makefile b/audio/yoshimi/Makefile
index 7d5b350d6a66..cec4ea023230 100644
--- a/audio/yoshimi/Makefile
+++ b/audio/yoshimi/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libargp.so:devel/argp-standalone \
libjack.so:audio/jack \
libmxml.so:textproc/mxml
-USES= cmake compiler:c++11-lang gnome ncurses pkgconfig readline:port
+USES= cmake compiler:c++11-lang gnome ncurses pkgconfig readline
USE_GNOME= cairo
USE_GITHUB= yes
diff --git a/biology/mrbayes/Makefile b/biology/mrbayes/Makefile
index 2dc794bfc40a..b3faab5813fe 100644
--- a/biology/mrbayes/Makefile
+++ b/biology/mrbayes/Makefile
@@ -12,7 +12,7 @@ COMMENT= Bayesian inference of phylogeny
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= readline:port
+USES= readline
USE_GITHUB= yes
GH_ACCOUNT= NBISweden
GH_PROJECT= MrBayes
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 72dfaf05b0f9..308c44bd9740 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -71,7 +71,7 @@ DEBUG_CFLAGS= -g
GUILE_CONFIGURE_WITH= guile
GUILE_LIB_DEPENDS= libguile-2.2.so:lang/guile2
NLS_USES= gettext-runtime
-PORT_READLINE_USES= readline:port
+PORT_READLINE_USES= readline
PORT_ICONV_USES= iconv:wchar_t
PYTHON_CONFIGURE_ON= --with-python=${PYTHON_CMD}
PYTHON_CONFIGURE_OFF= --without-python
diff --git a/devel/grv/Makefile b/devel/grv/Makefile
index bb0cd5e73e54..ae405d9d4b1b 100644
--- a/devel/grv/Makefile
+++ b/devel/grv/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgit2.so:devel/libgit2
-USES= go ncurses pkgconfig readline:port
+USES= go ncurses pkgconfig readline
USE_GITHUB= yes
GH_ACCOUNT= rgburke
GH_SUBDIR= src/github.com/rgburke/grv
diff --git a/devel/opendht/Makefile b/devel/opendht/Makefile
index ae1dbd192861..f3563ba29556 100644
--- a/devel/opendht/Makefile
+++ b/devel/opendht/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libargon2.so:security/libargon2 \
libnettle.so:security/nettle \
libgnutls.so:security/gnutls
-USES= cmake compiler:c++11-lib pathfix pkgconfig readline:port
+USES= cmake compiler:c++11-lib pathfix pkgconfig readline
USE_GITHUB= yes
GH_ACCOUNT= savoirfairelinux
USE_LDCONFIG= yes
diff --git a/devel/tclreadline/Makefile b/devel/tclreadline/Makefile
index 92ff7354df27..898b7a2a81a7 100644
--- a/devel/tclreadline/Makefile
+++ b/devel/tclreadline/Makefile
@@ -11,7 +11,7 @@ COMMENT= GNU readline for TCL
LICENSE= BSD3CLAUSE
-USES= autoreconf libtool tcl readline:port
+USES= autoreconf libtool tcl readline
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
diff --git a/devel/tig/Makefile b/devel/tig/Makefile
index 7ee9ed7f2bd0..5e05ac0b39a4 100644
--- a/devel/tig/Makefile
+++ b/devel/tig/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
TEST_DEPENDS= git:devel/git
-USES= iconv gmake ncurses readline:port
+USES= iconv gmake ncurses readline
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE}
MAKE_ARGS= V=1
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 9e05f0ce0e5a..991bf3cdb470 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -24,7 +24,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -lboost_system
PORTSCOUT= limitw:1,even
USES= cmake compiler:c++11-lang cpe gnome pkgconfig \
- python:3.6+,run readline:port shebangfix ssl sdl tar:bzip2 xorg
+ python:3.6+,run readline shebangfix ssl sdl tar:bzip2 xorg
USE_SDL= image2 mixer2 ttf2
USE_LDCONFIG= yes
USE_GNOME= cairo pango
diff --git a/lang/io/Makefile.addons b/lang/io/Makefile.addons
index ec5e2eda3b3a..7555c4b0113b 100644
--- a/lang/io/Makefile.addons
+++ b/lang/io/Makefile.addons
@@ -101,7 +101,7 @@ OPENGL_USE= GL=glut XORG=xmu
POSTGRESQL_USES= pgsql
PYTHON_USES= python:3.3+
QDBM_LIB_DEPENDS= libqdbm.so:databases/qdbm
-READLINE_USES= readline:port
+READLINE_USES= readline
REGEX_LIB_DEPENDS= libpcre.so:devel/pcre
SQLITE3_USES= sqlite:3
SAMPLERATECONVERTER_LIB_DEPENDS=\
diff --git a/lang/mdk/Makefile b/lang/mdk/Makefile
index c364e304c80a..b34bbb8fb865 100644
--- a/lang/mdk/Makefile
+++ b/lang/mdk/Makefile
@@ -10,7 +10,7 @@ COMMENT= Utilities for developing programs using MIX and MIXAL
LICENSE= GPLv3
-USES= gettext gmake gnome ncurses pkgconfig readline:port
+USES= gettext gmake gnome ncurses pkgconfig readline
USE_GNOME= glib20 gtk30 intltool
GNU_CONFIGURE= yes
TEST_TARGET= check
diff --git a/lang/newlisp/Makefile b/lang/newlisp/Makefile
index 959713a67b24..9d8c25be47bf 100644
--- a/lang/newlisp/Makefile
+++ b/lang/newlisp/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libffi.so:devel/libffi
CONFLICTS= newlisp-devel-[0-9]*
-USES= readline:port tar:tgz
+USES= readline tar:tgz
OPTIONS_SUB= yes
HAS_CONFIGURE= yes
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index a492ba198698..26465776d71c 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -15,7 +15,7 @@ LICENSE= PSFL
DEPRECATED= EOLed upstream
EXPIRATION_DATE= 2020-12-31
-USES= cpe ncurses pathfix pkgconfig readline:port shebangfix ssl tar:xz
+USES= cpe ncurses pathfix pkgconfig readline shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/lang/python36/Makefile b/lang/python36/Makefile
index 7769c1855501..0434c86a5698 100644
--- a/lang/python36/Makefile
+++ b/lang/python36/Makefile
@@ -18,7 +18,7 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-USES= cpe ncurses pathfix pkgconfig readline:port shebangfix ssl tar:xz
+USES= cpe ncurses pathfix pkgconfig readline shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/lang/python37/Makefile b/lang/python37/Makefile
index 6f4225651176..e83ef0fc6abf 100644
--- a/lang/python37/Makefile
+++ b/lang/python37/Makefile
@@ -17,7 +17,7 @@ LICENSE= PSFL
LIB_DEPENDS= libffi.so:devel/libffi \
libmpdec.so:math/mpdecimal
-USES= cpe ncurses pathfix pkgconfig readline:port shebangfix ssl tar:xz
+USES= cpe ncurses pathfix pkgconfig readline shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/lang/python38/Makefile b/lang/python38/Makefile
index b0d976496459..da6a5bfe9ad1 100644
--- a/lang/python38/Makefile
+++ b/lang/python38/Makefile
@@ -13,7 +13,7 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-USES= cpe ncurses pathfix pkgconfig readline:port shebangfix ssl tar:xz
+USES= cpe ncurses pathfix pkgconfig readline shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/lang/python39/Makefile b/lang/python39/Makefile
index 4e474427c9c4..0bc868234c78 100644
--- a/lang/python39/Makefile
+++ b/lang/python39/Makefile
@@ -13,7 +13,7 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-USES= compiler:c11 cpe ncurses pathfix pkgconfig readline:port \
+USES= compiler:c11 cpe ncurses pathfix pkgconfig readline \
shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
diff --git a/lang/ruby26/Makefile b/lang/ruby26/Makefile
index 762e01092286..06393d6096ef 100644
--- a/lang/ruby26/Makefile
+++ b/lang/ruby26/Makefile
@@ -66,7 +66,7 @@ LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-dir=${LOCALBASE}
LIBEDIT_USES= libedit
RDOC_CONFIGURE_ENABLE= install-rdoc
READLINE_CONFIGURE_ON= --disable-libedit --with-readline-dir=${LOCALBASE}
-READLINE_USES= readline:port
+READLINE_USES= readline
CPE_VENDOR= ruby-lang
CPE_VERSION= ${RUBY_RELVERSION}
diff --git a/lang/ruby27/Makefile b/lang/ruby27/Makefile
index 65435e0f12dc..75ec067993cc 100644
--- a/lang/ruby27/Makefile
+++ b/lang/ruby27/Makefile
@@ -66,7 +66,7 @@ LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-dir=${LOCALBASE}
LIBEDIT_USES= libedit
RDOC_CONFIGURE_ENABLE= install-rdoc
READLINE_CONFIGURE_ON= --disable-libedit --with-readline-dir=${LOCALBASE}
-READLINE_USES= readline:port
+READLINE_USES= readline
CPE_VENDOR= ruby-lang
CPE_VERSION= ${RUBY_RELVERSION}
diff --git a/lang/scm/Makefile b/lang/scm/Makefile
index 166e17f92dba..25534139a453 100644
--- a/lang/scm/Makefile
+++ b/lang/scm/Makefile
@@ -70,12 +70,8 @@ EXTRA_PATCHES+= ${FILESDIR}/ia64-patch
ARCHOBJS= continue-ia64.S
.endif
-.if "${readline_ARGS}" == "port"
LIBEDIT_SUB1= ${CPPFLAGS}" "${LDFLAGS:M-L*}
LIBEDIT_SUB2= ${LDFLAGS:M-L*}
-.else
-LIBEDIT_SUB1= -I/usr/include/edit" "
-.endif
post-patch:
@${REINPLACE_CMD} -e 's|/usr/include|${LOCALBASE}/include| ; \
diff --git a/lang/sdcc/Makefile b/lang/sdcc/Makefile
index 8607ea79da7a..ffb10c94f599 100644
--- a/lang/sdcc/Makefile
+++ b/lang/sdcc/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/adjacency_list.hpp:devel/boost-l
CONFLICTS_INSTALL= sdcc-[0-9]* sdcc-devel-[0-9]*
GNU_CONFIGURE= yes
USES= autoreconf:build bison compiler:c++11-lang gmake \
- readline:port python shebangfix tar:bzip2
+ readline python shebangfix tar:bzip2
SHEBANG_FILES= support/scripts/as2gbmap.py
TEST_WRKSRC= ${WRKSRC}/support/regression
TEST_ARGS= --no-print-directory # tons of them, way too annoying
diff --git a/lang/tauthon/Makefile b/lang/tauthon/Makefile
index 438f570cf435..aac57d6d7f5d 100644
--- a/lang/tauthon/Makefile
+++ b/lang/tauthon/Makefile
@@ -17,7 +17,7 @@ LICENSE= PSFL
DEPRECATED= Uses Python 2.7 codebase
EXPIRATION_DATE= 2021-06-23
-USES= pathfix shebangfix autoreconf ncurses pkgconfig readline:port ssl tar:xz
+USES= pathfix shebangfix autoreconf ncurses pkgconfig readline ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_GITHUB= yes
diff --git a/math/R/Makefile b/math/R/Makefile
index 2cda68013594..8ca604cb38bc 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -26,7 +26,7 @@ RUN_DEPENDS= gmake:devel/gmake
# - Create a meta-port for the recommended packages
USES= compiler:c++11-lang gmake iconv libtool localbase pathfix perl5 \
- readline:port
+ readline
USE_LDCONFIG= ${PREFIX}/lib/R/lib
USE_PERL5= build
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 274d61913e5d..74947c18085f 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -70,7 +70,7 @@ OFFSCREEN_DESC= Enable offscreen rendering using OSMesa library
OFFSCREEN_LIB_DEPENDS= libOSMesa.so:graphics/libosmesa
READLINE_CONFIGURE_ENABLE= readline
-READLINE_USES= readline:port
+READLINE_USES= readline
TEST_TARGET= test
TEST_WRKSRC= ${WRKSRC}/tests
diff --git a/math/cvc4/Makefile b/math/cvc4/Makefile
index 45f716f4baa4..47f620bb2e02 100644
--- a/math/cvc4/Makefile
+++ b/math/cvc4/Makefile
@@ -60,7 +60,7 @@ PYTHON_CMAKE_BOOL= BUILD_BINDINGS_PYTHON USE_PYTHON3
PYTHON_BUILD_DEPENDS= swig:devel/swig
READLINE_CMAKE_BOOL= USE_READLINE
-READLINE_USES= readline:port
+READLINE_USES= readline
GMP_CMAKE_BOOL= ENABLE_PORTFOLIO
GMP_CMAKE_ON= -DENABLE_DUMPING=OFF
diff --git a/math/eukleides/Makefile b/math/eukleides/Makefile
index 36d93b77c2d8..653c99786f78 100644
--- a/math/eukleides/Makefile
+++ b/math/eukleides/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= pstoedit:graphics/pstoedit \
getopt>=0:misc/getopt
-USES= bison gettext iconv gmake readline:port tar:bzip2
+USES= bison gettext iconv gmake readline tar:bzip2
USE_TEX= latex
INSTALL_TARGET= install PREFIX=${STAGEDIR}${PREFIX}
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index a160134d1beb..5e1c5094c96e 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libicuuc.so:devel/icu \
libmpfr.so:math/mpfr
USES= compiler:c++14-lang gettext gmake gnome iconv libtool \
- localbase ncurses pathfix pkgconfig readline:port
+ localbase ncurses pathfix pkgconfig readline
USE_GNOME= intltool libxml2
USE_LDCONFIG= yes
diff --git a/math/units/Makefile b/math/units/Makefile
index c16302cdfbad..8914a816431f 100644
--- a/math/units/Makefile
+++ b/math/units/Makefile
@@ -19,7 +19,7 @@ INFO= units
OPTIONS_DEFINE= READLINE
OPTIONS_DEFAULT= READLINE
-READLINE_USES= readline:port
+READLINE_USES= readline
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index d21d8f418470..e746dee6e7a4 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -59,7 +59,7 @@ PYTHON_USES= python:3.5+
PYTHON_USES_OFF=python:3.5+,build
PYTHON_CMAKE_BOOL= ENABLE_PYTHON_SCRIPTING ENABLE_PYTHON_EXTENSION
-READLINE_USES= readline:port
+READLINE_USES= readline
READLINE_CMAKE_BOOL= ENABLE_LIBREADLINE
SPIRO_DESC= Use libspiro to edit with clothoid splines
diff --git a/security/krb5-117/Makefile b/security/krb5-117/Makefile
index ecae51c1556b..31e81e9d02ee 100644
--- a/security/krb5-117/Makefile
+++ b/security/krb5-117/Makefile
@@ -44,7 +44,7 @@ CPE_PRODUCT= kerberos
OPTIONS_DEFINE= EXAMPLES NLS KRB5_PDF KRB5_HTML DNS_FOR_REALM LDAP LMDB
OPTIONS_DEFAULT= KRB5_PDF KRB5_HTML READLINE
OPTIONS_RADIO= CMD_LINE_EDITING
-OPTIONS_RADIO_CMD_LINE_EDITING= READLINE READLINE_PORT LIBEDIT
+OPTIONS_RADIO_CMD_LINE_EDITING= READLINE LIBEDIT
CMD_LINE_EDITING_DESC= Command line editing for kadmin and ktutil
KRB5_PDF_DESC= Install krb5 PDF documentation
KRB5_HTML_DESC= Install krb5 HTML documentation
@@ -59,8 +59,7 @@ LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
LMDB_IMPLIES= LDAP
NLS_USES= gettext
READLINE_USES= readline
-READLINE_PORT_DESC= Command line editing via devel/readline
-READLINE_PORT_USES= readline:port
+READLINE_CONFIGURE_WITH=readline
LIBEDIT_USES= libedit
LIBEDIT_CONFIGURE_WITH= libedit
@@ -94,13 +93,6 @@ LDFLAGS:= -Wl,-rpath,${_RPATH}${F:S/-Wl,-rpath,//} \
BROKEN= LIB_DEPENDS when using KRB5_HOME is broken
.endif
-# OPTIONS helper causes conflicting with/without
-.if ${PORT_OPTIONS:MREADLINE} || ${PORT_OPTIONS:MREADLINE_PORT}
-CONFIGURE_ARGS+= --with-readline
-.else
-CONFIGURE_ARGS+= --without-readline
-.endif
-
.if defined(PROGRAM_TRANSFORM_NAME) && ${PROGRAM_TRANSFORM_NAME} != ""
CONFIGURE_ARGS+= --program-transform-name="${PROGRAM_TRANSFORM_NAME}"
.endif
diff --git a/security/krb5-118/Makefile b/security/krb5-118/Makefile
index e938eb71b847..c8c4262785db 100644
--- a/security/krb5-118/Makefile
+++ b/security/krb5-118/Makefile
@@ -41,7 +41,7 @@ CPE_PRODUCT= kerberos
OPTIONS_DEFINE= EXAMPLES NLS KRB5_PDF KRB5_HTML DNS_FOR_REALM LDAP LMDB
OPTIONS_DEFAULT= KRB5_PDF KRB5_HTML READLINE
OPTIONS_RADIO= CMD_LINE_EDITING
-OPTIONS_RADIO_CMD_LINE_EDITING= READLINE READLINE_PORT LIBEDIT
+OPTIONS_RADIO_CMD_LINE_EDITING= READLINE LIBEDIT
CMD_LINE_EDITING_DESC= Command line editing for kadmin and ktutil
KRB5_PDF_DESC= Install krb5 PDF documentation
KRB5_HTML_DESC= Install krb5 HTML documentation
@@ -56,8 +56,7 @@ LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
LMDB_IMPLIES= LDAP
NLS_USES= gettext
READLINE_USES= readline
-READLINE_PORT_DESC= Command line editing via devel/readline
-READLINE_PORT_USES= readline:port
+READLINE_CONFIGURE_WITH=readline
LIBEDIT_USES= libedit
LIBEDIT_CONFIGURE_WITH= libedit
@@ -91,13 +90,6 @@ LDFLAGS:= -Wl,-rpath,${_RPATH}${F:S/-Wl,-rpath,//} \
BROKEN= LIB_DEPENDS when using KRB5_HOME is broken
.endif
-# OPTIONS helper causes conflicting with/without
-.if ${PORT_OPTIONS:MREADLINE} || ${PORT_OPTIONS:MREADLINE_PORT}
-CONFIGURE_ARGS+= --with-readline
-.else
-CONFIGURE_ARGS+= --without-readline
-.endif
-
.if defined(PROGRAM_TRANSFORM_NAME) && ${PROGRAM_TRANSFORM_NAME} != ""
CONFIGURE_ARGS+= --program-transform-name="${PROGRAM_TRANSFORM_NAME}"
.endif
diff --git a/security/krb5-119/Makefile b/security/krb5-119/Makefile
index 183d32b7208a..9d7d1a1a7430 100644
--- a/security/krb5-119/Makefile
+++ b/security/krb5-119/Makefile
@@ -41,7 +41,7 @@ CPE_PRODUCT= kerberos
OPTIONS_DEFINE= EXAMPLES NLS KRB5_PDF KRB5_HTML DNS_FOR_REALM LDAP LMDB
OPTIONS_DEFAULT= KRB5_PDF KRB5_HTML READLINE
OPTIONS_RADIO= CMD_LINE_EDITING
-OPTIONS_RADIO_CMD_LINE_EDITING= READLINE READLINE_PORT LIBEDIT
+OPTIONS_RADIO_CMD_LINE_EDITING= READLINE LIBEDIT
CMD_LINE_EDITING_DESC= Command line editing for kadmin and ktutil
KRB5_PDF_DESC= Install krb5 PDF documentation
KRB5_HTML_DESC= Install krb5 HTML documentation
@@ -56,8 +56,7 @@ LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
LMDB_IMPLIES= LDAP
NLS_USES= gettext
READLINE_USES= readline
-READLINE_PORT_DESC= Command line editing via devel/readline
-READLINE_PORT_USES= readline:port
+READLINE_CONFIGURE_WITH=readline
LIBEDIT_USES= libedit
LIBEDIT_CONFIGURE_WITH= libedit
@@ -91,13 +90,6 @@ LDFLAGS:= -Wl,-rpath,${_RPATH}${F:S/-Wl,-rpath,//} \
BROKEN= LIB_DEPENDS when using KRB5_HOME is broken
.endif
-# OPTIONS helper causes conflicting with/without
-.if ${PORT_OPTIONS:MREADLINE} || ${PORT_OPTIONS:MREADLINE_PORT}
-CONFIGURE_ARGS+= --with-readline
-.else
-CONFIGURE_ARGS+= --without-readline
-.endif
-
.if defined(PROGRAM_TRANSFORM_NAME) && ${PROGRAM_TRANSFORM_NAME} != ""
CONFIGURE_ARGS+= --program-transform-name="${PROGRAM_TRANSFORM_NAME}"
.endif
diff --git a/security/krb5-devel/Makefile b/security/krb5-devel/Makefile
index 2f05c3dff3ac..99505ee8ec46 100644
--- a/security/krb5-devel/Makefile
+++ b/security/krb5-devel/Makefile
@@ -42,7 +42,7 @@ CPE_PRODUCT= kerberos
OPTIONS_DEFINE= EXAMPLES NLS DNS_FOR_REALM LDAP LMDB
OPTIONS_DEFAULT= KRB5_PDF KRB5_HTML READLINE
OPTIONS_RADIO= CMD_LINE_EDITING
-OPTIONS_RADIO_CMD_LINE_EDITING= READLINE READLINE_PORT LIBEDIT
+OPTIONS_RADIO_CMD_LINE_EDITING= READLINE LIBEDIT
CMD_LINE_EDITING_DESC= Command line editing for kadmin and ktutil
DNS_FOR_REALM_DESC= Enable DNS lookups for Kerberos realm names
DNS_FOR_REALM_CONFIGURE_ENABLE= dns-for-realm
@@ -55,8 +55,7 @@ LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
LMDB_IMPLIES= LDAP
NLS_USES= gettext
READLINE_USES= readline
-READLINE_PORT_DESC= Command line editing via devel/readline
-READLINE_PORT_USES= readline:port
+READLINE_CONFIGURE_WITH=readline
LIBEDIT_USES= libedit
LIBEDIT_CONFIGURE_WITH= libedit
@@ -90,13 +89,6 @@ LDFLAGS:= -Wl,-rpath,${_RPATH}${F:S/-Wl,-rpath,//} \
BROKEN= LIB_DEPENDS when using KRB5_HOME is broken
.endif
-# OPTIONS helper causes conflicting with/without
-.if ${PORT_OPTIONS:MREADLINE} || ${PORT_OPTIONS:MREADLINE_PORT}
-CONFIGURE_ARGS+= --with-readline
-.else
-CONFIGURE_ARGS+= --without-readline
-.endif
-
.if defined(PROGRAM_TRANSFORM_NAME) && ${PROGRAM_TRANSFORM_NAME} != ""
CONFIGURE_ARGS+= --program-transform-name="${PROGRAM_TRANSFORM_NAME}"
.endif
diff --git a/sysutils/bareos-server/Makefile b/sysutils/bareos-server/Makefile
index 10342df51ca9..77f41f1f89b5 100644
--- a/sysutils/bareos-server/Makefile
+++ b/sysutils/bareos-server/Makefile
@@ -17,7 +17,7 @@ CONFLICTS?= bacula19*-server bacula18*-server-* bareos17-server-*
LIB_DEPENDS+= liblzo2.so:archivers/lzo2 \
libjansson.so:devel/jansson
-USES+= cmake compiler:c++11-lang localbase perl5 pkgconfig readline:port \
+USES+= cmake compiler:c++11-lang localbase perl5 pkgconfig readline \
shebangfix
USE_GITHUB= yes
USE_PERL5= run
diff --git a/sysutils/bareos17-server/Makefile b/sysutils/bareos17-server/Makefile
index 636dc0fc4816..6817b7f1e51a 100644
--- a/sysutils/bareos17-server/Makefile
+++ b/sysutils/bareos17-server/Makefile
@@ -17,7 +17,7 @@ CONFLICTS?= bacula*-server-* bareos16-server-*
LIB_DEPENDS+= liblzo2.so:archivers/lzo2 \
libjansson.so:devel/jansson
-USES+= libtool:keepla pkgconfig readline:port shebangfix
+USES+= libtool:keepla pkgconfig readline shebangfix
USE_GITHUB= yes
USERS= bareos
diff --git a/sysutils/bareos18-server/Makefile b/sysutils/bareos18-server/Makefile
index 7bde97e4abe4..b51b4ca9ee3e 100644
--- a/sysutils/bareos18-server/Makefile
+++ b/sysutils/bareos18-server/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS+= liblzo2.so:archivers/lzo2 \
libjansson.so:devel/jansson
USES+= cmake:insource compiler:c++11-lang localbase perl5 pkgconfig \
- readline:port shebangfix
+ readline shebangfix
USE_GITHUB= yes
USE_PERL5= run
diff --git a/sysutils/bareos19-server/Makefile b/sysutils/bareos19-server/Makefile
index 503c5df84c4c..0b7b74bcf117 100644
--- a/sysutils/bareos19-server/Makefile
+++ b/sysutils/bareos19-server/Makefile
@@ -17,7 +17,7 @@ CONFLICTS?= bacula18*-server bacula17*-server-*
LIB_DEPENDS+= liblzo2.so:archivers/lzo2 \
libjansson.so:devel/jansson
-USES+= cmake compiler:c++11-lang localbase perl5 pkgconfig readline:port \
+USES+= cmake compiler:c++11-lang localbase perl5 pkgconfig readline \
shebangfix
USE_GITHUB= yes
USE_PERL5= run
diff --git a/sysutils/slurm-wlm/Makefile b/sysutils/slurm-wlm/Makefile
index bec93eb0253f..60ad0b5c88b1 100644
--- a/sysutils/slurm-wlm/Makefile
+++ b/sysutils/slurm-wlm/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libjson-c.so:devel/json-c \
liblz4.so:archivers/liblz4
USES= compiler:c11 gmake gnome libtool localbase lua pkgconfig \
- python:build readline:port shebangfix ssl tar:bz2
+ python:build readline shebangfix ssl tar:bz2
USE_LDCONFIG= yes
USE_RC_SUBR= slurmctld slurmd