aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuraj Lutter <otis@FreeBSD.org>2023-02-13 10:44:49 +0000
committerMatthias Andree <mandree@FreeBSD.org>2023-02-20 22:08:51 +0000
commit982f1ce4b4370b5892147e0e4b420f3ac2224c30 (patch)
tree54e536023b5823953c6c363b53027461849334a0
parent01927a4913fa76325592b3331f39fcf0d2aa36de (diff)
downloadports-982f1ce4b4370b5892147e0e4b420f3ac2224c30.tar.gz
ports-982f1ce4b4370b5892147e0e4b420f3ac2224c30.zip
www/node16: Use ccache if available
Set CC_host and CXX_host to also use ccache when available. This helps to speed up the build significantly. And while here, also portclippy/portfmt a bit. PR: 269491
-rw-r--r--www/node16/Makefile121
1 files changed, 65 insertions, 56 deletions
diff --git a/www/node16/Makefile b/www/node16/Makefile
index fdec6b049e4e..91afb2ec9a65 100644
--- a/www/node16/Makefile
+++ b/www/node16/Makefile
@@ -12,16 +12,52 @@ WWW= https://nodejs.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_SSL= libressl libressl-devel
-BROKEN_SSL_REASON= Node.js ${PORTVERSION:R:R}.x LTS requires OpenSSL 1.1.x or the BUNDLED_SSL option enabled
-ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc64 powerpc64le
+ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc64 powerpc64le
-USES= compiler:c++11-lib gmake python:3.6+,build pkgconfig \
- localbase shebangfix
+BUILD_DEPENDS+= brotli>=1.0.9,1:archivers/brotli \
+ c-ares>=1.17.2:dns/c-ares \
+ libnghttp2>=1.45.1:www/libnghttp2 \
+ libuv>=1.42.0:devel/libuv \
+ objdump:devel/binutils
+LIB_DEPENDS+= libbrotlidec.so:archivers/brotli \
+ libcares.so:dns/c-ares \
+ libnghttp2.so:www/libnghttp2 \
+ libuv.so:devel/libuv
-OPTIONS_DEFINE= BUNDLED_SSL DOCS NLS DTRACE COREPACK
-OPTIONS_DEFAULT= DTRACE COREPACK
-OPTIONS_SUB= yes
+USES= compiler:c++11-lib gmake localbase pkgconfig python:3.6+,build \
+ shebangfix
+
+BROKEN_SSL= libressl libressl-devel
+BROKEN_SSL_REASON= node.js ${PORTVERSION:R:R}.x LTS requires OpenSSL 1.1.x or the BUNDLED_SSL option enabled
+
+SHEBANG_FILES= deps/v8/third_party/inspector_protocol/*.py deps/v8/tools/*.py \
+ tools/*.py tools/inspector_protocol/*.py
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
+ --shared-brotli \
+ --shared-cares \
+ --shared-libuv \
+ --shared-nghttp2 \
+ --shared-zlib \
+ --without-npm
+CONFIGURE_ENV+= CC_host="${CCACHE_BIN} ${CC}" \
+ CFLAGS_host="${CFLAGS}" \
+ CXX_host="${CCACHE_BIN} ${CXX}" \
+ CXXFLAGS_host="${CXXFLAGS}" \
+ LDFLAGS_host="${LDFLAGS}" \
+ LINK_host=${CXX}
+MAKE_ENV+= CFLAGS.host="${CFLAGS}" \
+ CXXFLAGS.host="${CXXFLAGS}" \
+ LDFLAGS.host="${LDFLAGS}"
+
+CONFLICTS_INSTALL= node[0-9][0-9]
+
+REINPLACE_ARGS= -i ''
+PORTSCOUT= limit:^16\.
+
+OPTIONS_DEFINE= BUNDLED_SSL COREPACK DOCS DTRACE NLS
+OPTIONS_DEFAULT= COREPACK DTRACE
.if !exists(/usr/sbin/dtrace)
OPTIONS_EXCLUDE+= DTRACE
@@ -29,62 +65,35 @@ OPTIONS_EXCLUDE+= DTRACE
OPTIONS_EXCLUDE_aarch64= DTRACE
# dt_modtext:/usr/src/cddl/contrib/opensolaris/lib/libdtrace/common/dt_link.c(820): arm not implemented
-OPTIONS_EXCLUDE_armv6= DTRACE
-OPTIONS_EXCLUDE_armv7= DTRACE
+OPTIONS_EXCLUDE_armv6= DTRACE
+OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_EXCLUDE_powerpc64= DTRACE
OPTIONS_EXCLUDE_powerpc64le= DTRACE
-BUNDLED_SSL_DESC= Use node.js's bundled OpenSSL implementation
-BUNDLED_SSL_USES_OFF= ssl
-BUNDLED_SSL_CONFIGURE_OFF= --shared-openssl --openssl-use-def-ca-store
-BUNDLED_SSL_RUN_DEPENDS_OFF= ca_root_nss>=0:security/ca_root_nss
-
-NLS_CONFIGURE_ON= --with-intl=system-icu
-NLS_BUILD_DEPENDS= icu>=69.1:devel/icu
-NLS_LIB_DEPENDS= libicui18n.so:devel/icu
-
-DTRACE_CONFIGURE_ON= --with-dtrace
+OPTIONS_SUB= yes
+BUNDLED_SSL_DESC= Use node.js's bundled OpenSSL implementation
COREPACK_DESC= Build and install corepack package manager
-COREPACK_CONFIGURE_OFF= --without-corepack
-HAS_CONFIGURE= yes
+BUNDLED_SSL_RUN_DEPENDS_OFF= ca_root_nss>=0:security/ca_root_nss
+BUNDLED_SSL_USES_OFF= ssl
+BUNDLED_SSL_CONFIGURE_OFF= --openssl-use-def-ca-store \
+ --shared-openssl
-CONFLICTS_INSTALL= node[0-9][0-9]
+COREPACK_CONFIGURE_OFF= --without-corepack
-CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
- --without-npm \
- --shared-brotli \
- --shared-cares \
- --shared-libuv \
- --shared-nghttp2 \
- --shared-zlib
+DTRACE_CONFIGURE_ON= --with-dtrace
-SHEBANG_FILES= deps/v8/tools/*.py \
- deps/v8/third_party/inspector_protocol/*.py \
- tools/*.py \
- tools/inspector_protocol/*.py
+NLS_BUILD_DEPENDS= icu>=69.1:devel/icu
+NLS_LIB_DEPENDS= libicui18n.so:devel/icu
+NLS_CONFIGURE_ON= --with-intl=system-icu
PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
-REINPLACE_ARGS= -i ''
-MAKE_ENV+= CC.host=${CC} CFLAGS.host="${CFLAGS}" \
- CXX.host=${CXX} CXXFLAGS.host="${CXXFLAGS}" \
- LINK.host=${CXX} LDFLAGS.host="${LDFLAGS}"
-
-BUILD_DEPENDS+= brotli>=1.0.9,1:archivers/brotli \
- c-ares>=1.17.2:dns/c-ares \
- libuv>=1.42.0:devel/libuv \
- libnghttp2>=1.45.1:www/libnghttp2 \
- objdump:devel/binutils
-LIB_DEPENDS+= libbrotlidec.so:archivers/brotli \
- libcares.so:dns/c-ares \
- libuv.so:devel/libuv \
- libnghttp2.so:www/libnghttp2
.include <bsd.port.options.mk>
.if (defined(PPC_ABI) && ${PPC_ABI} == ELFv2) || ${ARCH} == powerpc64le
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-common.gypi
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-common.gypi
.endif
.if ${ARCH} == armv6 || ${ARCH} == armv7
@@ -92,7 +101,7 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-tools_v8__gypfiles_v8.gyp
.endif
.if ${PORT_OPTIONS:MBUNDLED_SSL} && ${ARCH} != amd64
-CONFIGURE_ARGS+=--openssl-no-asm
+CONFIGURE_ARGS+= --openssl-no-asm
.endif
post-patch:
@@ -100,12 +109,12 @@ post-patch:
${WRKSRC}/tools/v8_gypfiles/v8.gyp
post-configure:
- # Post-process Makefile and *.mk files created by node-gyp and remove
- # all occurrences of -I${LOCALBASE}/include. C*FLAGS include this
- # before all -I../deps/* for bundled code. This can cause build
- # breakages if the dependency is installed in ${LOCALBASE}. The
- # USES+=localbase # above will ensure that we pick up includes for real
- # external dependencies.
+# Post-process Makefile and *.mk files created by node-gyp and remove
+# all occurrences of -I${LOCALBASE}/include. C*FLAGS include this
+# before all -I../deps/* for bundled code. This can cause build
+# breakages if the dependency is installed in ${LOCALBASE}. The
+# USES+=localbase # above will ensure that we pick up includes for real
+# external dependencies.
${FIND} ${WRKSRC}/out -type f -print0 \
| ${XARGS} -0 ${REINPLACE_CMD} -e "s|-I${LOCALBASE}/include||g"