aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-04-23 19:07:29 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-05-07 18:38:47 +0000
commit9d2bf7ac7fa5d5cfb5a1aea086de8ba40e773f8c (patch)
treef7e0fd1a37ff8ef8147da79c22e14a3ea8fff5cb
parentbda00852389edd6ae3bb940fa5dff08f3042e255 (diff)
downloadports-9d2bf7ac7fa5d5cfb5a1aea086de8ba40e773f8c.tar.gz
ports-9d2bf7ac7fa5d5cfb5a1aea086de8ba40e773f8c.zip
textproc/html2text: fix build with clang 16
Since clang 16 (and gcc 11) the default C++ standard is now gnu++17. Because textproc/html2text's Makefile does not explicitly set its C++ standard, this leads to several errors: /usr/local/lib/bison.cc:429:3: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register int yystate; ^~~~~~~~~ /usr/local/lib/bison.cc:430:3: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register int yyn; ^~~~~~~~~ /usr/local/lib/bison.cc:431:3: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register short *yyssp; ^~~~~~~~~ /usr/local/lib/bison.cc:432:3: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register YY_HTMLParser_STYPE *yyvsp; ^~~~~~~~~ Add USE_CXXSTD=gnu++98 to avoid these errors. PR: 271031 Approved by: maintainer timeout (2 weeks) MFH: 2023Q2
-rw-r--r--textproc/html2text/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/textproc/html2text/Makefile b/textproc/html2text/Makefile
index 394feb4b7524..8a53e2dab50d 100644
--- a/textproc/html2text/Makefile
+++ b/textproc/html2text/Makefile
@@ -1,5 +1,6 @@
PORTNAME= html2text
PORTVERSION= 1.3.2a
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= textproc
MASTER_SITES= SUNSITE/apps/www/converters \
@@ -13,6 +14,7 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
HAS_CONFIGURE= yes
+USE_CXXSTD= gnu++98
PORTDOCS= CHANGES CREDITS KNOWN_BUGS README TODO
PLIST_FILES= bin/html2text man/man1/html2text.1.gz man/man5/html2textrc.5.gz