aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-04-12 13:01:45 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-04-12 16:00:27 +0000
commit9d4a2bfa624891b509f0ee0fdfcbbc396fbc1bd9 (patch)
tree4e11ba45bdf275e3977570f70af1eacb62816693
parent097f8a341d39f789bc1790a37cbf8b367a4bea0a (diff)
downloadports-9d4a2bfa624891b509f0ee0fdfcbbc396fbc1bd9.tar.gz
ports-9d4a2bfa624891b509f0ee0fdfcbbc396fbc1bd9.zip
devel/liberasurecode: update to 1.6.3
- take over maintainership of this unmaintained port - add a DOCS option - add a non-default SIMD option for adapting the binary to the CPU - patch out -Werror more thoroughly Changelog: https://github.com/openstack/liberasurecode/blob/master/ChangeLog PR: 263241
-rw-r--r--devel/liberasurecode/Makefile17
-rw-r--r--devel/liberasurecode/distinfo6
-rw-r--r--devel/liberasurecode/files/patch-Makefile.am11
-rw-r--r--devel/liberasurecode/files/patch-doc_Makefile.am10
-rw-r--r--devel/liberasurecode/files/patch-src_Makefile.am11
-rw-r--r--devel/liberasurecode/files/patch-test_Makefile.am6
-rw-r--r--devel/liberasurecode/files/patch-test_builtin_rs__vand_liberasurecode__rs__vand__test.c6
-rw-r--r--devel/liberasurecode/pkg-plist3
8 files changed, 44 insertions, 26 deletions
diff --git a/devel/liberasurecode/Makefile b/devel/liberasurecode/Makefile
index 327599b5854e..8d791b60c563 100644
--- a/devel/liberasurecode/Makefile
+++ b/devel/liberasurecode/Makefile
@@ -1,18 +1,17 @@
# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
PORTNAME= liberasurecode
-PORTVERSION= 1.4.0
+PORTVERSION= 1.6.3
CATEGORIES= devel
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= fuz@fuz.su
COMMENT= Unified Erasure Coding interface for common storage workloads
LICENSE= BSD2CLAUSE
+USES= gmake pkgconfig autoreconf libtool
USE_GITHUB= yes
GH_ACCOUNT= openstack
-
-USES= gmake pkgconfig autoreconf libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
@@ -20,4 +19,14 @@ CONFIGURE_ARGS= --with-pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
TEST_TARGET= test
+CFLAGS_amd64= -DINTEL_SSE2
+
+# documentation file names vary depending on architecture
+PORTDOCS= html
+
+OPTIONS_DEFINE= DOCS SIMD
+DOCS_CONFIGURE_ENABLE= doxygen
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
+SIMD_CONFIGURE_ENABLE= mmi
+
.include <bsd.port.mk>
diff --git a/devel/liberasurecode/distinfo b/devel/liberasurecode/distinfo
index f195764e28e5..d76993b00dda 100644
--- a/devel/liberasurecode/distinfo
+++ b/devel/liberasurecode/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1491476820
-SHA256 (openstack-liberasurecode-1.4.0_GH0.tar.gz) = 71b3ed74147a042c6fa857261269bd348979ee28256156ce5ac045f30f2035cc
-SIZE (openstack-liberasurecode-1.4.0_GH0.tar.gz) = 206187
+TIMESTAMP = 1649694909
+SHA256 (openstack-liberasurecode-1.6.3_GH0.tar.gz) = 8c1afa0a4d5f4909ae864a5d00381b963b4a179364ba591611ceb634c3c9eb99
+SIZE (openstack-liberasurecode-1.6.3_GH0.tar.gz) = 210599
diff --git a/devel/liberasurecode/files/patch-Makefile.am b/devel/liberasurecode/files/patch-Makefile.am
new file mode 100644
index 000000000000..3c1f0b30195c
--- /dev/null
+++ b/devel/liberasurecode/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am.orig 2022-04-08 23:59:40 UTC
++++ Makefile.am
+@@ -8,7 +8,7 @@ INCLUDE = -I$(abs_top_builddir)/include \
+ -I$(abs_top_builddir)/include/xor_codes
+
+ AM_CPPFLAGS = $(CPPFLAGS) $(INCLUDE)
+-AM_CPPFLAGS += -Werror -Wall
++AM_CPPFLAGS += -Wall
+
+ AM_CFLAGS = -fPIC $(AM_CPPFLAGS) @GCOV_FLAGS@ -L/usr/local/lib
+
diff --git a/devel/liberasurecode/files/patch-doc_Makefile.am b/devel/liberasurecode/files/patch-doc_Makefile.am
new file mode 100644
index 000000000000..c86697289992
--- /dev/null
+++ b/devel/liberasurecode/files/patch-doc_Makefile.am
@@ -0,0 +1,10 @@
+--- doc/Makefile.am.orig 2022-04-12 08:07:13 UTC
++++ doc/Makefile.am
+@@ -1,5 +1,5 @@
+ DOC_MODULE=@PACKAGE@
+-HTML_DIR=$(datadir)/$(DOC_MODULE)/html
++HTML_DIR=$(docdir)/html
+-TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
++TARGET_DIR=$(HTML_DIR)
+
+ all-local: html/index.html
diff --git a/devel/liberasurecode/files/patch-src_Makefile.am b/devel/liberasurecode/files/patch-src_Makefile.am
deleted file mode 100644
index a84827e7e604..000000000000
--- a/devel/liberasurecode/files/patch-src_Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.am.orig 2017-04-14 13:42:39 UTC
-+++ src/Makefile.am
-@@ -28,7 +28,7 @@ liberasurecode_la_SOURCES = \
- builtin/rs_vand/rs_galois.c \
- backends/shss/shss.c
-
--liberasurecode_la_CPPFLAGS = -Werror @GCOV_FLAGS@
-+liberasurecode_la_CPPFLAGS = @GCOV_FLAGS@
- liberasurecode_la_LIBADD = \
- builtin/null_code/libnullcode.la -lpthread -lm @GCOV_LDFLAGS@ \
- builtin/xor_codes/libXorcode.la -lpthread -lm @GCOV_LDFLAGS@ \
diff --git a/devel/liberasurecode/files/patch-test_Makefile.am b/devel/liberasurecode/files/patch-test_Makefile.am
index c1b20b8292aa..b0a361639c31 100644
--- a/devel/liberasurecode/files/patch-test_Makefile.am
+++ b/devel/liberasurecode/files/patch-test_Makefile.am
@@ -1,4 +1,4 @@
---- test/Makefile.am.orig 2017-04-06 11:15:44 UTC
+--- test/Makefile.am.orig 2022-04-08 23:59:40 UTC
+++ test/Makefile.am
@@ -5,22 +5,22 @@ test_xor_hd_code_SOURCES = \
builtin/xor_codes/test_xor_hd_code.c \
@@ -16,8 +16,8 @@
liberasurecode_test_SOURCES = liberasurecode_test.c
liberasurecode_test_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/include/erasurecode @GCOV_FLAGS@
--liberasurecode_test_LDFLAGS = @GCOV_LDFLAGS@ $(top_builddir)/src/liberasurecode.la -ldl -lpthread
-+liberasurecode_test_LDFLAGS = @GCOV_LDFLAGS@ $(top_builddir)/src/liberasurecode.la -lpthread
+-liberasurecode_test_LDFLAGS = @GCOV_LDFLAGS@ $(top_builddir)/src/liberasurecode.la -ldl -lpthread -lz
++liberasurecode_test_LDFLAGS = @GCOV_LDFLAGS@ $(top_builddir)/src/liberasurecode.la -lpthread -lz
check_PROGRAMS += liberasurecode_test
libec_slap_SOURCES = libec_slap.c
diff --git a/devel/liberasurecode/files/patch-test_builtin_rs__vand_liberasurecode__rs__vand__test.c b/devel/liberasurecode/files/patch-test_builtin_rs__vand_liberasurecode__rs__vand__test.c
index 243ba4b772da..f77767ddc48e 100644
--- a/devel/liberasurecode/files/patch-test_builtin_rs__vand_liberasurecode__rs__vand__test.c
+++ b/devel/liberasurecode/files/patch-test_builtin_rs__vand_liberasurecode__rs__vand__test.c
@@ -1,8 +1,8 @@
---- test/builtin/rs_vand/liberasurecode_rs_vand_test.c.orig 2017-04-06 11:14:01 UTC
+--- test/builtin/rs_vand/liberasurecode_rs_vand_test.c.orig 2022-04-08 23:59:40 UTC
+++ test/builtin/rs_vand/liberasurecode_rs_vand_test.c
-@@ -32,6 +32,10 @@
- #include <time.h>
+@@ -33,6 +33,10 @@
#include <liberasurecode_rs_vand.h>
+ #include <sys/stat.h>
+#ifdef __FreeBSD__
+#include <sys/stat.h>
diff --git a/devel/liberasurecode/pkg-plist b/devel/liberasurecode/pkg-plist
index b0753f08ebca..6afa592c4d38 100644
--- a/devel/liberasurecode/pkg-plist
+++ b/devel/liberasurecode/pkg-plist
@@ -26,7 +26,7 @@ lib/libXorcode.so.1.0.1
lib/liberasurecode.a
lib/liberasurecode.so
lib/liberasurecode.so.1
-lib/liberasurecode.so.1.4.0
+lib/liberasurecode.so.1.6.3
lib/liberasurecode_rs_vand.a
lib/liberasurecode_rs_vand.so
lib/liberasurecode_rs_vand.so.1
@@ -36,4 +36,3 @@ lib/libnullcode.so
lib/libnullcode.so.1
lib/libnullcode.so.1.0.1
libdata/pkgconfig/erasurecode-1.pc
-@dir %%DATADIR%%/html/liberasurecode