aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-13 00:02:29 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-13 00:02:29 +0000
commita637a846278661ef4204419583e4233a77a8456e (patch)
treef2c9b92b92891f7e0cb521e6c858a281e729f749
parent4e0db8a7406485b81659c9b26b0629756faecc15 (diff)
downloadports-a637a846278661ef4204419583e4233a77a8456e.tar.gz
ports-a637a846278661ef4204419583e4233a77a8456e.zip
devel/thrust: fix build without libomp
CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage CMake Error at /usr/local/share/cmake/Modules/FindOpenMP.cmake:261 (try_compile): Failed to configure test project build system. Call Stack (most recent call first): /usr/local/share/cmake/Modules/FindOpenMP.cmake:537 (_OPENMP_GET_FLAGS) CMakeLists.txt:305 (find_package)
-rw-r--r--devel/thrust/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/devel/thrust/Makefile b/devel/thrust/Makefile
index 309249d911c5..8d531b5ed043 100644
--- a/devel/thrust/Makefile
+++ b/devel/thrust/Makefile
@@ -10,6 +10,9 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake
+.if !exists(/usr/include/omp.h)
+USES+= compiler:gcc-c++11-lib
+.endif
USE_GITHUB= yes
NO_ARCH= yes