aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-08-15 06:37:48 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-08-15 06:37:52 +0000
commitac064f0542689d9c4ff6ca58c046a60d93129305 (patch)
tree9226b3e8128ad2aecb7ee71698e412798efa1368
parent4e043393f374bfd88ba26d65767b48f7c87bd9bc (diff)
downloadports-ac064f0542689d9c4ff6ca58c046a60d93129305.tar.gz
ports-ac064f0542689d9c4ff6ca58c046a60d93129305.zip
x11-toolkits/fltk: update FLTK to version 1.3.7
This release does not contain new ABI features and is 100% binary compatible with releases 1.3.5 and 1.3.6. PR: 254934 Submitted by: yuri
-rw-r--r--x11-toolkits/fltk/Makefile10
-rw-r--r--x11-toolkits/fltk/distinfo6
-rw-r--r--x11-toolkits/fltk/files/patch-CMake_macros.cmake14
-rw-r--r--x11-toolkits/fltk/files/patch-test_CMakeLists.txt34
-rw-r--r--x11-toolkits/fltk/files/patch-test_Makefile37
-rw-r--r--x11-toolkits/fltk/files/patch-test_demo.menu11
-rw-r--r--x11-toolkits/fltk/files/patch-test_help__dialog.cxx18
7 files changed, 4 insertions, 126 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index 0d8907edadf8..b94be22433a3 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -1,8 +1,7 @@
# Created by: Dima Sivachenko <dima@Chg.RU>
PORTNAME= fltk
-PORTVERSION= 1.3.5
-PORTREVISION= 1
+PORTVERSION= 1.3.7
CATEGORIES= x11-toolkits
MASTER_SITES= https://www.fltk.org/pub/${PORTNAME}/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -30,10 +29,6 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= EXAMPLES
-post-extract:
- @${MV} ${WRKSRC}/test/help.cxx ${WRKSRC}/test/help_dialog.cxx
- @${MV} ${WRKSRC}/test/help-test.html ${WRKSRC}/test/help_dialog.html
-
post-patch: .SILENT
prefix="${PREFIX}" ; plength=$$(($${#prefix}+10)) ; \
${REINPLACE_CMD} -e "\|/etc/fltk|{s||${PREFIX}&|;s|10|$${plength}|;}" \
@@ -42,9 +37,6 @@ post-patch: .SILENT
${WRKSRC}/test/Makefile
${REINPLACE_CMD} -e '/^INSTALL_BIN/s,-m,${STRIP} &, ; \
s,^\.SILENT,#&,' ${WRKSRC}/makeinclude.in
- ${REINPLACE_CMD} -E \
- 's,(.*)LDFLAGS(.*)LINKSHARED(.*),\1LINKSHARED\2LDFLAGS\3,' \
- ${WRKSRC}/fluid/Makefile
post-install:
.for x in fltk fltk_forms fltk_gl fltk_images
diff --git a/x11-toolkits/fltk/distinfo b/x11-toolkits/fltk/distinfo
index 887f4dbd7963..0711b72c8bf4 100644
--- a/x11-toolkits/fltk/distinfo
+++ b/x11-toolkits/fltk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1551605094
-SHA256 (fltk-1.3.5-source.tar.bz2) = 2933c72400f9e7c0f4c3a81a1ce98bc9582b2a3edc44b8597ccd26e240e32c3c
-SIZE (fltk-1.3.5-source.tar.bz2) = 4497531
+TIMESTAMP = 1627221460
+SHA256 (fltk-1.3.7-source.tar.bz2) = 5ff1e90766ff4216e78e9a19a9bf527e6258f04accccd4429e9bb829b01d690d
+SIZE (fltk-1.3.7-source.tar.bz2) = 4571092
diff --git a/x11-toolkits/fltk/files/patch-CMake_macros.cmake b/x11-toolkits/fltk/files/patch-CMake_macros.cmake
deleted file mode 100644
index 226b7405afcb..000000000000
--- a/x11-toolkits/fltk/files/patch-CMake_macros.cmake
+++ /dev/null
@@ -1,14 +0,0 @@
---- CMake/macros.cmake.orig 2019-03-03 08:40:23 UTC
-+++ CMake/macros.cmake
-@@ -90,11 +90,6 @@ function(CREATE_EXAMPLE NAME SOURCES LIBRARIES)
-
- set (tname ${NAME}) # target name
-
-- # rename reserved target name "help" (CMake 2.8.12 and later)
-- if (${tname} MATCHES "^help$")
-- set (tname "test_help")
-- endif (${tname} MATCHES "^help$")
--
- foreach(src ${SOURCES})
- if ("${src}" MATCHES "\\.fl$")
- list(APPEND flsrcs ${src})
diff --git a/x11-toolkits/fltk/files/patch-test_CMakeLists.txt b/x11-toolkits/fltk/files/patch-test_CMakeLists.txt
deleted file mode 100644
index 93ad8414aa74..000000000000
--- a/x11-toolkits/fltk/files/patch-test_CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
---- test/CMakeLists.txt.orig 2019-03-03 08:40:23 UTC
-+++ test/CMakeLists.txt
-@@ -64,7 +64,7 @@ CREATE_EXAMPLE(file_chooser file_chooser.cxx "fltk;flt
- CREATE_EXAMPLE(fonts fonts.cxx fltk)
- CREATE_EXAMPLE(forms forms.cxx "fltk;fltk_forms")
- CREATE_EXAMPLE(hello hello.cxx fltk)
--CREATE_EXAMPLE(help help.cxx "fltk;fltk_images")
-+CREATE_EXAMPLE(help_dialog help_dialog.cxx "fltk;fltk_images")
- CREATE_EXAMPLE(icon icon.cxx fltk)
- CREATE_EXAMPLE(iconize iconize.cxx fltk)
- CREATE_EXAMPLE(image image.cxx fltk)
-@@ -134,7 +134,7 @@ endif(FLTK_HAVE_CAIRO)
- # Note: this is incomplete as of 11 Feb 2015
- # Todo: currently all files are copied, but some of them need configuration:
- # - demo.menu: fluid can't be started (wrong path)
--# - demo.menu: help (help-test.html) can't find its images (not copied)
-+# - demo.menu: help_dialog (help_dialog.html) can't find its images (not copied)
- # - maybe more ...
-
- # prepare for a "better" test file installation path
-@@ -149,11 +149,11 @@ configure_file(demo.menu ${TESTFILE_PATH}/demo.menu CO
-
- # use target directory only to avoid redundancy
- configure_file(rgb.txt ${TESTFILE_PATH} COPYONLY)
--configure_file(help-test.html ${TESTFILE_PATH} COPYONLY)
-+configure_file(help_dialog.html ${TESTFILE_PATH} COPYONLY)
- configure_file(browser.cxx ${TESTFILE_PATH} COPYONLY)
- configure_file(editor.cxx ${TESTFILE_PATH} COPYONLY)
- if(APPLE AND NOT OPTION_APPLE_X11)
- configure_file(browser.cxx "${TESTFILE_PATH}/browser.app/Contents/Resources/browser.cxx" COPYONLY)
- configure_file(rgb.txt ${TESTFILE_PATH}/colbrowser.app/Contents/Resources/rgb.txt COPYONLY)
-- configure_file(help-test.html ${TESTFILE_PATH}/help.app/Contents/Resources/help-test.html COPYONLY)
-+ configure_file(help_dialog.html ${TESTFILE_PATH}/help_dialog.app/Contents/Resources/help_dialog.html COPYONLY)
- endif(APPLE AND NOT OPTION_APPLE_X11)
diff --git a/x11-toolkits/fltk/files/patch-test_Makefile b/x11-toolkits/fltk/files/patch-test_Makefile
deleted file mode 100644
index 9ac59b2ee483..000000000000
--- a/x11-toolkits/fltk/files/patch-test_Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
---- test/Makefile.orig 2019-03-03 08:40:23 UTC
-+++ test/Makefile
-@@ -53,7 +53,7 @@ CPPFILES =\
- gl_overlay.cxx \
- glpuzzle.cxx \
- hello.cxx \
-- help.cxx \
-+ help_dialog.cxx \
- icon.cxx \
- iconize.cxx \
- image.cxx \
-@@ -126,7 +126,7 @@ ALL = \
- fonts$(EXEEXT) \
- forms$(EXEEXT) \
- hello$(EXEEXT) \
-- help$(EXEEXT) \
-+ help_dialog$(EXEEXT) \
- icon$(EXEEXT) \
- iconize$(EXEEXT) \
- image$(EXEEXT) \
-@@ -372,12 +372,12 @@ forms$(EXEEXT): forms.o
-
- hello$(EXEEXT): hello.o
-
--help$(EXEEXT): help.o $(IMGLIBNAME)
-+help_dialog$(EXEEXT): help_dialog.o $(IMGLIBNAME)
- echo Linking $@...
-- $(CXX) $(ARCHFLAGS) $(CXXFLAGS) $(LDFLAGS) help.o -o $@ $(LINKFLTKIMG) $(LDLIBS)
-+ $(CXX) $(ARCHFLAGS) $(CXXFLAGS) $(LDFLAGS) help_dialog.o -o $@ $(LINKFLTKIMG) $(LDLIBS)
- $(OSX_ONLY) ../fltk-config --post $@
-- $(OSX_ONLY) mkdir -p help.app/Contents/Resources
-- $(OSX_ONLY) cp -f help-test.html help.app/Contents/Resources/
-+ $(OSX_ONLY) mkdir -p help_dialog.app/Contents/Resources
-+ $(OSX_ONLY) cp -f help_dialog.html help_dialog.app/Contents/Resources/
-
- icon$(EXEEXT): icon.o
-
diff --git a/x11-toolkits/fltk/files/patch-test_demo.menu b/x11-toolkits/fltk/files/patch-test_demo.menu
deleted file mode 100644
index 24f5037dda31..000000000000
--- a/x11-toolkits/fltk/files/patch-test_demo.menu
+++ /dev/null
@@ -1,11 +0,0 @@
---- test/demo.menu.orig 2019-03-03 08:40:23 UTC
-+++ test/demo.menu
-@@ -77,7 +77,7 @@
- @o:Font Tests...:@of
- @of:Fonts:fonts
- @of:UTF-8:utf8
-- @o:HelpDialog:help
-+ @o:HelpDialog:help_dialog
- @o:Input Choice:input_choice
- @o:Preferences:preferences
- @o:Threading:threads
diff --git a/x11-toolkits/fltk/files/patch-test_help__dialog.cxx b/x11-toolkits/fltk/files/patch-test_help__dialog.cxx
deleted file mode 100644
index 4a9a603a16e7..000000000000
--- a/x11-toolkits/fltk/files/patch-test_help__dialog.cxx
+++ /dev/null
@@ -1,18 +0,0 @@
---- test/help_dialog.cxx.orig 2019-03-03 08:40:23 UTC
-+++ test/help_dialog.cxx
-@@ -46,13 +46,13 @@ main(int argc, // I - Number of command-line argume
- strcpy(buf, argv[0]);
- char *slash = strrchr(buf, '/');
- if (slash)
-- strcpy(slash, "/../Resources/help-test.html");
-+ strcpy(slash, "/../Resources/help_dialog.html");
- help->load(buf);
-
- #else
-
- if (argc <= 1)
-- help->load("help-test.html");
-+ help->load("help_dialog.html");
- else
- help->load(argv[1]);
-