aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 03:39:26 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 04:19:04 +0000
commitac5d3e751150add8dffbbdb912c66c35b8fe11b0 (patch)
tree8f847afe7df24ca66c383ed99bdc1ea2fae7be53
parent042bcd8ac40e44a2b5f348a2524a3616610a4dd1 (diff)
downloadports-ac5d3e751150add8dffbbdb912c66c35b8fe11b0.tar.gz
ports-ac5d3e751150add8dffbbdb912c66c35b8fe11b0.zip
security/py-pyhanko-certvalidator: Add py-pyhanko-certvalidator 0.19.4
pyhanko-certvalidator is a Python library for validating X.509 certificates paths. It supports various options, including: validation at a specific moment in time, whitelisting and revocation checks. This library started as a fork of wbond/certvalidator with patches for pyHanko, but has since diverged considerably from its parent repository. WWW: https://github.com/MatthiasValvekens/certvalidator
-rw-r--r--security/Makefile1
-rw-r--r--security/py-pyhanko-certvalidator/Makefile26
-rw-r--r--security/py-pyhanko-certvalidator/distinfo3
-rw-r--r--security/py-pyhanko-certvalidator/pkg-descr8
4 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ea1be53cfb77..bfd4a85b4537 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -930,6 +930,7 @@
SUBDIR += py-pycryptodome
SUBDIR += py-pycryptodomex
SUBDIR += py-pyelliptic
+ SUBDIR += py-pyhanko-certvalidator
SUBDIR += py-pylibacl
SUBDIR += py-pymacaroons
SUBDIR += py-pynacl
diff --git a/security/py-pyhanko-certvalidator/Makefile b/security/py-pyhanko-certvalidator/Makefile
new file mode 100644
index 000000000000..6489ef05cf9f
--- /dev/null
+++ b/security/py-pyhanko-certvalidator/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pyhanko-certvalidator
+PORTVERSION= 0.19.4
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Validates X.509 certificates and paths
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1crypto>=1.2.0:devel/py-asn1crypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=3.3.1:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}oscrypto>=1.1.0:security/py-oscrypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.24.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}uritools>=3.0.1:net/py-uritools@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-pyhanko-certvalidator/distinfo b/security/py-pyhanko-certvalidator/distinfo
new file mode 100644
index 000000000000..d5d31aac07f5
--- /dev/null
+++ b/security/py-pyhanko-certvalidator/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1649423656
+SHA256 (pyhanko-certvalidator-0.19.4.tar.gz) = 7e7ea8dd0ac8864dac7af092c7f8ee3864f3f74e1c2e4228a2e0d8baad7015a3
+SIZE (pyhanko-certvalidator-0.19.4.tar.gz) = 63878
diff --git a/security/py-pyhanko-certvalidator/pkg-descr b/security/py-pyhanko-certvalidator/pkg-descr
new file mode 100644
index 000000000000..bfba517ca718
--- /dev/null
+++ b/security/py-pyhanko-certvalidator/pkg-descr
@@ -0,0 +1,8 @@
+pyhanko-certvalidator is a Python library for validating X.509 certificates
+paths. It supports various options, including: validation at a specific moment
+in time, whitelisting and revocation checks.
+
+This library started as a fork of wbond/certvalidator with patches for pyHanko,
+but has since diverged considerably from its parent repository.
+
+WWW: https://github.com/MatthiasValvekens/certvalidator