aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2023-04-05 20:06:17 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2023-04-05 20:06:17 +0000
commitacb81ef79946a6697deee901c35ad72769fed1bd (patch)
treedeeb24819aedd1e3d63434e414b0524687813543
parent08e811b21810363333719a62794f035c0dab73c9 (diff)
new port: security/cpfx
PFX decoder for CryptoPro GOST R 34.10-2012 implementation
-rw-r--r--security/Makefile1
-rw-r--r--security/cpfx/Makefile33
-rw-r--r--security/cpfx/distinfo3
-rw-r--r--security/cpfx/pkg-descr3
4 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 88021d3ad285..d8b4ed292fc5 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -99,6 +99,7 @@
SUBDIR += courierpasswd
SUBDIR += courieruserinfo
SUBDIR += cowrie
+ SUBDIR += cpfx
SUBDIR += cracklib
SUBDIR += crackpkcs12
SUBDIR += create-cert
diff --git a/security/cpfx/Makefile b/security/cpfx/Makefile
new file mode 100644
index 000000000000..7fa15113dba9
--- /dev/null
+++ b/security/cpfx/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= cpfx
+DISTVERSION= g20221025
+CATEGORIES= security
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= eugen@FreeBSD.org
+COMMENT= PFX decoder for CryptoPro GOST R 34.10-2012 implementation
+WWW= https://github.com/li0ard/cpfx
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=2.6.0:devel/py-asn1@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygost>=5.11:security/py-pygost@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyderasn>=9.3:devel/py-pyderasn@${PY_FLAVOR}
+
+PLIST_FILES= bin/cpfx.py bin/schemas.py
+USES= python
+
+USE_PYTHON= flavors
+USE_GITHUB= yes
+
+GH_ACCOUNT= li0ard
+GH_TAGNAME= 69c3d7d
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+do-install:
+ @cd ${WRKSRC} && \
+ ${REINPLACE_CMD} $$'1s,^,#!${PYTHON_CMD}\\n,' cpfx.py && \
+ ${INSTALL_SCRIPT} cpfx.py schemas.py ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/cpfx/distinfo b/security/cpfx/distinfo
new file mode 100644
index 000000000000..f479bb261449
--- /dev/null
+++ b/security/cpfx/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1680396777
+SHA256 (li0ard-cpfx-g20221025-69c3d7d_GH0.tar.gz) = aa67d827f27d6ffc9384320207c564cc5a0f60c52f0d58c82bce3e81e2d72b4b
+SIZE (li0ard-cpfx-g20221025-69c3d7d_GH0.tar.gz) = 7959
diff --git a/security/cpfx/pkg-descr b/security/cpfx/pkg-descr
new file mode 100644
index 000000000000..550a319b3950
--- /dev/null
+++ b/security/cpfx/pkg-descr
@@ -0,0 +1,3 @@
+PFX decoder for CryptoPro GOST R 34.10-2012 implementation.
+
+No support for deprecated GOST R 34.10-2001.