aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 17:37:45 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 18:26:13 +0000
commitafd72f06bf351bea22af0efc134af69292a0fe61 (patch)
tree1b4ff2245bc8c899f3e62cd891d02fee4ee67237
parent83a63a66b6daaa39954b194f9acf18faacee2142 (diff)
downloadports-afd72f06bf351bea22af0efc134af69292a0fe61.tar.gz
ports-afd72f06bf351bea22af0efc134af69292a0fe61.zip
mail/avenger: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--mail/avenger/Makefile28
1 files changed, 15 insertions, 13 deletions
diff --git a/mail/avenger/Makefile b/mail/avenger/Makefile
index 6d7a086be8ec..2a00e3d27f0f 100644
--- a/mail/avenger/Makefile
+++ b/mail/avenger/Makefile
@@ -11,34 +11,40 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
USES= bdb ssl
+USE_CXXSTD= c++14
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-ssl=${OPENSSLBASE} \
+ --with-db=${LOCALBASE} \
+ --with-etcdir=${ETCDIR}
+CONFIGURE_ENV= WFLAGS='-Wall'
+
+# Fix build with clang11
+CFLAGS+= -fcommon
CONFLICTS_INSTALL= mailutils # bin/dotlock
+SUB_FILES= pkg-message
+
USERS= ${PORTNAME}
GROUPS= ${USERS}
PORTDOCS= INSTALL INSTALL.html README NEWS
-SUB_FILES= pkg-message
-
-CONFIGURE_ENV= WFLAGS='-Wall'
-CONFIGURE_ARGS= --enable-ssl=${OPENSSLBASE} \
- --with-db=${LOCALBASE} \
- --with-etcdir=${ETCDIR}
-# Fix build with clang11
-CFLAGS+= -fcommon
OPTIONS_DEFINE= DOCS SASL
-SASL_CONFIGURE_ENABLE= sasl
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
+SASL_CONFIGURE_ENABLE= sasl
post-patch:
@${REINPLACE_CMD} -e \
'/for vers in/s|5.*;|${BDB_LIB_NAME:S,db-,,};|' \
${WRKSRC}/configure
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
post-install:
@${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/etc/asmtpd.conf \
@@ -51,8 +57,4 @@ post-install:
(cd ${WRKSRC}/etc ; ${INSTALL_DATA} smtp-filter.pf avsendmail.m4 \
${STAGEDIR}${DATADIR})
-do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-
.include <bsd.port.mk>