aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg A. Mamontov <oleg@mamontov.net>2023-08-30 21:01:43 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-10 16:13:02 +0000
commitb33d841b2e25772ccdaa789ea455c0b636156b57 (patch)
treedc21d486390d6d7ba9499e0044236988716773ab
parent42c6d0e54ad9bd941e0b805cab7f70af83139806 (diff)
downloadports-b33d841b2e25772ccdaa789ea455c0b636156b57.tar.gz
ports-b33d841b2e25772ccdaa789ea455c0b636156b57.zip
www/angie-module-vod: VOD dynamic module for Angie
Module allows on-the-fly repackaging of MP4 files to DASH, HDS, HLS, MSS. It provides following working modes: - local: serve locally accessible files (local disk/NFS mounted) - remote: serve files accessible via HTTP using range requests - mapped - serve files according to a specification encoded in JSON format PR: 273462
-rw-r--r--www/Makefile1
-rw-r--r--www/angie-module-vod/Makefile25
-rw-r--r--www/angie-module-vod/files/pkg-message.in15
-rw-r--r--www/angie-module-vod/pkg-descr5
-rw-r--r--www/angie-module-vod/pkg-plist3
5 files changed, 49 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5033ea3047ad..e80e38732953 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -48,6 +48,7 @@
SUBDIR += angie-module-set-misc
SUBDIR += angie-module-subs
SUBDIR += angie-module-upload
+ SUBDIR += angie-module-vod
SUBDIR += angie-module-xslt
SUBDIR += anyremote2html
SUBDIR += apache-mode.el
diff --git a/www/angie-module-vod/Makefile b/www/angie-module-vod/Makefile
new file mode 100644
index 000000000000..36b0743905c7
--- /dev/null
+++ b/www/angie-module-vod/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= angie-module-vod
+GH_TUPLE= kaltura:nginx-vod-module:1.31:module
+
+COMMENT= VOD dynamic module for Angie
+
+LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
+ libswscale.so:multimedia/ffmpeg
+
+MASTERDIR= ${.CURDIR}/../../www/angie
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_LIB} ${WRKSRC}/objs/ngx_http_vod_module.so \
+ ${STAGEDIR}${MODDIR}
+
+ ${INSTALL_MAN} ${WRKSRC_module}/README.md ${STAGEDIR}${DOCSDIR}
+
+do-install-DEBUG-on:
+ ${INSTALL} ${COPY} -m ${_SHAREMODE} \
+ ${WRKSRC_DEBUG}/objs/ngx_http_vod_module.so \
+ ${STAGEDIR}${MODDIR}/ngx_http_vod_module-debug.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/angie-module-vod/files/pkg-message.in b/www/angie-module-vod/files/pkg-message.in
new file mode 100644
index 000000000000..598333e9a38a
--- /dev/null
+++ b/www/angie-module-vod/files/pkg-message.in
@@ -0,0 +1,15 @@
+[
+{ type: install
+ message: <<EOM
+
+The VOD dynamic module for Angie has been installed.
+To enable this module, add the following to %%PREFIX%%/etc/angie/angie.conf
+and reload angie:
+
+ load_module modules/ngx_http_vod_module.so;
+
+Please refer to the module documentation for further details:
+https://github.com/kaltura/nginx-vod-module
+EOM
+}
+]
diff --git a/www/angie-module-vod/pkg-descr b/www/angie-module-vod/pkg-descr
new file mode 100644
index 000000000000..e164f1cad005
--- /dev/null
+++ b/www/angie-module-vod/pkg-descr
@@ -0,0 +1,5 @@
+Module allows on-the-fly repackaging of MP4 files to DASH, HDS, HLS, MSS.
+It provides following working modes:
+- local: serve locally accessible files (local disk/NFS mounted)
+- remote: serve files accessible via HTTP using range requests
+- mapped - serve files according to a specification encoded in JSON format
diff --git a/www/angie-module-vod/pkg-plist b/www/angie-module-vod/pkg-plist
new file mode 100644
index 000000000000..c753b9e1511c
--- /dev/null
+++ b/www/angie-module-vod/pkg-plist
@@ -0,0 +1,3 @@
+%%DOCSDIR%%/README.md
+%%MODDIR%%/ngx_http_vod_module.so
+%%DEBUG%%%%MODDIR%%/ngx_http_vod_module-debug.so