aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2022-02-23 02:59:04 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-02-23 02:59:04 +0000
commitc1df24f8c4a711b99a922e31b61784306dd72315 (patch)
tree92e224cffbefc103b97edbefb2b87eb01533fd01
parentce7e2f4d8b47c06bb69828614583928a5b88eef4 (diff)
downloadports-c1df24f8c4a711b99a922e31b61784306dd72315.tar.gz
ports-c1df24f8c4a711b99a922e31b61784306dd72315.zip
security/sssd: Add SMB flavor
PR: 261730 Approved by: maintainer timeout (2+ weeks)
-rw-r--r--security/sssd/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/security/sssd/Makefile b/security/sssd/Makefile
index b3676d1de8b8..3e6f3d311f3a 100644
--- a/security/sssd/Makefile
+++ b/security/sssd/Makefile
@@ -33,6 +33,10 @@ BUILD_DEPENDS= xmlcatalog:textproc/libxml2 \
krb5>=1.10:security/krb5 \
nsupdate:dns/bind-tools
+FLAVORS= default smb
+FLAVOR?= ${FLAVORS:[1]}
+smb_PKGNAMESUFFIX= -smb
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-selinux --without-semanage \
--without-libnl --without-nfsv4-idmapd-plugin \
@@ -83,6 +87,10 @@ SMB_LIB_DEPENDS= libndr-nbt.so.0:net/samba412 \
libsamba-util.so.0:net/samba412 \
libsmbclient.so.0:net/samba412
+.if ${FLAVOR} == smb
+OPTIONS_DEFAULT+= SMB
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|NSS_STATUS_NOTFOUND|NS_NOTFOUND|g' \
-e 's|NSS_STATUS_UNAVAIL|NS_UNAVAIL|g' \