aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/sssd/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/security/sssd/Makefile b/security/sssd/Makefile
index b3676d1de8b8..3e6f3d311f3a 100644
--- a/security/sssd/Makefile
+++ b/security/sssd/Makefile
@@ -33,6 +33,10 @@ BUILD_DEPENDS= xmlcatalog:textproc/libxml2 \
krb5>=1.10:security/krb5 \
nsupdate:dns/bind-tools
+FLAVORS= default smb
+FLAVOR?= ${FLAVORS:[1]}
+smb_PKGNAMESUFFIX= -smb
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-selinux --without-semanage \
--without-libnl --without-nfsv4-idmapd-plugin \
@@ -83,6 +87,10 @@ SMB_LIB_DEPENDS= libndr-nbt.so.0:net/samba412 \
libsamba-util.so.0:net/samba412 \
libsmbclient.so.0:net/samba412
+.if ${FLAVOR} == smb
+OPTIONS_DEFAULT+= SMB
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|NSS_STATUS_NOTFOUND|NS_NOTFOUND|g' \
-e 's|NSS_STATUS_UNAVAIL|NS_UNAVAIL|g' \