aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 19:58:09 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 19:58:09 +0000
commitc917dfab31a0888bab1860150a3a32434fc7b67b (patch)
treed077a72d41981662619534c7f91109b294cc297b
parentd691c243fbfecc1e1341c5e50d1dedf9c0139a7a (diff)
downloadports-c917dfab31a0888bab1860150a3a32434fc7b67b.tar.gz
ports-c917dfab31a0888bab1860150a3a32434fc7b67b.zip
Add py-libpysal 4.3.0
Python Spatial Analysis Library Core libpysal offers four modules that form the building blocks in many upstream packages in the PySAL family: - Spatial Weights: libpysal.weights - Input-and output: libpysal.io - Computational geometry: libpysal.cg - Built-in example datasets libpysal.examples WWW: https://pysal.org/libpysal/ WWW: https://github.com/pysal/libpysal
Notes
Notes: svn path=/head/; revision=560053
-rw-r--r--science/Makefile1
-rw-r--r--science/py-libpysal/Makefile29
-rw-r--r--science/py-libpysal/distinfo3
-rw-r--r--science/py-libpysal/pkg-descr11
4 files changed, 44 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 7ea569db6285..4a04bf2a4844 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -248,6 +248,7 @@
SUBDIR += py-kinematics
SUBDIR += py-kliff
SUBDIR += py-liac-arff
+ SUBDIR += py-libpysal
SUBDIR += py-lifelines
SUBDIR += py-mdp
SUBDIR += py-mmtf-python
diff --git a/science/py-libpysal/Makefile b/science/py-libpysal/Makefile
new file mode 100644
index 000000000000..de03b9229a3c
--- /dev/null
+++ b/science/py-libpysal/Makefile
@@ -0,0 +1,29 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libpysal
+PORTVERSION= 4.3.0
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Core components of PySAL A library of spatial analysis functions
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.3,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.11:science/py-scipy@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-libpysal/distinfo b/science/py-libpysal/distinfo
new file mode 100644
index 000000000000..42846460d77d
--- /dev/null
+++ b/science/py-libpysal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609598761
+SHA256 (libpysal-4.3.0.tar.gz) = d7cb34aa20f07c93d8f1f12431aa7c6aa9a08b92cc4396022a04fc2086e5d2d7
+SIZE (libpysal-4.3.0.tar.gz) = 2355016
diff --git a/science/py-libpysal/pkg-descr b/science/py-libpysal/pkg-descr
new file mode 100644
index 000000000000..dff943e92236
--- /dev/null
+++ b/science/py-libpysal/pkg-descr
@@ -0,0 +1,11 @@
+Python Spatial Analysis Library Core
+
+libpysal offers four modules that form the building blocks in many upstream
+packages in the PySAL family:
+- Spatial Weights: libpysal.weights
+- Input-and output: libpysal.io
+- Computational geometry: libpysal.cg
+- Built-in example datasets libpysal.examples
+
+WWW: https://pysal.org/libpysal/
+WWW: https://github.com/pysal/libpysal