aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-05-30 14:50:14 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-05-30 14:50:50 +0000
commitca917fbf53d048edd527d7442a09ecb628a26ec8 (patch)
treebd7cf97297d5b432652e8364a35a2020abd64cf9
parentee340a5981cbffb4f0334c33e2495cba10322eb3 (diff)
downloadports-ca917fbf53d048edd527d7442a09ecb628a26ec8.tar.gz
ports-ca917fbf53d048edd527d7442a09ecb628a26ec8.zip
games/openfodder: mark BROKEN on armv[67]
In file included from Source/ScriptingEngine.cpp:24: In file included from ./Source/Utils/dukglue/dukglue.h:3: In file included from ./Source/Utils/dukglue/register_function.h:3: In file included from ./Source/Utils/dukglue/detail_function.h:3: In file included from ./Source/Utils/dukglue/detail_stack.h:6: In file included from ./Source/Utils/dukglue/detail_types.h:160: ./Source/Utils/dukglue/detail_primitive_types.h:52:3: error: redefinition of 'DukType<long long>' DUKGLUE_SIMPLE_VALUE_TYPE(time_t, duk_is_number, duk_get_uint, duk_push_uint, value) ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ./Source/Utils/dukglue/detail_primitive_types.h:17:10: note: expanded from macro 'DUKGLUE_SIMPLE_VALUE_TYPE' struct DukType<TYPE> { \ ^~~~~~~~~~~~~ ./Source/Utils/dukglue/detail_primitive_types.h:46:3: note: previous definition is here DUKGLUE_SIMPLE_VALUE_TYPE(int64_t, duk_is_number, duk_get_number, duk_push_number, value) // have to cast to double ^ ./Source/Utils/dukglue/detail_primitive_types.h:17:10: note: expanded from macro 'DUKGLUE_SIMPLE_VALUE_TYPE' struct DukType<TYPE> { \ ^ Reported by: pkg-fallout
-rw-r--r--games/openfodder/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/openfodder/Makefile b/games/openfodder/Makefile
index d45ca7f913ba..48c844c73d89 100644
--- a/games/openfodder/Makefile
+++ b/games/openfodder/Makefile
@@ -14,6 +14,9 @@ LICENSE_FILE_LGPL21+ = ${WRKSRC}/COPYING.LGPLv2.1.txt
LICENSE_FILE_MIT= ${WRKSRC}/COPYING.MIT.txt
LICENSE_FILE_ZLIB= ${WRKSRC}/COPYING.ZLIB.txt
+BROKEN_armv6= https://github.com/OpenFodder/openfodder/issues/89
+BROKEN_armv7= https://github.com/OpenFodder/openfodder/issues/89
+
USES= compiler:c++14-lang sdl
USE_GITHUB= yes
USE_SDL= mixer2