aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:12:52 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:05 +0000
commitcc65b56368c50c4e560bcb56ea5088688efef245 (patch)
tree140b70595ec9e895048b67a937abd05c8f80bf40
parente0bab44c0245be5c46717f8342f652b6f0a27380 (diff)
downloadports-cc65b56368c50c4e560bcb56ea5088688efef245.tar.gz
ports-cc65b56368c50c4e560bcb56ea5088688efef245.zip
devel/py-preshed3: Add py-preshed3 3.0.9
preshed provides simple but high performance Cython hash table mapping pre-randomized keys to void* values.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-preshed3/Makefile30
-rw-r--r--devel/py-preshed3/distinfo3
-rw-r--r--devel/py-preshed3/pkg-descr2
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4c50a5c732c7..61aca300f71b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5256,6 +5256,7 @@
SUBDIR += py-pre-commit-hooks
SUBDIR += py-prefixed
SUBDIR += py-preshed
+ SUBDIR += py-preshed3
SUBDIR += py-pretend
SUBDIR += py-prettyprinter
SUBDIR += py-prettytable
diff --git a/devel/py-preshed3/Makefile b/devel/py-preshed3/Makefile
new file mode 100644
index 000000000000..a74d2cfe1be1
--- /dev/null
+++ b/devel/py-preshed3/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= preshed
+PORTVERSION= 3.0.9
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 3
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Cython hash table that trusts the keys are pre-hashed
+WWW= https://github.com/explosion/preshed
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cymem>=2.0.2<2.1.0:devel/py-cymem@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}murmurhash>=0.28.0<1.1.0:devel/py-murmurhash@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cymem>=2.0.2<2.1.0:devel/py-cymem@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}murmurhash>=0.28.0<1.1.0:devel/py-murmurhash@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent cython pep517
+
+PORTSCOUT= limit^3\.
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/devel/py-preshed3/distinfo b/devel/py-preshed3/distinfo
new file mode 100644
index 000000000000..10de27050c44
--- /dev/null
+++ b/devel/py-preshed3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1703703076
+SHA256 (preshed-3.0.9.tar.gz) = 721863c5244ffcd2651ad0928951a2c7c77b102f4e11a251ad85d37ee7621660
+SIZE (preshed-3.0.9.tar.gz) = 14478
diff --git a/devel/py-preshed3/pkg-descr b/devel/py-preshed3/pkg-descr
new file mode 100644
index 000000000000..747ce50a4f19
--- /dev/null
+++ b/devel/py-preshed3/pkg-descr
@@ -0,0 +1,2 @@
+preshed provides simple but high performance Cython hash table mapping
+pre-randomized keys to void* values.