aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:48:30 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:21 +0000
commitcde90c30cba1af8999ec9eb0352d01f5de902ce7 (patch)
tree05af3769544ce211236bcc4b6a27fabdc7d87760
parent4e5ce2aec65d4fa762aec0d688660b1ec0603c29 (diff)
downloadports-cde90c30cba1af8999ec9eb0352d01f5de902ce7.tar.gz
ports-cde90c30cba1af8999ec9eb0352d01f5de902ce7.zip
textproc/py-mistune: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--textproc/py-mistune/Makefile9
-rw-r--r--textproc/py-mistune/files/setup.py3
2 files changed, 5 insertions, 7 deletions
diff --git a/textproc/py-mistune/Makefile b/textproc/py-mistune/Makefile
index ca1c6807f220..a52d4c5bbbc1 100644
--- a/textproc/py-mistune/Makefile
+++ b/textproc/py-mistune/Makefile
@@ -1,5 +1,6 @@
PORTNAME= mistune
PORTVERSION= 2.0.4
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,14 +12,14 @@ WWW= https://github.com/lepture/mistune
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
USES= cpe python:3.6+
-USE_PYTHON= autoplist concurrent distutils unittest
+USE_PYTHON= autoplist concurrent pep517 unittest
NO_ARCH= yes
CPE_VENDOR= mistune_project
-post-patch:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
-
.include <bsd.port.mk>
diff --git a/textproc/py-mistune/files/setup.py b/textproc/py-mistune/files/setup.py
deleted file mode 100644
index 606849326a40..000000000000
--- a/textproc/py-mistune/files/setup.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from setuptools import setup
-
-setup()