aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-05-16 14:03:51 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-05-16 22:19:48 +0000
commitcf87c36466fa256148c17d28a66825746cd1f69f (patch)
treeca16a61b76f0d580309b74a9c30ed8c2f1bf3a2a
parent804ac2395851da1f7e19c986895ebc92277a573e (diff)
downloadports-cf87c36466fa256148c17d28a66825746cd1f69f.tar.gz
ports-cf87c36466fa256148c17d28a66825746cd1f69f.zip
security/botan2: fix build on powerpc64
In file included from src/lib/block/aes/aes_power8/aes_power8.cpp:15: /usr/lib/clang/18/include/altivec.h:17365:10: error: '__builtin_altivec_crypto_vcipher' needs target feature power8-vector 17365 | return __builtin_altivec_crypto_vcipher(__a, __b); | ^
-rw-r--r--security/botan2/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/security/botan2/Makefile b/security/botan2/Makefile
index 231db7ec7a05..a291f1d1961a 100644
--- a/security/botan2/Makefile
+++ b/security/botan2/Makefile
@@ -78,6 +78,9 @@ SQLITE3_CONFIGURE_WITH= sqlite3
CONFIGURE_ARGS+= --cc-abi="-march=armv8-a+crypto"
.elif ${ARCH} == powerpc64
CONFIGURE_ARGS+= --cpu="ppc64"
+.if !defined(MACHINE_CPU) || (defined(MACHINE_CPU) && !${MACHINE_ABI:Mvsx2})
+CONFIGURE_ARGS+= --disable-powercrypto
+.endif
.elif ${ARCH} == powerpc64le
CONFIGURE_ARGS+= --cpu="ppc64le"
.endif