aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-08 20:07:36 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-08 20:16:40 +0000
commitd4396c88fe783f63b37edd9ea1340fc6d8b39c73 (patch)
tree40a27d4718d4a11291f405a326a4e5166bbaa640
parent9e4bbaa48bff12bb0898748c969f37ba7483f01b (diff)
downloadports-d4396c88fe783f63b37edd9ea1340fc6d8b39c73.tar.gz
ports-d4396c88fe783f63b37edd9ea1340fc6d8b39c73.zip
devel/py-hacking: Add py-hacking 6.1.0
hacking is a set of flake8 plugins that test and enforce the OpenStack StyleGuide Hacking pins its dependencies, as a new release of some dependency can break hacking based gating jobs. This is because new versions of dependencies can introduce new rules, or make existing rules stricter.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-hacking/Makefile25
-rw-r--r--devel/py-hacking/distinfo3
-rw-r--r--devel/py-hacking/pkg-descr6
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 500362cdfe56..44f55b8e947f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4821,6 +4821,7 @@
SUBDIR += py-gtfslib
SUBDIR += py-guppy3
SUBDIR += py-gyp
+ SUBDIR += py-hacking
SUBDIR += py-hammett
SUBDIR += py-hash_ring
SUBDIR += py-hatch
diff --git a/devel/py-hacking/Makefile b/devel/py-hacking/Makefile
new file mode 100644
index 000000000000..7ef6fc6b2904
--- /dev/null
+++ b/devel/py-hacking/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= hacking
+PORTVERSION= 6.1.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= OpenStack Hacking Guideline Enforcement
+WWW= https://docs.openstack.org/hacking/latest/ \
+ https://github.com/openstack/hacking
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=2.0.0:devel/py-pbr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flake8>=6.1.0<6.2:devel/py-flake8@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-hacking/distinfo b/devel/py-hacking/distinfo
new file mode 100644
index 000000000000..159c5fb0a299
--- /dev/null
+++ b/devel/py-hacking/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1712580498
+SHA256 (hacking-6.1.0.tar.gz) = de506a3124034e18b4e3a69c95de498c3460bcbc49c1643d3178d15bc6daac14
+SIZE (hacking-6.1.0.tar.gz) = 62587
diff --git a/devel/py-hacking/pkg-descr b/devel/py-hacking/pkg-descr
new file mode 100644
index 000000000000..12d223fe431b
--- /dev/null
+++ b/devel/py-hacking/pkg-descr
@@ -0,0 +1,6 @@
+hacking is a set of flake8 plugins that test and enforce the OpenStack
+StyleGuide
+
+Hacking pins its dependencies, as a new release of some dependency can break
+hacking based gating jobs. This is because new versions of dependencies can
+introduce new rules, or make existing rules stricter.