aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 13:59:00 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 17:42:34 +0000
commitd92c0802eadd8d10118f3237e96de9580a6770bb (patch)
tree1a644a58142f0b04a95e179424ae1a976d7b075b
parent0f960bc918b489abb26ec39db1552d270ffbc1f3 (diff)
downloadports-d92c0802eadd8d10118f3237e96de9580a6770bb.tar.gz
ports-d92c0802eadd8d10118f3237e96de9580a6770bb.zip
biology/canu: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--biology/canu/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/biology/canu/Makefile b/biology/canu/Makefile
index d9b670ebf467..2f352aaf22d8 100644
--- a/biology/canu/Makefile
+++ b/biology/canu/Makefile
@@ -19,16 +19,15 @@ LIB_DEPENDS= libboost_regex.so:devel/boost-libs
RUN_DEPENDS= gnuplot:math/gnuplot
USES= compiler:c++11-lang gmake localbase perl5 tar:xz
-USE_JAVA= yes
-
+USE_CXXSTD= c++14
+USE_JAVA= 8+
JAVA_RUN= yes
-JAVA_VERSION= 8+
-WRKSRC_SUBDIR= src
# Upstream Makefile compiles directly into ${DESTDIR}${PREFIX} rather than
# using a separate install target.
MAKE_ENV= DESTDIR=${WRKSRC} CANU_BUILD_ENV=ports
-CXXFLAGS+= -std=c++14
+
+WRKSRC_SUBDIR= src
.include <bsd.port.pre.mk>