aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/canu/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/biology/canu/Makefile b/biology/canu/Makefile
index d9b670ebf467..2f352aaf22d8 100644
--- a/biology/canu/Makefile
+++ b/biology/canu/Makefile
@@ -19,16 +19,15 @@ LIB_DEPENDS= libboost_regex.so:devel/boost-libs
RUN_DEPENDS= gnuplot:math/gnuplot
USES= compiler:c++11-lang gmake localbase perl5 tar:xz
-USE_JAVA= yes
-
+USE_CXXSTD= c++14
+USE_JAVA= 8+
JAVA_RUN= yes
-JAVA_VERSION= 8+
-WRKSRC_SUBDIR= src
# Upstream Makefile compiles directly into ${DESTDIR}${PREFIX} rather than
# using a separate install target.
MAKE_ENV= DESTDIR=${WRKSRC} CANU_BUILD_ENV=ports
-CXXFLAGS+= -std=c++14
+
+WRKSRC_SUBDIR= src
.include <bsd.port.pre.mk>