aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-09 10:58:17 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-09 10:58:17 +0000
commitda12a4916a304c09cad280f9bbbe90e1f116b229 (patch)
tree87f32c56f97f151b20db43a0987d921f9aa6f0b1
parentef098521b38e6a98016425f0d8bd3029ef0f6533 (diff)
downloadports-da12a4916a304c09cad280f9bbbe90e1f116b229.tar.gz
ports-da12a4916a304c09cad280f9bbbe90e1f116b229.zip
devel/py-jaraco.util: Convert to USE_PYTHON=pytest
-rw-r--r--devel/py-jaraco.util/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/devel/py-jaraco.util/Makefile b/devel/py-jaraco.util/Makefile
index db3f39a369e1..9d9bd3caee28 100644
--- a/devel/py-jaraco.util/Makefile
+++ b/devel/py-jaraco.util/Makefile
@@ -13,8 +13,7 @@ LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jaraco>=0:devel/py-jaraco@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jaraco.context>=0:devel/py-jaraco.context@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=4.6:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-black>=0.3.7:devel/py-pytest-black@${PY_FLAVOR} \
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-black>=0.3.7:devel/py-pytest-black@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-checkdocs>=2.4:devel/py-pytest-checkdocs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-enabler>=1.0.1:devel/py-pytest-enabler@${PY_FLAVOR} \
@@ -22,7 +21,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=4.6:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-mypy>=0:devel/py-pytest-mypy@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent distutils pytest
NO_ARCH= yes
@@ -36,7 +35,4 @@ post-install:
trim-jaraco-namespace:
@${REINPLACE_CMD} '/jaraco\/__init__\./d; /jaraco\/__pycache__\/__init__\./d' ${TMPPLIST}
-do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
-
.include <bsd.port.mk>