aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-08-15 13:57:17 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-08-15 19:06:03 +0000
commitdc4e8c040a8b3b544b4cacab693c407f6bcd1d84 (patch)
treed20ee7e8019c01804c91d0f127751510371adba5
parent4c230fed88cc283e954899005d11ed7995f3c05e (diff)
downloadports-dc4e8c040a8b3b544b4cacab693c407f6bcd1d84.tar.gz
ports-dc4e8c040a8b3b544b4cacab693c407f6bcd1d84.zip
KDE: make ecm a build-only dependency in KDE Plasma
-rw-r--r--audio/plasma5-kpipewire/Makefile4
-rw-r--r--audio/plasma5-plasma-pa/Makefile5
-rw-r--r--deskutils/plasma5-sddm-kcm/Makefile6
-rw-r--r--devel/plasma5-kwrited/Makefile4
-rw-r--r--devel/plasma5-plasma-sdk/Makefile7
-rw-r--r--multimedia/plasma5-plank-player/Makefile4
-rw-r--r--security/plasma5-kwallet-pam/Makefile4
-rw-r--r--sysutils/plasma5-plasma-disks/Makefile6
-rw-r--r--sysutils/plasma5-plasma-systemmonitor/Makefile6
-rw-r--r--sysutils/plasma5-polkit-kde-agent-1/Makefile6
-rw-r--r--x11-themes/plasma5-breeze-gtk/Makefile8
-rw-r--r--x11-themes/plasma5-breeze/Makefile6
-rw-r--r--x11-themes/plasma5-oxygen/Makefile6
-rw-r--r--x11-themes/plasma5-plasma-workspace-wallpapers/Makefile3
-rw-r--r--x11/plasma5-kactivitymanagerd/Makefile5
-rw-r--r--x11/plasma5-kwayland-integration/Makefile6
-rw-r--r--x11/plasma5-layer-shell-qt/Makefile3
-rw-r--r--x11/plasma5-plasma-bigscreen/Makefile10
-rw-r--r--x11/plasma5-plasma-integration/Makefile6
19 files changed, 69 insertions, 36 deletions
diff --git a/audio/plasma5-kpipewire/Makefile b/audio/plasma5-kpipewire/Makefile
index 75b84df67862..576501345d3c 100644
--- a/audio/plasma5-kpipewire/Makefile
+++ b/audio/plasma5-kpipewire/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kpipewire
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= audio kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -15,7 +16,8 @@ USES= cmake compiler:c++11-lib gettext gl gnome kde:5 pkgconfig qt:5 \
shebangfix tar:xz
USE_GL= egl gbm gl
USE_GNOME= glib20
-USE_KDE= coreaddons ecm i18n plasma-wayland-protocols wayland
+USE_KDE= coreaddons i18n plasma-wayland-protocols wayland \
+ ecm:build
USE_QT= core dbus declarative gui network wayland \
buildtools:build qmake:build
diff --git a/audio/plasma5-plasma-pa/Makefile b/audio/plasma5-plasma-pa/Makefile
index 60ab3da031bf..e52ca7abbb37 100644
--- a/audio/plasma5-plasma-pa/Makefile
+++ b/audio/plasma5-plasma-pa/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-pa
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= audio kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -13,9 +14,9 @@ RUN_DEPENDS= ${LOCALBASE}/share/sounds/freedesktop/index.theme:audio/freedesktop
USES= cmake compiler:c++11-lib gettext gnome kde:5 pkgconfig qt:5 \
shebangfix tar:xz
USE_GNOME= glib20
-USE_KDE= config configwidgets coreaddons ecm globalaccel i18n kcmutils \
+USE_KDE= config configwidgets coreaddons globalaccel i18n kcmutils \
kdeclarative notifications package plasma-framework \
- doctools:build
+ doctools:build ecm:build
USE_QT= core dbus declarative gui network widgets xml \
buildtools:build qmake:build
diff --git a/deskutils/plasma5-sddm-kcm/Makefile b/deskutils/plasma5-sddm-kcm/Makefile
index 48c23aa62996..03d7956baf54 100644
--- a/deskutils/plasma5-sddm-kcm/Makefile
+++ b/deskutils/plasma5-sddm-kcm/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sddm-kcm
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= deskutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -9,8 +10,9 @@ WWW= https://www.kde.org/plasma-desktop
USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig qt:5 tar:xz \
xorg
USE_KDE= archive attica auth codecs completion config configwidgets \
- coreaddons ecm i18n jobwidgets kcmutils kdeclarative kio \
- newstuff service widgetsaddons windowsystem xmlgui
+ coreaddons i18n jobwidgets kcmutils kdeclarative kio newstuff \
+ service widgetsaddons windowsystem xmlgui \
+ ecm:build
USE_QT= concurrent core dbus declarative designer gui network uiplugin \
widgets x11extras xml \
buildtools:build qmake:build
diff --git a/devel/plasma5-kwrited/Makefile b/devel/plasma5-kwrited/Makefile
index ebb2d30f3810..c78d7dee53fb 100644
--- a/devel/plasma5-kwrited/Makefile
+++ b/devel/plasma5-kwrited/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kwrited
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -7,7 +8,8 @@ COMMENT= Plasma5 daemon listening for wall and write messages
WWW= https://www.kde.org/plasma-desktop
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
-USE_KDE= coreaddons dbusaddons ecm i18n notifications pty
+USE_KDE= coreaddons dbusaddons i18n notifications pty \
+ ecm:build
USE_QT= core dbus gui widgets \
buildtools:build qmake:build
diff --git a/devel/plasma5-plasma-sdk/Makefile b/devel/plasma5-plasma-sdk/Makefile
index 34c7997eb68d..1b169b6cf0d8 100644
--- a/devel/plasma5-plasma-sdk/Makefile
+++ b/devel/plasma5-plasma-sdk/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-sdk
DISTVERSION= ${KDE_PLASMA_VERSION}.1
+PORTREVISION= 1
CATEGORIES= devel kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -8,11 +9,11 @@ WWW= https://www.kde.org/plasma-desktop
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz xorg
USE_KDE= archive attica auth codecs completion config configwidgets \
- coreaddons dbusaddons ecm i18n iconthemes itemmodels \
- jobwidgets kdeclarative kio kirigami2 newstuff package parts \
+ coreaddons dbusaddons i18n iconthemes itemmodels jobwidgets \
+ kdeclarative kio kirigami2 newstuff package parts \
plasma-framework service solid sonnet syntaxhighlighting \
texteditor textwidgets widgetsaddons windowsystem xmlgui \
- doctools:build
+ doctools:build ecm:build
USE_QT= concurrent core dbus declarative gui network webkit widgets \
x11extras xml \
buildtools:build qmake:build
diff --git a/multimedia/plasma5-plank-player/Makefile b/multimedia/plasma5-plank-player/Makefile
index e02ccbc5cef6..d3994ac2cfc9 100644
--- a/multimedia/plasma5-plank-player/Makefile
+++ b/multimedia/plasma5-plank-player/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plank-player
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= multimedia kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -8,7 +9,8 @@ WWW= https://www.kde.org/plasma-desktop
USES= cmake compiler:c++11-lib desktop-file-utils gettext kde:5 \
pkgconfig qt:5 shebangfix tar:xz
-USE_KDE= ecm i18n kirigami2
+USE_KDE= i18n kirigami2 \
+ ecm:build
USE_QT= core declarative gui multimedia network quickcontrols2 \
buildtools:build qmake:build
diff --git a/security/plasma5-kwallet-pam/Makefile b/security/plasma5-kwallet-pam/Makefile
index 714c3f129558..d50f53ea3f62 100644
--- a/security/plasma5-kwallet-pam/Makefile
+++ b/security/plasma5-kwallet-pam/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kwallet-pam
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= security kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +11,8 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error
USES= cmake gettext kde:5 qt:5 tar:xz
-USE_KDE= ecm wallet
+USE_KDE= wallet \
+ ecm:build
USE_QT= gui \
buildtools:build qmake:build
diff --git a/sysutils/plasma5-plasma-disks/Makefile b/sysutils/plasma5-plasma-disks/Makefile
index 23d295a4b7d9..4b627ade4c61 100644
--- a/sysutils/plasma5-plasma-disks/Makefile
+++ b/sysutils/plasma5-plasma-disks/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-disks
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -26,8 +27,9 @@ RUN_DEPENDS= smartmontools>0:sysutils/smartmontools
USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz xorg
USE_KDE= activities auth codecs config configwidgets coreaddons \
- dbusaddons ecm i18n kdeclarative kio ksysguard notifications \
- plasma-framework service solid widgetsaddons windowsystem
+ dbusaddons i18n kdeclarative kio ksysguard notifications \
+ plasma-framework service solid widgetsaddons windowsystem \
+ ecm:build
USE_QT= concurrent core dbus declarative gui network quickcontrols \
widgets xml \
buildtools:build qmake:build
diff --git a/sysutils/plasma5-plasma-systemmonitor/Makefile b/sysutils/plasma5-plasma-systemmonitor/Makefile
index 1be08c01ada8..0e839b98ad4d 100644
--- a/sysutils/plasma5-plasma-systemmonitor/Makefile
+++ b/sysutils/plasma5-plasma-systemmonitor/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-systemmonitor
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -9,9 +10,10 @@ WWW= https://www.kde.org/plasma-desktop
USES= cmake compiler:c++11-lib desktop-file-utils gettext kde:5 \
localbase pathfix qt:5 tar:xz xorg
USE_KDE= attica auth codecs config configwidgets coreaddons dbusaddons \
- ecm globalaccel i18n itemmodels kdeclarative kio ksystemstats \
+ globalaccel i18n itemmodels kdeclarative kio ksystemstats \
libksysguard newstuff package service widgetsaddons \
- windowsystem xmlgui
+ windowsystem xmlgui \
+ ecm:build
USE_QT= concurrent core dbus declarative gui network quickcontrols2 \
widgets xml \
buildtools:build qmake:build
diff --git a/sysutils/plasma5-polkit-kde-agent-1/Makefile b/sysutils/plasma5-polkit-kde-agent-1/Makefile
index 2aa029313b9a..7881e855171a 100644
--- a/sysutils/plasma5-polkit-kde-agent-1/Makefile
+++ b/sysutils/plasma5-polkit-kde-agent-1/Makefile
@@ -1,5 +1,6 @@
PORTNAME= polkit-kde-agent-1
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -9,8 +10,9 @@ WWW= https://www.kde.org/plasma-desktop
LIB_DEPENDS= libpolkit-qt5-core-1.so:sysutils/polkit-qt
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz xorg
-USE_KDE= config coreaddons crash dbusaddons ecm i18n iconthemes \
- notifications widgetsaddons windowsystem
+USE_KDE= config coreaddons crash dbusaddons i18n iconthemes \
+ notifications widgetsaddons windowsystem \
+ ecm:build
USE_QT= core dbus gui widgets \
buildtools:build qmake:build
USE_XORG= x11
diff --git a/x11-themes/plasma5-breeze-gtk/Makefile b/x11-themes/plasma5-breeze-gtk/Makefile
index a1b6f0ae190b..de3d83c81ebb 100644
--- a/x11-themes/plasma5-breeze-gtk/Makefile
+++ b/x11-themes/plasma5-breeze-gtk/Makefile
@@ -1,5 +1,6 @@
PORTNAME= breeze-gtk
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-themes kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -11,10 +12,11 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>0:graphics/py-cairo@${PY_FLAVOR} \
sassc:textproc/sassc
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>0:graphics/py-cairo@${PY_FLAVOR}
-USES= cmake compiler:c++11-lang gnome kde:5 pkgconfig python \
- qt:5 tar:xz
+USES= cmake compiler:c++11-lang gnome kde:5 pkgconfig python qt:5 \
+ tar:xz
USE_GNOME= gdkpixbuf2
-USE_KDE= breeze ecm
+USE_KDE= breeze \
+ ecm:build
USE_QT= core \
buildtools:build qmake:build
CMAKE_ARGS= -DPython3_EXECUTABLE:PATH=${PYTHON_CMD}
diff --git a/x11-themes/plasma5-breeze/Makefile b/x11-themes/plasma5-breeze/Makefile
index 2ea1a112158e..45efbb30c0aa 100644
--- a/x11-themes/plasma5-breeze/Makefile
+++ b/x11-themes/plasma5-breeze/Makefile
@@ -1,5 +1,6 @@
PORTNAME= breeze
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-themes kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -13,9 +14,10 @@ LIB_DEPENDS= libfftw3_threads.so:math/fftw3
USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig qt:5 tar:xz \
xorg
USE_KDE= auth breeze-icons codecs config configwidgets coreaddons \
- decoration ecm frameworkintegration guiaddons i18n iconthemes \
+ decoration frameworkintegration guiaddons i18n iconthemes \
kcmutils kirigami2 plasma-framework service wayland \
- widgetsaddons windowsystem
+ widgetsaddons windowsystem \
+ ecm:build
USE_QT= core dbus declarative gui network widgets x11extras xml \
buildtools:build qmake:build
USE_XORG= x11 xcb
diff --git a/x11-themes/plasma5-oxygen/Makefile b/x11-themes/plasma5-oxygen/Makefile
index d06bb382f988..9deed00d3228 100644
--- a/x11-themes/plasma5-oxygen/Makefile
+++ b/x11-themes/plasma5-oxygen/Makefile
@@ -1,5 +1,6 @@
PORTNAME= oxygen
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-themes kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -13,8 +14,9 @@ USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig qt:5 tar:xz \
xorg
USE_LDCONFIG= yes
USE_KDE= auth codecs completion config configwidgets coreaddons \
- decoration ecm frameworkintegration guiaddons i18n kcmutils \
- service wayland widgetsaddons windowsystem
+ decoration frameworkintegration guiaddons i18n kcmutils \
+ service wayland widgetsaddons windowsystem \
+ ecm:build
USE_QT= core dbus declarative gui network widgets x11extras xml \
buildtools:build qmake:build
USE_XORG= x11 xcb
diff --git a/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile b/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile
index fa94ec36109d..76956ff853e7 100644
--- a/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile
+++ b/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-workspace-wallpapers
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-themes kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LGPL3
USES= cmake kde:5 qt:5 tar:xz
-USE_KDE= ecm
+USE_KDE= ecm:build
USE_QT= buildtools:build \
qmake:build
diff --git a/x11/plasma5-kactivitymanagerd/Makefile b/x11/plasma5-kactivitymanagerd/Makefile
index 4e516519c080..f5865c43f2ce 100644
--- a/x11/plasma5-kactivitymanagerd/Makefile
+++ b/x11/plasma5-kactivitymanagerd/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kactivitymanagerd
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -10,8 +11,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/range/algorithm.hpp:devel/boost-libs
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz xorg
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
- ecm globalaccel i18n kio service widgetsaddons windowsystem \
- xmlgui
+ globalaccel i18n kio service widgetsaddons windowsystem xmlgui \
+ ecm:build
USE_QT= concurrent core dbus gui network sql widgets xml \
buildtools:build qmake:build
USE_XORG= x11
diff --git a/x11/plasma5-kwayland-integration/Makefile b/x11/plasma5-kwayland-integration/Makefile
index 63f62491f0cb..605754095662 100644
--- a/x11/plasma5-kwayland-integration/Makefile
+++ b/x11/plasma5-kwayland-integration/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kwayland-integration
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -14,8 +15,9 @@ BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
USES= cmake compiler:c++11-lib gl kde:5 pkgconfig qt:5 tar:xz xorg
USE_GL= gl
-USE_KDE= ecm guiaddons idletime plasma-wayland-protocols wayland \
- windowsystem
+USE_KDE= guiaddons idletime plasma-wayland-protocols wayland \
+ windowsystem \
+ ecm:build
USE_QT= core gui wayland widgets \
buildtools:build qmake:build
USE_XORG= x11
diff --git a/x11/plasma5-layer-shell-qt/Makefile b/x11/plasma5-layer-shell-qt/Makefile
index 84b7bba624f4..21f6bd65c867 100644
--- a/x11/plasma5-layer-shell-qt/Makefile
+++ b/x11/plasma5-layer-shell-qt/Makefile
@@ -1,5 +1,6 @@
PORTNAME= layer-shell-qt
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -13,7 +14,7 @@ LIB_DEPENDS= libwayland-client.so:graphics/wayland \
USES= cmake compiler:c++11-lang gettext gl kde:5 pkgconfig qt:5 \
tar:xz
USE_GL= gl
-USE_KDE= ecm
+USE_KDE= ecm:build
USE_QT= core gui wayland \
buildtools:build qmake:build
diff --git a/x11/plasma5-plasma-bigscreen/Makefile b/x11/plasma5-plasma-bigscreen/Makefile
index 6fe0ac0c8193..46acf2f8e2ff 100644
--- a/x11/plasma5-plasma-bigscreen/Makefile
+++ b/x11/plasma5-plasma-bigscreen/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-bigscreen
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -9,10 +10,11 @@ WWW= https://www.kde.org/plasma-desktop
USES= cmake compiler:c++11-lib cpe desktop-file-utils gettext kde:5 \
pkgconfig qt:5 tar:xz xorg
USE_KDE= activities activities-stats auth codecs completion config \
- configwidgets coreaddons ecm i18n jobwidgets kcmutils \
- kdeclarative kio kirigami2 notifications package \
- plasma-framework plasma-workspace service solid wayland \
- widgetsaddons windowsystem
+ configwidgets coreaddons i18n jobwidgets kcmutils kdeclarative \
+ kio kirigami2 notifications package plasma-framework \
+ plasma-workspace service solid wayland widgetsaddons \
+ windowsystem \
+ ecm:build
USE_QT= concurrent core dbus declarative gui network widgets xml \
buildtools:build qmake:build
USE_XORG= x11
diff --git a/x11/plasma5-plasma-integration/Makefile b/x11/plasma5-plasma-integration/Makefile
index f1d9148b2237..374b9a4268ab 100644
--- a/x11/plasma5-plasma-integration/Makefile
+++ b/x11/plasma5-plasma-integration/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-integration
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -12,9 +13,10 @@ RUN_DEPENDS= hack-font>=0:x11-fonts/hack-font
USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig qt:5 \
shebangfix tar:xz xorg
USE_KDE= auth bookmarks breeze codecs completion config configwidgets \
- coreaddons ecm i18n iconthemes itemviews jobwidgets kio \
+ coreaddons i18n iconthemes itemviews jobwidgets kio \
notifications service solid wayland widgetsaddons windowsystem \
- xmlgui xdg-desktop-portal-kde \
+ xdg-desktop-portal-kde xmlgui \
+ ecm:build \
qqc2-desktop-style:run
USE_QT= concurrent core dbus declarative gui network quickcontrols2 \
wayland widgets x11extras xml \