aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2024-01-24 21:39:54 +0000
committerLarry Rosenman <ler@FreeBSD.org>2024-01-24 21:41:05 +0000
commitdde3eadf2029d2700c4fcef546f86d6cdc26b467 (patch)
tree512a2bba0ddffd6fd66e1e959ddc4ab2f949eb06
parent2f448a87ed311d7e3bc506c6a42e23da6ad8bfee (diff)
downloadports-dde3eadf2029d2700c4fcef546f86d6cdc26b467.tar.gz
ports-dde3eadf2029d2700c4fcef546f86d6cdc26b467.zip
mail/dovecot-pigeonhole: add an EXAMPLES option
- install the example scripts from the tarball Requested by: mwl
-rw-r--r--mail/dovecot-pigeonhole/Makefile21
1 files changed, 19 insertions, 2 deletions
diff --git a/mail/dovecot-pigeonhole/Makefile b/mail/dovecot-pigeonhole/Makefile
index f9451ad52d16..5c3e2932d82b 100644
--- a/mail/dovecot-pigeonhole/Makefile
+++ b/mail/dovecot-pigeonhole/Makefile
@@ -1,5 +1,6 @@
PORTNAME= dovecot-pigeonhole
PORTVERSION= 0.5.21
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://pigeonhole.dovecot.org/releases/${DOVECOTVERSION}/
DISTNAME= ${PORTNAME:C/-/-${DOVECOTVERSION}-/}-${PORTVERSION}
@@ -24,8 +25,8 @@ INSTALL_TARGET= install-strip
USES= compiler:c11 libtool ssl
USE_LDCONFIG= ${PREFIX}/lib/dovecot
-OPTIONS_DEFINE= DOCS LDAP MANAGESIEVE
-OPTIONS_DEFAULT=MANAGESIEVE GSSAPI_NONE
+OPTIONS_DEFINE= DOCS EXAMPLES LDAP MANAGESIEVE
+OPTIONS_DEFAULT=EXAMPLES MANAGESIEVE GSSAPI_NONE
OPTIONS_SINGLE= GSSAPI
OPTIONS_SINGLE_GSSAPI= GSSAPI_NONE GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
@@ -52,6 +53,7 @@ LDAP_LDFLAGS= -L${LOCALBASE}/lib
LDAP_USES= ldap
PORTDOCS= sieve/extensions/* sieve/plugins/* sieve/locations/*
+PORTEXAMPLES= *
post-patch:
@${REINPLACE_CMD} -E '\
@@ -59,4 +61,19 @@ post-patch:
s!^(uninstall-am:) uninstall-sieve_docDATA!\1!;' \
${WRKSRC}/doc/Makefile.in
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+
+ ${CP} ${WRKSRC}/examples/elvey.sieve ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/jerry.sieve ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/mjohnson.sieve ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/mklose.sieve ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/relational.rfc5231.sieve ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/rfc3028.sieve ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/sanjay.sieve ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/sieve_examples.sieve ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/subaddress.rfc5233.sieve ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/vacation.sieve ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/examples/vivil.sieve ${STAGEDIR}${EXAMPLESDIR}
+
.include <bsd.port.mk>