aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Büker <freebsd@michael-bueker.de>2021-08-06 14:16:44 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-08-06 14:16:44 +0000
commitebec65d5759b72f45c99d6125d59e06ae774b70c (patch)
tree66f869d4151833dae671b668aa1d86fa9160d27c
parent3862fee82cb80ca11316a2ed63574cfa1f14a940 (diff)
downloadports-ebec65d5759b72f45c99d6125d59e06ae774b70c.tar.gz
ports-ebec65d5759b72f45c99d6125d59e06ae774b70c.zip
comms/py-fritzconnection: New port
Python tool to communicate with AVM FritzBox routers. PR: 256989
-rw-r--r--comms/Makefile1
-rw-r--r--comms/py-fritzconnection/Makefile25
-rw-r--r--comms/py-fritzconnection/distinfo3
-rw-r--r--comms/py-fritzconnection/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index ed430ecc19cb..45a8042b822e 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -132,6 +132,7 @@
SUBDIR += predict
SUBDIR += py-adafruit-ampy
SUBDIR += py-esptool
+ SUBDIR += py-fritzconnection
SUBDIR += py-hid
SUBDIR += py-hidapi
SUBDIR += py-libimobiledevice
diff --git a/comms/py-fritzconnection/Makefile b/comms/py-fritzconnection/Makefile
new file mode 100644
index 000000000000..58360b3b2102
--- /dev/null
+++ b/comms/py-fritzconnection/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= fritzconnection
+DISTVERSION= 1.6.0
+CATEGORIES= comms python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd@michael-bueker.de
+COMMENT= Python tool to communicate with AVM FritzBox routers
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.22.0:www/py-requests@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= kbr
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+
+.include <bsd.port.mk>
diff --git a/comms/py-fritzconnection/distinfo b/comms/py-fritzconnection/distinfo
new file mode 100644
index 000000000000..bfdaeb380a7d
--- /dev/null
+++ b/comms/py-fritzconnection/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1628255923
+SHA256 (kbr-fritzconnection-1.6.0_GH0.tar.gz) = 8ef7bea2d892dc7070c6ed6ca7d1c5649e1277ad1b07a85e49e4f57f8b5f6493
+SIZE (kbr-fritzconnection-1.6.0_GH0.tar.gz) = 73672
diff --git a/comms/py-fritzconnection/pkg-descr b/comms/py-fritzconnection/pkg-descr
new file mode 100644
index 000000000000..0a6f8e32a9d1
--- /dev/null
+++ b/comms/py-fritzconnection/pkg-descr
@@ -0,0 +1,4 @@
+A Python tool to communicate with the AVM FritzBox family of home routers.
+It uses the TR-064 protocol over UPnP.
+
+WWW: https://github.com/kbr/fritzconnection/