aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2014-08-13 15:48:42 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2014-08-13 15:48:42 +0000
commitf163e0e4230348182a35427b4737af5105dbf981 (patch)
tree7272a29f5a23f498a4cbb5b380d3dd4e5856cc62
parent99ad49927ddc9927a848f6890ae0ab3cbc88896d (diff)
downloadports-f163e0e4230348182a35427b4737af5105dbf981.tar.gz
ports-f163e0e4230348182a35427b4737af5105dbf981.zip
New port: lang/p5-Try-Tiny-Retry:
This module extends Try::Tiny to add support for retries. Try::Tiny provides bare bones try/catch statements that are designed to minimize common mistakes done with eval blocks (for instance assuming that $@ is set to a true value on error, or clobbering previous values of $@, and NOTHING else. WWW: http://search.cpan.org/dist/Try-Tiny-Retry/
Notes
Notes: svn path=/head/; revision=364793
-rw-r--r--lang/Makefile1
-rw-r--r--lang/p5-Try-Tiny-Retry/Makefile20
-rw-r--r--lang/p5-Try-Tiny-Retry/distinfo2
-rw-r--r--lang/p5-Try-Tiny-Retry/pkg-descr8
-rw-r--r--lang/p5-Try-Tiny-Retry/pkg-plist5
5 files changed, 36 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 8041c5a93e65..fbbf7ee87c7a 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -215,6 +215,7 @@
SUBDIR += p5-Tcl
SUBDIR += p5-Test-XPath
SUBDIR += p5-Try-Tiny
+ SUBDIR += p5-Try-Tiny-Retry
SUBDIR += p5-TryCatch
SUBDIR += p5-ePerl
SUBDIR += p5-signatures
diff --git a/lang/p5-Try-Tiny-Retry/Makefile b/lang/p5-Try-Tiny-Retry/Makefile
new file mode 100644
index 000000000000..91083080eb43
--- /dev/null
+++ b/lang/p5-Try-Tiny-Retry/Makefile
@@ -0,0 +1,20 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Try-Tiny-Retry
+PORTVERSION= 0.004
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DAGOLDEN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Extends Try::Tiny to allow retries
+
+BUILD_DEPENDS= p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/lang/p5-Try-Tiny-Retry/distinfo b/lang/p5-Try-Tiny-Retry/distinfo
new file mode 100644
index 000000000000..228f9701bafb
--- /dev/null
+++ b/lang/p5-Try-Tiny-Retry/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Try-Tiny-Retry-0.004.tar.gz) = 8af70c1bd46d749388738b7ea03c703cac898be939a5ff37117a01ed7eda8bbe
+SIZE (Try-Tiny-Retry-0.004.tar.gz) = 17228
diff --git a/lang/p5-Try-Tiny-Retry/pkg-descr b/lang/p5-Try-Tiny-Retry/pkg-descr
new file mode 100644
index 000000000000..78915e16129f
--- /dev/null
+++ b/lang/p5-Try-Tiny-Retry/pkg-descr
@@ -0,0 +1,8 @@
+This module extends Try::Tiny to add support for retries.
+
+Try::Tiny provides bare bones try/catch statements that are designed
+to minimize common mistakes done with eval blocks (for instance assuming
+that $@ is set to a true value on error, or clobbering previous values
+of $@, and NOTHING else.
+
+WWW: http://search.cpan.org/dist/Try-Tiny-Retry/
diff --git a/lang/p5-Try-Tiny-Retry/pkg-plist b/lang/p5-Try-Tiny-Retry/pkg-plist
new file mode 100644
index 000000000000..5a748d4601b8
--- /dev/null
+++ b/lang/p5-Try-Tiny-Retry/pkg-plist
@@ -0,0 +1,5 @@
+%%PERL5_MAN3%%/Try::Tiny::Retry.3.gz
+%%SITE_PERL%%/Try/Tiny/Retry.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Try/Tiny/Retry/.packlist
+@dirrmtry %%SITE_PERL%%/Try/Tiny
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Try/Tiny/Retry