aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiguel Gocobachi <miguel@gocobachi.dev>2022-06-02 16:19:55 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-06-05 11:19:22 +0000
commitf19a91214e0d7881bb0b8b5f6467ff42a76c28a8 (patch)
treec7b378d6e9bc7f5baa09ec2d30e32bed305eedb7
parentd8e59b79701f50af84541883fd290053bf2f33ff (diff)
downloadports-f19a91214e0d7881bb0b8b5f6467ff42a76c28a8.tar.gz
ports-f19a91214e0d7881bb0b8b5f6467ff42a76c28a8.zip
editors/elementary-code: update to 6.2.0
PR: 264358 Reported by: miguel@gocobachi.dev
-rw-r--r--editors/elementary-code/Makefile10
-rw-r--r--editors/elementary-code/distinfo8
-rw-r--r--editors/elementary-code/files/patch-plugins_editorconfig_meson.build9
-rw-r--r--editors/elementary-code/files/patch-plugins_terminal_terminal.vala21
4 files changed, 33 insertions, 15 deletions
diff --git a/editors/elementary-code/Makefile b/editors/elementary-code/Makefile
index 02a26c051f00..27b8b2c397e7 100644
--- a/editors/elementary-code/Makefile
+++ b/editors/elementary-code/Makefile
@@ -1,11 +1,7 @@
PORTNAME= elementary-code
-DISTVERSION= 6.0.0
-PORTREVISION= 4
+DISTVERSION= 6.2.0
CATEGORIES= editors
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= a2607cce3a6b.patch:-p1 # https://github.com/elementary/code/pull/1165
-
MAINTAINER= miguel@gocobachi.dev
COMMENT= Code editor designed for elementary OS
@@ -13,8 +9,6 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= valac:lang/vala
-RUN_DEPENDS= droid-fonts-ttf>0:x11-fonts/droid-fonts-ttf \
- pkcheck:sysutils/polkit
LIB_DEPENDS= libatk-1.0.so:accessibility/atk \
libeditorconfig.so:editors/editorconfig-core-c \
libfontconfig.so:x11-fonts/fontconfig \
@@ -29,6 +23,8 @@ LIB_DEPENDS= libatk-1.0.so:accessibility/atk \
libvala-0.48.so:lang/vala \
libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
libzeitgeist-2.0.so:sysutils/zeitgeist
+RUN_DEPENDS= droid-fonts-ttf>0:x11-fonts/droid-fonts-ttf \
+ pkcheck:sysutils/polkit
USES= compiler:c++11-lang desktop-file-utils gettext gnome meson \
ninja pkgconfig python:3.6+,build xorg
diff --git a/editors/elementary-code/distinfo b/editors/elementary-code/distinfo
index 9f1d8950003b..35db590b7c97 100644
--- a/editors/elementary-code/distinfo
+++ b/editors/elementary-code/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1628896888
-SHA256 (elementary-code-6.0.0_GH0.tar.gz) = c58b33db512e1c031f6870eb62b035dea764dbdd7c54b8e19c434af8ccd3a384
-SIZE (elementary-code-6.0.0_GH0.tar.gz) = 1303421
-SHA256 (a2607cce3a6b.patch) = d16ec6023bbc26a5fd919d2233e52caa983af667533c44592ba0120bd6122119
-SIZE (a2607cce3a6b.patch) = 661
+TIMESTAMP = 1653761499
+SHA256 (elementary-code-6.2.0_GH0.tar.gz) = 9ec273182b053fb424cc78ddd8da869d13261d35f22cd2198f2899b654d13d4f
+SIZE (elementary-code-6.2.0_GH0.tar.gz) = 1427323
diff --git a/editors/elementary-code/files/patch-plugins_editorconfig_meson.build b/editors/elementary-code/files/patch-plugins_editorconfig_meson.build
index 1310f0da1d04..80a08578e7c2 100644
--- a/editors/elementary-code/files/patch-plugins_editorconfig_meson.build
+++ b/editors/elementary-code/files/patch-plugins_editorconfig_meson.build
@@ -1,12 +1,15 @@
---- plugins/editorconfig/meson.build.orig 2020-06-28 09:00:29 UTC
+--- plugins/editorconfig/meson.build.orig 2022-05-31 04:56:45 UTC
+++ plugins/editorconfig/meson.build
-@@ -7,7 +7,8 @@ module_files = [
+@@ -7,7 +7,11 @@ module_files = [
module_deps = [
codecore_dep,
- meson.get_compiler('c').find_library('editorconfig')
+ meson.get_compiler('c')
-+ .find_library('editorconfig', dirs: ['/usr/local/lib'])
++ .find_library('editorconfig', dirs: [
++ '/usr/local/lib'
++ ]
++ )
]
shared_module(
diff --git a/editors/elementary-code/files/patch-plugins_terminal_terminal.vala b/editors/elementary-code/files/patch-plugins_terminal_terminal.vala
new file mode 100644
index 000000000000..8443bc31aca0
--- /dev/null
+++ b/editors/elementary-code/files/patch-plugins_terminal_terminal.vala
@@ -0,0 +1,21 @@
+--- plugins/terminal/terminal.vala.orig 2022-04-04 16:20:49 UTC
++++ plugins/terminal/terminal.vala
+@@ -200,13 +200,16 @@ public class Scratch.Plugins.Terminal : Peas.Extension
+
+ public string get_shell_location () {
+ int pid = (!) (this.child_pid);
++ string cwd = "";
+
+ try {
+- return GLib.FileUtils.read_link ("/proc/%d/cwd".printf (pid));
++ //return GLib.FileUtils.read_link ("/proc/%d/cwd".printf (pid));
++ GLib.Process.spawn_command_line_sync ("pwd", out cwd);
+ } catch (GLib.FileError error) {
+ warning ("An error occurred while fetching the current dir of shell");
+- return "";
+ }
++
++ return cwd;
+ }
+
+ void on_hook_notebook () {