aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-08-17 18:47:17 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-08-17 18:48:37 +0000
commitfa08ed068803ea89d2d1b88e2cdc82eedb51aef9 (patch)
tree2c9f3914e5f1c1237b1be5575510210d00dceaeb
parent42758da17ebd03d53b0b28ccdf43932fcfde1cce (diff)
downloadports-fa08ed068803ea89d2d1b88e2cdc82eedb51aef9.tar.gz
ports-fa08ed068803ea89d2d1b88e2cdc82eedb51aef9.zip
sysutils/accountsservice: Fix build in presence of security/libxcrypt
PR: 270881 Reported by: John Hein <jcfyecrayz@liamekaens.com> Sponsored by: Serenity Cybersecurity, LLC
-rw-r--r--sysutils/accountsservice/Makefile3
-rw-r--r--sysutils/accountsservice/files/patch-meson.build13
2 files changed, 15 insertions, 1 deletions
diff --git a/sysutils/accountsservice/Makefile b/sysutils/accountsservice/Makefile
index e4b92dbde119..734b439d2b9a 100644
--- a/sysutils/accountsservice/Makefile
+++ b/sysutils/accountsservice/Makefile
@@ -1,5 +1,6 @@
PORTNAME= accountsservice
PORTVERSION= 23.13.9
+PORTREVISION= 1
CATEGORIES= sysutils devel
MASTER_SITES= https://www.freedesktop.org/software/${PORTNAME}/
@@ -14,7 +15,7 @@ BUILD_DEPENDS= dbus>0:devel/dbus
LIB_DEPENDS= libpolkit-gobject-1.so:sysutils/polkit \
libconsolekit.so:sysutils/consolekit2
-USES= cpe gettext gnome localbase:ldflags meson pkgconfig tar:xz
+USES= cpe gettext gnome meson pkgconfig tar:xz
CPE_VENDOR= freedesktop
USE_GNOME= glib20 intltool libxslt introspection:build
USE_LDCONFIG= yes
diff --git a/sysutils/accountsservice/files/patch-meson.build b/sysutils/accountsservice/files/patch-meson.build
index 0c44fe80183b..4149f6c07630 100644
--- a/sysutils/accountsservice/files/patch-meson.build
+++ b/sysutils/accountsservice/files/patch-meson.build
@@ -8,3 +8,16 @@
config_h.set_quoted('PATH_WTMP', path_wtmp)
endif
+@@ -159,11 +158,7 @@ polkit_gobject_dep = dependency('polkit-gobject-1')
+ # salt drawn from secure system ressources with at least 128 bits.
+ # (96 bits for sha512crypt, as more is not supported by this method, since
+ # the effectively used maximum is 16 base64-encoded characters)
+-crypt_dep = dependency('libxcrypt', required: false, version: '>= 4')
+-config_h.set('HAVE_CRYPT_GENSALT', crypt_dep.found())
+-if not crypt_dep.found()
+- crypt_dep = cc.find_library('crypt')
+-endif
++crypt_dep = cc.find_library('crypt')
+
+ dbus_dep = dependency('dbus-1')
+ if dbus_dep.version().version_compare('>=1.9.18')