aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-05 20:41:59 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-05 20:46:34 +0000
commitfe7a3312729eeed37fc9fc7b3957e77c70acd4fd (patch)
tree9d5b5cc26180b2bd8162cfc2fea9a9023ab935cc
parent4cdf64230e4b9f8361a8ecd47054f7e8c8a4ea2c (diff)
downloadports-fe7a3312729eeed37fc9fc7b3957e77c70acd4fd.tar.gz
ports-fe7a3312729eeed37fc9fc7b3957e77c70acd4fd.zip
security/py-yubikey-manager: Fix BUILD_DEPENDS
from pyproject.toml: [build-system] requires = ["poetry-core>=1.0.0"] build-backend = "poetry.core.masonry.api" Approved by: portmgr (blanket) With hat: python Reference: https://github.com/Yubico/yubikey-manager/blob/5.2.0/pyproject.toml#L49-L51
-rw-r--r--security/py-yubikey-manager/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/security/py-yubikey-manager/Makefile b/security/py-yubikey-manager/Makefile
index 627003afdcca..ac57cb359916 100644
--- a/security/py-yubikey-manager/Makefile
+++ b/security/py-yubikey-manager/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${RUN_DEPENDS} \
- ${PYTHON_PKGNAMEPREFIX}poetry>=0:devel/py-poetry@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}fido2>0:security/py-fido2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}keyring>=0:security/py-keyring@${PY_FLAVOR} \