aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTatsuki Makino <tatsuki_makino@hotmail.com>2021-06-14 21:47:09 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-06-14 21:47:09 +0000
commitff9826a26bbb6c08bb6b5f260b838a573576d111 (patch)
tree7c70cfaa441df41196c49929e90321323c943253
parent4de7b118bcc2c06c4ec41fa7213e530884f9131e (diff)
downloadports-ff9826a26bbb6c08bb6b5f260b838a573576d111.tar.gz
ports-ff9826a26bbb6c08bb6b5f260b838a573576d111.zip
audio/libopenshot-audio: Update to 0.2.0.59
PR: 256590
-rw-r--r--audio/libopenshot-audio/Makefile9
-rw-r--r--audio/libopenshot-audio/distinfo6
-rw-r--r--audio/libopenshot-audio/files/patch-CMakeLists.txt60
-rw-r--r--audio/libopenshot-audio/files/patch-JuceLibraryCode_modules_juce__core_native_juce__BasicNativeHeaders.h5
-rw-r--r--audio/libopenshot-audio/files/patch-JuceLibraryCode_modules_juce__core_native_juce__linux__SystemStats.cpp18
-rw-r--r--audio/libopenshot-audio/pkg-plist10
6 files changed, 74 insertions, 34 deletions
diff --git a/audio/libopenshot-audio/Makefile b/audio/libopenshot-audio/Makefile
index 7d164fe3ffbc..4fbe23db0c02 100644
--- a/audio/libopenshot-audio/Makefile
+++ b/audio/libopenshot-audio/Makefile
@@ -1,7 +1,7 @@
PORTNAME= libopenshot-audio
DISTVERSIONPREFIX= v
-DISTVERSION= 0.2.0-29
-DISTVERSIONSUFFIX= -gcdfe5a1
+DISTVERSION= 0.2.0-59
+DISTVERSIONSUFFIX= -g92ff608
CATEGORIES= audio multimedia
MAINTAINER= tatsuki_makino@hotmail.com
@@ -11,9 +11,10 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:audio/alsa-plugins
-LIB_DEPENDS= libasound.so:audio/alsa-lib
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ libsysinfo.so:devel/libsysinfo
-USES= cmake compiler:c++11-lang dos2unix
+USES= cmake compiler:c++11-lang
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= OpenShot
diff --git a/audio/libopenshot-audio/distinfo b/audio/libopenshot-audio/distinfo
index a0c137e84082..aac4057e3671 100644
--- a/audio/libopenshot-audio/distinfo
+++ b/audio/libopenshot-audio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1613703600
-SHA256 (OpenShot-libopenshot-audio-v0.2.0-29-gcdfe5a1_GH0.tar.gz) = ac50e8f79440b365121e9c59644e33f25c174e4d2c5418b7e8fa9b011b7b5723
-SIZE (OpenShot-libopenshot-audio-v0.2.0-29-gcdfe5a1_GH0.tar.gz) = 1720976
+TIMESTAMP = 1622257200
+SHA256 (OpenShot-libopenshot-audio-v0.2.0-59-g92ff608_GH0.tar.gz) = 757c4305a99427955299f9c32214d1df63a5e42e49a76690d24b9d24764661a7
+SIZE (OpenShot-libopenshot-audio-v0.2.0-59-g92ff608_GH0.tar.gz) = 1711214
diff --git a/audio/libopenshot-audio/files/patch-CMakeLists.txt b/audio/libopenshot-audio/files/patch-CMakeLists.txt
index 5f12033edc9b..019ef1951105 100644
--- a/audio/libopenshot-audio/files/patch-CMakeLists.txt
+++ b/audio/libopenshot-audio/files/patch-CMakeLists.txt
@@ -1,18 +1,64 @@
---- CMakeLists.txt.orig 2020-09-11 12:10:25 UTC
+--- CMakeLists.txt.orig 2021-05-09 14:57:33 UTC
+++ CMakeLists.txt
-@@ -218,8 +218,14 @@ if(UNIX AND NOT APPLE)
+@@ -170,6 +170,13 @@ set_target_properties(openshot-audio PROPERTIES
+ EXPORT_NAME Audio # Exports as OpenShot::Audio target
+ )
+
++if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
++ find_package(Threads REQUIRED)
++ if(Threads_FOUND)
++ target_link_libraries(openshot-audio PRIVATE ${CMAKE_THREAD_LIBS_INIT})
++ endif(Threads_FOUND)
++endif(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
++
+ # Require language features we use
+ if(CMAKE_VERSION VERSION_GREATER 3.8)
+ target_compile_features(openshot-audio PUBLIC
+@@ -188,7 +195,8 @@ endif()
+ # Enable stack-unwinding support in c objects on gcc-based platforms.
+ # Failing to do so will cause your program to be terminated when a png
+ # or a jpeg exception is thrown on linux or macosx.
+-if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
++if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU" OR
++ CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+ target_compile_options(openshot-audio PRIVATE -fexceptions)
+ endif()
+
+@@ -249,8 +257,8 @@ if(UNIX AND NOT APPLE)
INTERFACE_INCLUDE_DIRECTORIES ${ALSA_INCLUDE_DIR}
INTERFACE_LINK_LIBRARIES ${ALSA_LIBRARIES})
endif()
- target_compile_definitions(openshot-audio PUBLIC LINUX)
+- target_link_libraries(openshot-audio PUBLIC ALSA::ALSA)
+ #target_compile_definitions(openshot-audio PUBLIC LINUX)
- target_link_libraries(openshot-audio PUBLIC ALSA::ALSA)
-+
++ target_link_libraries(openshot-audio PRIVATE ALSA::ALSA)
+ else()
+ # For EXPORTED Config
+ set(NEED_ALSA FALSE)
+@@ -258,10 +266,24 @@ endif()
+
+ # ZLIB -- uses IMPORTED target ZLIB::ZLIB which has existed since CMake 3.1
+ find_package(ZLIB REQUIRED)
+-target_link_libraries(openshot-audio PUBLIC ZLIB::ZLIB)
++target_link_libraries(openshot-audio PRIVATE ZLIB::ZLIB)
+
++# EXECINFO, SYSINFO
++if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+ find_library(EXECINFO_LIBRARY NAMES execinfo)
+ if(NOT EXECINFO_LIBRARY)
+ message(FATAL_ERROR "${EXECINFO_LIBRARY}")
+ endif(NOT EXECINFO_LIBRARY)
-+ target_link_libraries(openshot-audio PUBLIC ${EXECINFO_LIBRARY})
- endif()
++ target_link_libraries(openshot-audio PRIVATE ${EXECINFO_LIBRARY})
++ find_library(SYSINFO_LIBRARY NAMES sysinfo)
++ if(NOT SYSINFO_LIBRARY)
++ message(FATAL_ERROR "${SYSINFO_LIBRARY}")
++ endif(NOT SYSINFO_LIBRARY)
++ target_link_libraries(openshot-audio PRIVATE ${SYSINFO_LIBRARY})
++endif(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
++
+ # Link with dynamic loader for platform
+-target_link_libraries(openshot-audio PUBLIC ${CMAKE_DL_LIBS})
++target_link_libraries(openshot-audio PRIVATE ${CMAKE_DL_LIBS})
- # ZLIB -- uses IMPORTED target ZLIB::ZLIB which has existed since CMake 3.1
+ # Create an alias so our EXPORT target name works internally, as well
+ add_library(OpenShot::Audio ALIAS openshot-audio)
diff --git a/audio/libopenshot-audio/files/patch-JuceLibraryCode_modules_juce__core_native_juce__BasicNativeHeaders.h b/audio/libopenshot-audio/files/patch-JuceLibraryCode_modules_juce__core_native_juce__BasicNativeHeaders.h
index aac90be637ed..69ecad0630ea 100644
--- a/audio/libopenshot-audio/files/patch-JuceLibraryCode_modules_juce__core_native_juce__BasicNativeHeaders.h
+++ b/audio/libopenshot-audio/files/patch-JuceLibraryCode_modules_juce__core_native_juce__BasicNativeHeaders.h
@@ -1,11 +1,12 @@
---- JuceLibraryCode/modules/juce_core/native/juce_BasicNativeHeaders.h.orig 2020-09-11 12:10:25 UTC
+--- JuceLibraryCode/modules/juce_core/native/juce_BasicNativeHeaders.h.orig 2021-05-09 14:57:33 UTC
+++ JuceLibraryCode/modules/juce_core/native/juce_BasicNativeHeaders.h
-@@ -272,6 +272,8 @@
+@@ -272,6 +272,9 @@
#include <sys/wait.h>
#include <utime.h>
#include <poll.h>
+ #include <net/if_dl.h>
+ #include <pthread_np.h>
++ #include <sys/sysinfo.h>
//==============================================================================
#elif JUCE_ANDROID
diff --git a/audio/libopenshot-audio/files/patch-JuceLibraryCode_modules_juce__core_native_juce__linux__SystemStats.cpp b/audio/libopenshot-audio/files/patch-JuceLibraryCode_modules_juce__core_native_juce__linux__SystemStats.cpp
index 7b33431c15e8..10ae6faf8170 100644
--- a/audio/libopenshot-audio/files/patch-JuceLibraryCode_modules_juce__core_native_juce__linux__SystemStats.cpp
+++ b/audio/libopenshot-audio/files/patch-JuceLibraryCode_modules_juce__core_native_juce__linux__SystemStats.cpp
@@ -1,20 +1,6 @@
---- JuceLibraryCode/modules/juce_core/native/juce_linux_SystemStats.cpp.orig 2020-09-11 12:10:25 UTC
+--- JuceLibraryCode/modules/juce_core/native/juce_linux_SystemStats.cpp.orig 2021-05-09 14:57:33 UTC
+++ JuceLibraryCode/modules/juce_core/native/juce_linux_SystemStats.cpp
-@@ -91,10 +91,13 @@ int SystemStats::getCpuSpeedInMegahertz()
-
- int SystemStats::getMemorySizeInMegabytes()
- {
-+#if JUCE_BSD
-+#else
- struct sysinfo sysi;
-
- if (sysinfo (&sysi) == 0)
- return (int) (sysi.totalram * sysi.mem_unit / (1024 * 1024));
-+#endif
-
- return 0;
- }
-@@ -139,8 +142,13 @@ static String getLocaleValue (nl_item key)
+@@ -139,8 +139,13 @@ static String getLocaleValue (nl_item key)
return result;
}
diff --git a/audio/libopenshot-audio/pkg-plist b/audio/libopenshot-audio/pkg-plist
index 88f99b55598e..36440bffe873 100644
--- a/audio/libopenshot-audio/pkg-plist
+++ b/audio/libopenshot-audio/pkg-plist
@@ -1,6 +1,7 @@
-bin/openshot-audio-test-sound
+bin/openshot-audio-demo
include/libopenshot-audio/AppConfig.h
include/libopenshot-audio/JuceHeader.h
+include/libopenshot-audio/OpenShotAudio.h
include/libopenshot-audio/juce_audio_basics/audio_play_head/juce_AudioPlayHead.h
include/libopenshot-audio/juce_audio_basics/buffers/juce_AudioChannelSet.h
include/libopenshot-audio/juce_audio_basics/buffers/juce_AudioDataConverters.h
@@ -322,10 +323,15 @@ include/libopenshot-audio/juce_events/native/juce_win32_HiddenMessageWindow.h
include/libopenshot-audio/juce_events/native/juce_win32_WinRTWrapper.h
include/libopenshot-audio/juce_events/timers/juce_MultiTimer.h
include/libopenshot-audio/juce_events/timers/juce_Timer.h
+lib/cmake/OpenShotAudio/FindASIO.cmake
+lib/cmake/OpenShotAudio/OpenShotAudioConfig.cmake
+lib/cmake/OpenShotAudio/OpenShotAudioConfigVersion.cmake
+lib/cmake/OpenShotAudio/OpenShotAudioTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/OpenShotAudio/OpenShotAudioTargets.cmake
lib/libopenshot-audio.so
lib/libopenshot-audio.so.0.2.0
lib/libopenshot-audio.so.7
-man/man1/openshot-audio-test-sound.1.gz
+man/man1/openshot-audio-demo.1.gz
@dir include/libopenshot-audio/juce_audio_devices/native/java/app/com/roli/juce
@dir include/libopenshot-audio/juce_core/native/java/app/com/roli/juce
@dir include/libopenshot-audio/juce_core/native/javacore/app/com/roli/juce