aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.autotools.mk
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
commit789d75c728ef23566a07bf5b9bc2190bf34ff4f1 (patch)
treedc7540d42fa2d5d7c1c74515e3bdbf6ab842cd17 /Mk/bsd.autotools.mk
parentd1a9e827c98542eb35619dffa314cba50fb08b58 (diff)
downloadports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.tar.gz
ports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.zip
-Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a. -Remove devel/libtool15 and devel/libltdl15. -Fix ports build with libtool22/libltdl22. -Bump ports that depend on libltdl22 due to shared library version change. -Explain what to do update in the UPDATING. It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop and applications in the runtime. With help: marcus and kwm Pointyhat-exp: a few times by pav Tested by: pgollucci, "Romain Tartière" <romain@blogreen.org>, and a few MarcusCom CVS users. Also, I might have missed a few. Repocopy by: marcus Approved by: portmgr
Notes
Notes: svn path=/head/; revision=238781
Diffstat (limited to 'Mk/bsd.autotools.mk')
-rw-r--r--Mk/bsd.autotools.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 4fe59ce24b62..e09fcaea8fe1 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -175,10 +175,10 @@ BUILD_DEPENDS+= ${AUTOCONF_DEPENDS}
#---------------------------------------------------------------------------
# Convenience function to save people having to depend directly on
-# devel/libltdl15
+# devel/libltdl22
#
.if defined(AUTOTOOL_libltdl)
-LIB_DEPENDS+= ltdl.4:${PORTSDIR}/devel/libltdl15
+LIB_DEPENDS+= ltdl.7:${PORTSDIR}/devel/libltdl22
.endif
.if defined(AUTOTOOL_libtool)
@@ -202,7 +202,7 @@ LIBTOOLIZE= ${LOCALBASE}/bin/libtoolize
LIBTOOL_LIBEXECDIR= ${LOCALBASE}/libexec/libtool
LIBTOOL_SHAREDIR= ${LOCALBASE}/share/libtool
LIBTOOL_M4= ${LOCALBASE}/share/aclocal/libtool.m4
-LTMAIN= ${LIBTOOL_SHAREDIR}/ltmain.sh
+LTMAIN= ${LIBTOOL_SHAREDIR}/config/ltmain.sh
LIBTOOL_VARS= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} LIBTOOL_M4=${LIBTOOL_M4}
LIBTOOL_DEPENDS= ${LIBTOOL}:${PORTSDIR}/devel/libtool${LIBTOOL_VERSION}