aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.autotools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.autotools.mk')
-rw-r--r--Mk/bsd.autotools.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 4fe59ce24b62..e09fcaea8fe1 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -175,10 +175,10 @@ BUILD_DEPENDS+= ${AUTOCONF_DEPENDS}
#---------------------------------------------------------------------------
# Convenience function to save people having to depend directly on
-# devel/libltdl15
+# devel/libltdl22
#
.if defined(AUTOTOOL_libltdl)
-LIB_DEPENDS+= ltdl.4:${PORTSDIR}/devel/libltdl15
+LIB_DEPENDS+= ltdl.7:${PORTSDIR}/devel/libltdl22
.endif
.if defined(AUTOTOOL_libtool)
@@ -202,7 +202,7 @@ LIBTOOLIZE= ${LOCALBASE}/bin/libtoolize
LIBTOOL_LIBEXECDIR= ${LOCALBASE}/libexec/libtool
LIBTOOL_SHAREDIR= ${LOCALBASE}/share/libtool
LIBTOOL_M4= ${LOCALBASE}/share/aclocal/libtool.m4
-LTMAIN= ${LIBTOOL_SHAREDIR}/ltmain.sh
+LTMAIN= ${LIBTOOL_SHAREDIR}/config/ltmain.sh
LIBTOOL_VARS= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} LIBTOOL_M4=${LIBTOOL_M4}
LIBTOOL_DEPENDS= ${LIBTOOL}:${PORTSDIR}/devel/libtool${LIBTOOL_VERSION}