aboutsummaryrefslogtreecommitdiff
path: root/archivers/dpkg
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-06-11 20:45:39 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-06-11 20:45:39 +0000
commita3692db463880d20b805496c9d25b3a5d389ed1e (patch)
tree2f561fa27a25bde726ff70580899f8fbd5d8e033 /archivers/dpkg
parentba50b420f758f5b2f16819eda12ef7cb56a53afe (diff)
downloadports-a3692db463880d20b805496c9d25b3a5d389ed1e.tar.gz
ports-a3692db463880d20b805496c9d25b3a5d389ed1e.zip
- Update to version 1.18.1
- Our gzip don't support --rsyncable flag, add patch to fix it
Notes
Notes: svn path=/head/; revision=389251
Diffstat (limited to 'archivers/dpkg')
-rw-r--r--archivers/dpkg/Makefile9
-rw-r--r--archivers/dpkg/distinfo4
-rw-r--r--archivers/dpkg/files/patch-lib_compat_gettext.h2
-rw-r--r--archivers/dpkg/files/patch-scripts_Dpkg_Compression.pm11
4 files changed, 16 insertions, 10 deletions
diff --git a/archivers/dpkg/Makefile b/archivers/dpkg/Makefile
index 0e4a918c0cdc..cbecf9411f25 100644
--- a/archivers/dpkg/Makefile
+++ b/archivers/dpkg/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dpkg
-PORTVERSION= 1.18.0
-PORTREVISION= 1
+PORTVERSION= 1.18.1
CATEGORIES= archivers sysutils
MASTER_SITES= DEBIAN_POOL
DISTNAME= dpkg_${PORTVERSION}
@@ -29,7 +28,7 @@ SUB_FILES= pkg-install pkg-deinstall
SUB_LIST+= DPKGDIR=${DPKGDIR}
CONFIGURE_ARGS+=--with-admindir=${DPKGDIR} --libdir=${PREFIX}/libexec \
- --program-transform-name="" --with-libintl-prefix=${LOCALBASE} \
+ --with-libintl-prefix=${LOCALBASE} \
--with-logdir=/var/log
CONFIGURE_ENV+= PERL_LIBDIR="${PREFIX}/${SITE_PERL_REL}"
@@ -39,10 +38,6 @@ OPTIONS_SUB= yes
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
-post-patch:
- @${REINPLACE_CMD} '/^LDFLAGS/ s|$$| -lmd|' \
- ${WRKSRC}/lib/dpkg/Makefile.in
-
post-install:
(cd ${STAGEDIR}${DPKGDIR} && ${MKDIR} available diversions \
statoverride status)
diff --git a/archivers/dpkg/distinfo b/archivers/dpkg/distinfo
index c5e98a845945..aa1be48e158e 100644
--- a/archivers/dpkg/distinfo
+++ b/archivers/dpkg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dpkg_1.18.0.tar.xz) = 7b156fbeed5bbfb8aa546a18badb46e471b65fa00777ccd8d7e3bbce002f225a
-SIZE (dpkg_1.18.0.tar.xz) = 4330304
+SHA256 (dpkg_1.18.1.tar.xz) = cb26a97ca21c970cbe63a762125fe21f7437663badf6ce686589fe62650399da
+SIZE (dpkg_1.18.1.tar.xz) = 4340240
diff --git a/archivers/dpkg/files/patch-lib_compat_gettext.h b/archivers/dpkg/files/patch-lib_compat_gettext.h
index c2f60c451bcf..9598958acaee 100644
--- a/archivers/dpkg/files/patch-lib_compat_gettext.h
+++ b/archivers/dpkg/files/patch-lib_compat_gettext.h
@@ -1,4 +1,4 @@
---- lib/compat/gettext.h.orig 2015-05-07 18:40:12 UTC
+--- lib/compat/gettext.h.orig 2015-05-03 14:52:33 UTC
+++ lib/compat/gettext.h
@@ -53,7 +53,6 @@
<libintl.h>, which chokes if dcgettext is defined as a macro. So include
diff --git a/archivers/dpkg/files/patch-scripts_Dpkg_Compression.pm b/archivers/dpkg/files/patch-scripts_Dpkg_Compression.pm
new file mode 100644
index 000000000000..ad8ce0893d9f
--- /dev/null
+++ b/archivers/dpkg/files/patch-scripts_Dpkg_Compression.pm
@@ -0,0 +1,11 @@
+--- scripts/Dpkg/Compression.pm.orig 2015-06-11 20:28:56 UTC
++++ scripts/Dpkg/Compression.pm
+@@ -55,7 +55,7 @@ interact with the set of supported compr
+ my $COMP = {
+ gzip => {
+ file_ext => 'gz',
+- comp_prog => [ 'gzip', '--no-name', '--rsyncable' ],
++ comp_prog => [ 'gzip', '--no-name' ],
+ decomp_prog => [ 'gunzip' ],
+ default_level => 9,
+ },