aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-POE-Filter-Zlib/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-28 03:21:44 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-28 03:21:44 +0000
commit64bbf3e085c0342fbf46e54cbcd6b7dcff42b589 (patch)
tree18b56e175254787ec2939ad465fdff058d1d8b30 /archivers/p5-POE-Filter-Zlib/Makefile
parentb908b799ef74d646ccaf63fa84ad709364f09545 (diff)
downloadports-64bbf3e085c0342fbf46e54cbcd6b7dcff42b589.tar.gz
ports-64bbf3e085c0342fbf46e54cbcd6b7dcff42b589.zip
Add p5-POE-Filter-Zlib 1.2, a POE filter wrapped around Compress::Zlib.
PR: ports/100949 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=168919
Diffstat (limited to 'archivers/p5-POE-Filter-Zlib/Makefile')
-rw-r--r--archivers/p5-POE-Filter-Zlib/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/archivers/p5-POE-Filter-Zlib/Makefile b/archivers/p5-POE-Filter-Zlib/Makefile
new file mode 100644
index 000000000000..b96ba941869e
--- /dev/null
+++ b/archivers/p5-POE-Filter-Zlib/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-POE-Filter-Zlib
+# Date created: 2006-07-28
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Filter-Zlib
+PORTVERSION= 1.2
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A POE filter wrapped around Compress::Zlib
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Filter::Zlib.3
+
+.include <bsd.port.mk>