aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-POE-Filter-Zlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/p5-POE-Filter-Zlib/Makefile')
-rw-r--r--archivers/p5-POE-Filter-Zlib/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/archivers/p5-POE-Filter-Zlib/Makefile b/archivers/p5-POE-Filter-Zlib/Makefile
new file mode 100644
index 000000000000..b96ba941869e
--- /dev/null
+++ b/archivers/p5-POE-Filter-Zlib/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-POE-Filter-Zlib
+# Date created: 2006-07-28
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Filter-Zlib
+PORTVERSION= 1.2
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A POE filter wrapped around Compress::Zlib
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Filter::Zlib.3
+
+.include <bsd.port.mk>