aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2017-09-26 19:13:49 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2017-09-26 19:13:49 +0000
commitb90c8f8a63bceee4d24fabc25f71aaee76d304c5 (patch)
tree34541667dfb65c7108f2fd9b8f3e52a1969f712e /archivers
parent2b6d8e396c1bb73c33949a55a28a894ad0672c29 (diff)
downloadports-b90c8f8a63bceee4d24fabc25f71aaee76d304c5.tar.gz
ports-b90c8f8a63bceee4d24fabc25f71aaee76d304c5.zip
Add lazperf to the ports tree
and reenable databases/pointcloud PR: 221577
Notes
Notes: svn path=/head/; revision=450694
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/lazperf/Makefile23
-rw-r--r--archivers/lazperf/distinfo3
-rw-r--r--archivers/lazperf/files/patch-laz-perf_portable__endian.hpp16
-rw-r--r--archivers/lazperf/pkg-descr5
-rw-r--r--archivers/lazperf/pkg-plist22
6 files changed, 70 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index a42d0c69c97f..4aec29edace8 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -54,6 +54,7 @@
SUBDIR += kf5-karchive
SUBDIR += kzip
SUBDIR += laszip
+ SUBDIR += lazperf
SUBDIR += lbrate
SUBDIR += lbzip2
SUBDIR += lcab
diff --git a/archivers/lazperf/Makefile b/archivers/lazperf/Makefile
new file mode 100644
index 000000000000..6b095b21e1f5
--- /dev/null
+++ b/archivers/lazperf/Makefile
@@ -0,0 +1,23 @@
+# Created by: lbartoletti <lbartoletti@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= lazperf
+PORTVERSION= 1.1.0
+CATEGORIES= archivers databases geography
+
+MAINTAINER= lbartoletti@tuxfamily.org
+COMMENT= Alternative LAZ implementation for C++ and JavaScript
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cmake
+CMAKE_ARGS+= -DWITH_TESTS:BOOL=FALSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= hobu
+GH_PROJECT= laz-perf
+
+post-build:
+ ${RM} ${WRKSRC}/laz-perf/portable_endian.hpp.orig
+.include <bsd.port.mk>
diff --git a/archivers/lazperf/distinfo b/archivers/lazperf/distinfo
new file mode 100644
index 000000000000..e3a9777bbad0
--- /dev/null
+++ b/archivers/lazperf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502918669
+SHA256 (hobu-laz-perf-1.1.0_GH0.tar.gz) = 5413bb3e727d8b7155900f35b8f5e487eee418957d251fb3799d2cd3e17b2158
+SIZE (hobu-laz-perf-1.1.0_GH0.tar.gz) = 4025260
diff --git a/archivers/lazperf/files/patch-laz-perf_portable__endian.hpp b/archivers/lazperf/files/patch-laz-perf_portable__endian.hpp
new file mode 100644
index 000000000000..ea9f7f4b8dac
--- /dev/null
+++ b/archivers/lazperf/files/patch-laz-perf_portable__endian.hpp
@@ -0,0 +1,16 @@
+--- laz-perf/portable_endian.hpp.orig 2017-08-16 21:27:03 UTC
++++ laz-perf/portable_endian.hpp
+@@ -41,11 +41,11 @@
+ # define __PDP_ENDIAN PDP_ENDIAN
+ **/
+
+-#elif defined(__OpenBSD__) || defined(EMSCRIPTEN_OPEN_BSD)
++#elif defined(__OpenBSD__) || defined(__FreeBSD__) || defined(EMSCRIPTEN_OPEN_BSD)
+
+ # include <sys/endian.h>
+
+-#elif defined(__NetBSD__) || defined(__FreeBSD__) || defined(__DragonFly__) || defined(EMSCRIPTEN_BSD)
++#elif defined(__NetBSD__) || defined(__DragonFly__) || defined(EMSCRIPTEN_BSD)
+
+ # include <sys/endian.h>
+
diff --git a/archivers/lazperf/pkg-descr b/archivers/lazperf/pkg-descr
new file mode 100644
index 000000000000..0940f061f927
--- /dev/null
+++ b/archivers/lazperf/pkg-descr
@@ -0,0 +1,5 @@
+Alternative LAZ implementation. It supports compilation and usage in JavaScript,
+ usage in database contexts such as pgpointcloud and Oracle Point Cloud, and it
+executes faster than the LASzip codebase.
+
+WWW: https://github.com/hobu/laz-perf
diff --git a/archivers/lazperf/pkg-plist b/archivers/lazperf/pkg-plist
new file mode 100644
index 000000000000..8cd7d56f2ef4
--- /dev/null
+++ b/archivers/lazperf/pkg-plist
@@ -0,0 +1,22 @@
+include/laz-perf/common/common.hpp
+include/laz-perf/common/types.hpp
+include/laz-perf/compressor.hpp
+include/laz-perf/decoder.hpp
+include/laz-perf/decompressor.hpp
+include/laz-perf/detail/field_gpstime.hpp
+include/laz-perf/detail/field_point10.hpp
+include/laz-perf/detail/field_rgb.hpp
+include/laz-perf/detail/field_xyz.hpp
+include/laz-perf/encoder.hpp
+include/laz-perf/excepts.hpp
+include/laz-perf/factory.hpp
+include/laz-perf/formats.hpp
+include/laz-perf/io.hpp
+include/laz-perf/las.hpp
+include/laz-perf/main.cpp
+include/laz-perf/model.hpp
+include/laz-perf/portable_endian.hpp
+include/laz-perf/streams.hpp
+include/laz-perf/util.hpp
+lib/cmake/lazperf/lazperf-config.cmake
+lib/cmake/lazperf/lazperf-configVersion.cmake