aboutsummaryrefslogtreecommitdiff
path: root/astro/mepo
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-09-20 21:38:11 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-09-23 18:40:05 +0000
commit8fe61f2101afb2e8f259a9a6ee4b4de557e925c7 (patch)
tree684e271ab3f03253404aeb3a8e9fbffd0a6963d8 /astro/mepo
parentadd1cd7e99d8be56ebd85bb3fef1c38cd8989fec (diff)
downloadports-8fe61f2101afb2e8f259a9a6ee4b4de557e925c7.tar.gz
ports-8fe61f2101afb2e8f259a9a6ee4b4de557e925c7.zip
astro/mepo: add new port
Mepo is a fast, simple, and hackable OSM map viewer for desktop & mobile Linux devices (like the PinePhone, Librem 5, pmOS devices etc.) and both environment's various user interfaces (Wayland & X inclusive). Mepo works both offline and online, features a minimalist both touch/mouse and keyboard compatible interface, and offers a UNIX-philosophy inspired underlying design, exposing a powerful command language called Mepolang capable of being scripted to provide things like custom bounding-box search scripts, bookmarks, and more. https://sr.ht/~mil/Mepo/
Diffstat (limited to 'astro/mepo')
-rw-r--r--astro/mepo/Makefile43
-rw-r--r--astro/mepo/distinfo3
-rw-r--r--astro/mepo/pkg-descr8
-rw-r--r--astro/mepo/pkg-plist24
4 files changed, 78 insertions, 0 deletions
diff --git a/astro/mepo/Makefile b/astro/mepo/Makefile
new file mode 100644
index 000000000000..da0f836e5f15
--- /dev/null
+++ b/astro/mepo/Makefile
@@ -0,0 +1,43 @@
+PORTNAME= mepo
+DISTVERSION= 1.0_rc1
+CATEGORIES= astro geography wayland
+MASTER_SITES= https://git.sr.ht/~mil/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Fast, simple, and hackable OSM map viewer
+WWW= https://sr.ht/~mil/Mepo/
+
+LICENSE= GPLv3+ OFL11
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= zig>=0.9.0:lang/zig
+LIB_DEPENDS= libcurl.so:ftp/curl
+RUN_DEPENDS= jq:textproc/jq
+
+USES= pkgconfig sdl shebangfix
+USE_SDL= gfx2 image2 ttf2
+SHEBANG_FILES= scripts/*
+SHEBANG_LANG= sh
+sh_CMD= /bin/sh
+MAKE_ENV= DESTDIR="${STAGEDIR}"
+CONFIGURE_ARGS= --prefix "${PREFIX}" \
+ ${WITH_DEBUG:D:U-Drelease-fast} \
+ -Dcpu=${CPUTYPE:Ubaseline} \
+ --verbose
+NO_INSTALL= yes # strip(1) breaks runtime
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr,${LOCALBASE},' \
+ ${WRKSRC}/scripts/mepo_ui_menu_user_pin_updater.sh
+ @${REINPLACE_CMD} -e 's/pidof/pgrep/' \
+ -e 's/busctl/basuctl/' \
+ ${WRKSRC}/scripts/mepo_ui_helper_menu.sh
+
+do-build:
+ @(cd ${WRKSRC} && ${MAKE_ENV} zig build ${CONFIGURE_ARGS})
+
+do-test:
+ @(cd ${WRKSRC} && ${TEST_ENV} zig build test ${CONFIGURE_ARGS})
+
+.include <bsd.port.mk>
diff --git a/astro/mepo/distinfo b/astro/mepo/distinfo
new file mode 100644
index 000000000000..af91391d495b
--- /dev/null
+++ b/astro/mepo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1663709891
+SHA256 (mepo-1.0_rc1.tar.gz) = 6ed729463a0244d7425c05e92cbef69fc456a39975d93912678b82c140e2afb0
+SIZE (mepo-1.0_rc1.tar.gz) = 5426562
diff --git a/astro/mepo/pkg-descr b/astro/mepo/pkg-descr
new file mode 100644
index 000000000000..9e82c97f6178
--- /dev/null
+++ b/astro/mepo/pkg-descr
@@ -0,0 +1,8 @@
+Mepo is a fast, simple, and hackable OSM map viewer for desktop & mobile
+Linux devices (like the PinePhone, Librem 5, pmOS devices etc.) and both
+environment's various user interfaces (Wayland & X inclusive). Mepo
+works both offline and online, features a minimalist both touch/mouse
+and keyboard compatible interface, and offers a UNIX-philosophy
+inspired underlying design, exposing a powerful command language called
+Mepolang capable of being scripted to provide things like custom
+bounding-box search scripts, bookmarks, and more.
diff --git a/astro/mepo/pkg-plist b/astro/mepo/pkg-plist
new file mode 100644
index 000000000000..e3a75f57e892
--- /dev/null
+++ b/astro/mepo/pkg-plist
@@ -0,0 +1,24 @@
+bin/mepo
+bin/mepo_dl.sh
+bin/mepo_generated_osmtags.sh
+bin/mepo_ui_central_menu.sh
+bin/mepo_ui_helper_menu.sh
+bin/mepo_ui_helper_pref_pan.sh
+bin/mepo_ui_menu_dbg_queueclear.sh
+bin/mepo_ui_menu_dbg_queuedownloadinteractive.sh
+bin/mepo_ui_menu_dbg_queuedownloadnoninteractive.sh
+bin/mepo_ui_menu_pin_editor.sh
+bin/mepo_ui_menu_pref_fontsize.sh
+bin/mepo_ui_menu_pref_network.sh
+bin/mepo_ui_menu_pref_url.sh
+bin/mepo_ui_menu_pref_zoom.sh
+bin/mepo_ui_menu_reposition_nominatim.sh
+bin/mepo_ui_menu_route_graphhopper.sh
+bin/mepo_ui_menu_route_overpassrelation.sh
+bin/mepo_ui_menu_search_nominatim.sh
+bin/mepo_ui_menu_search_overpass.sh
+bin/mepo_ui_menu_user_pin_updater.sh
+share/applications/mepo.desktop
+share/icons/hicolor/128x128/apps/mepo.png
+share/icons/hicolor/512x512/apps/mepo.png
+share/pixmaps/mepo.png