aboutsummaryrefslogtreecommitdiff
path: root/astro/wmglobe/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-26 12:11:15 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-26 12:11:15 +0000
commit754b55a16325c16bfaf1fbe6a0c490f0ffb37b72 (patch)
tree9e11cf7eca412c04f6e65e861e8db4fa436cd644 /astro/wmglobe/Makefile
parenta01331d6efbadbf98d60e4677a70627c2fba767f (diff)
downloadports-754b55a16325c16bfaf1fbe6a0c490f0ffb37b72.tar.gz
ports-754b55a16325c16bfaf1fbe6a0c490f0ffb37b72.zip
Resurrect astro/wmglobe
- The distfile is available again on dockapps.net - Add some missing dependencies as reported by stage-qa - Assign port to the submitter PR: 226675 Submitted by: jd.fbsd@goneja.de
Notes
Notes: svn path=/head/; revision=491271
Diffstat (limited to 'astro/wmglobe/Makefile')
-rw-r--r--astro/wmglobe/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/astro/wmglobe/Makefile b/astro/wmglobe/Makefile
new file mode 100644
index 000000000000..52ac6ba44b4f
--- /dev/null
+++ b/astro/wmglobe/Makefile
@@ -0,0 +1,24 @@
+# Created by: Will Andrews <andrews@technologist.com>
+# $FreeBSD$
+
+PORTNAME= wmglobe
+PORTVERSION= 1.3
+PORTREVISION= 11
+CATEGORIES= astro windowmaker geography
+MASTER_SITES= https://www.dockapps.net/download/
+
+MAINTAINER= jd.fbsd@goneja.de
+COMMENT= Neat xearth-like WindowMaker dockapp
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libwraster.so:x11-wm/libwraster
+
+USE_XORG= x11 xext xpm
+
+PLIST_FILES= bin/wmglobe \
+ man/man1/wmglobe.1.gz
+MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
+
+.include <bsd.port.mk>