aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-07 21:42:28 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-07 21:42:28 +0000
commite730d999d3dd8305cbcbc35b739703175d0c2d68 (patch)
tree34ed59c815a96dcd021876d917ebc81830b5dedf /astro
parent2660d9ede27778db5ed22c2ab82560b9533cdf86 (diff)
downloadports-e730d999d3dd8305cbcbc35b739703175d0c2d68.tar.gz
ports-e730d999d3dd8305cbcbc35b739703175d0c2d68.zip
Add more PLIST_SUB to Mk/Uses/python.mk
- Add PYTHON_PYOEXTENSION and PYTHON_SUFFIX - Add PYTHON2 and PYTHON3 - Respect PYTHON_VERSION - Rename PYOEXTENSION to PYTHON_PYOEXTENSION This change would help: - Build databases/postgresql*-plpython with Python 3 (It has PLIST issue since bsd.python.mk to Uses/python.mk transition) - Simplify Makefile PR: 205807 Differential Revision: https://reviews.FreeBSD.org/D4758 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=430839
Diffstat (limited to 'astro')
-rw-r--r--astro/weather/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/astro/weather/Makefile b/astro/weather/Makefile
index bc86b77b57d6..06b7366f2c54 100644
--- a/astro/weather/Makefile
+++ b/astro/weather/Makefile
@@ -13,6 +13,7 @@ COMMENT= Utility to provide current weather conditions and forecasts
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
+NO_ARCH= yes
USES= python shebangfix tar:xz
PLIST_FILES= bin/${PORTNAME} \
@@ -35,12 +36,6 @@ PYCACHE_DIR= __pycache__/
PYCACHE_FILE= ${PORTNAME}.cpython-${PYTHON_SUFFIX}
.endif
-.if ${PYTHON_REL} < 3500
-PYTHON_PYOEXTENSION= pyo
-.else
-PYTHON_PYOEXTENSION= opt-1.pyc
-.endif
-
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}/${PORTNAME}.py
@${PYTHON_CMD} -O -m compileall ${WRKSRC}/${PORTNAME}.py