aboutsummaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-07-02 01:03:40 +0000
committerPatrick Li <pat@FreeBSD.org>2002-07-02 01:03:40 +0000
commitfd39b58ad1825ad210a75ed4282d1632c2e95f12 (patch)
tree159a02c1e0bb56673001f98ba68e45d6a1e7f35c /astro
parent7cc96e69922782bac43b2c0ba38a180808b4ec5f (diff)
downloadports-fd39b58ad1825ad210a75ed4282d1632c2e95f12.tar.gz
ports-fd39b58ad1825ad210a75ed4282d1632c2e95f12.zip
Update to 1.23.r9
PR: ports/39950 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=62305
Diffstat (limited to 'astro')
-rw-r--r--astro/gpsdrive/Makefile21
-rw-r--r--astro/gpsdrive/distinfo2
-rw-r--r--astro/gpsdrive/files/patch-src-Makefile.in (renamed from astro/gpsdrive/files/patch-src::Makefile.in)10
-rw-r--r--astro/gpsdrive/files/patch-src-em.c20
-rw-r--r--astro/gpsdrive/files/patch-src-gpsd.c128
-rw-r--r--astro/gpsdrive/files/patch-src-tm.c12
-rw-r--r--astro/gpsdrive/pkg-descr2
-rw-r--r--astro/gpsdrive/pkg-message6
-rw-r--r--astro/gpsdrive/pkg-plist13
9 files changed, 197 insertions, 17 deletions
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index 14d566417c14..c240646edfe7 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -6,27 +6,34 @@
#
PORTNAME= gpsdrive
-PORTVERSION= 1.20.r1
+PORTVERSION= 1.23.r9
CATEGORIES= astro
-MASTER_SITES= http://www.kraftvoll.at/software/ \
- http://ganter.quant-x.at/software/
+MASTER_SITES= http://gpsdrive.kraftvoll.at/ \
+ http://gpsdrive.teachlinux.com/ \
+ http://gpsdrive.flugfunk.de/ \
+ http://gpsdrive.alumnosfdi.org/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/pre/}
MAINTAINER= molter@gufi.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+BUILD_DEPENDS= ${X11BASE}/bin/gdk-pixbuf-config:${PORTSDIR}/graphics/gdk-pixbuf
+USE_PERL5= yes
USE_GLIB= yes
USE_GMAKE= yes
USE_GTK= yes
USE_LIBTOOL= yes
-
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --with-debug \
+ --disable-garmin
INSTALLS_SHLIB= yes
MAN1= gpsdrive.1
MANLANG= "" de es
+post-install:
+ @${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g'
+
.include <bsd.port.mk>
diff --git a/astro/gpsdrive/distinfo b/astro/gpsdrive/distinfo
index 7129910abd36..55a98ad14048 100644
--- a/astro/gpsdrive/distinfo
+++ b/astro/gpsdrive/distinfo
@@ -1 +1 @@
-MD5 (gpsdrive-1.20pre1.tar.gz) = a66ff1b6b12dd534ad91bb7ccb2b1316
+MD5 (gpsdrive-1.23pre9.tar.gz) = 86dd789483edd37125f863c2c7bf6741
diff --git a/astro/gpsdrive/files/patch-src::Makefile.in b/astro/gpsdrive/files/patch-src-Makefile.in
index 617d3ddde6de..83d63c16f1f5 100644
--- a/astro/gpsdrive/files/patch-src::Makefile.in
+++ b/astro/gpsdrive/files/patch-src-Makefile.in
@@ -1,7 +1,5 @@
-$FreeBSD$
-
---- src/Makefile.in.orig Mon Apr 29 15:47:49 2002
-+++ src/Makefile.in Tue Apr 30 17:23:55 2002
+--- src/Makefile.in~ Thu May 23 12:19:57 2002
++++ src/Makefile.in Thu May 23 12:21:24 2002
@@ -120,7 +120,7 @@
bin_PROGRAMS = $(PRG1) gpsdrive gpsd friendsd
@@ -11,7 +9,7 @@ $FreeBSD$
# gpsdrive_CFLAGS=@CFLAGS@
# libgpsd_a_CFLAGS=@CFLAGS@
# CFLAGS=
-@@ -172,7 +172,7 @@
+@@ -177,7 +177,7 @@
am_friendsd_OBJECTS = friendsd.$(OBJEXT)
friendsd_OBJECTS = $(am_friendsd_OBJECTS)
@@ -20,7 +18,7 @@ $FreeBSD$
friendsd_DEPENDENCIES =
friendsd_LDFLAGS =
@DISABLEGARMIN_TRUE@am_garble_OBJECTS =
-@@ -182,7 +182,7 @@
+@@ -187,7 +187,7 @@
@DISABLEGARMIN_FALSE@ garmin_link.$(OBJEXT) \
@DISABLEGARMIN_FALSE@ garmin_util.$(OBJEXT)
garble_OBJECTS = $(am_garble_OBJECTS)
diff --git a/astro/gpsdrive/files/patch-src-em.c b/astro/gpsdrive/files/patch-src-em.c
new file mode 100644
index 000000000000..1c2238163cfd
--- /dev/null
+++ b/astro/gpsdrive/files/patch-src-em.c
@@ -0,0 +1,20 @@
+--- src/em.c~ Tue Apr 16 15:06:51 2002
++++ src/em.c Thu Jun 27 17:54:05 2002
+@@ -362,7 +362,8 @@
+ char *bufp;
+ char *bufp2;
+ int i = 0, j = 0, nmea = 0;
+- int fd, nfds;
++ int fd;
++ extern int nfds;
+
+ if (p[h->ndata] == em_checksum (p, h->ndata))
+ {
+@@ -475,7 +476,6 @@
+ }
+ if (nmea > 0)
+ {
+- nfds = getdtablesize ();
+ if (debug > 4)
+ fprintf (stderr, "%s", buf);
+ for (fd = 0; fd < nfds; fd++)
diff --git a/astro/gpsdrive/files/patch-src-gpsd.c b/astro/gpsdrive/files/patch-src-gpsd.c
new file mode 100644
index 000000000000..58fcd74e4ab9
--- /dev/null
+++ b/astro/gpsdrive/files/patch-src-gpsd.c
@@ -0,0 +1,128 @@
+--- src/gpsd.c~ Fri Apr 19 20:26:14 2002
++++ src/gpsd.c Thu Jun 27 18:02:12 2002
+@@ -78,27 +78,31 @@
+ int debug = 0;
+ int device_speed = B4800;
+ int device_type;
++int nfds; /* number of file descriptors to select() for */
+ char *device_name = 0;
+ char *latitude = 0;
+ char *longitude = 0;
+ char latd = 'N';
+ char lond = 'W';
+- /* command line option defaults */
+-char *default_device_name = "/dev/gps";
+-char *default_latitude = "3600.000";
+-char *default_longitude = "-12300.000";
+-
+-int nfds, dsock;
+-int verbose = 1;
+-int bincount;
+
+-int reopen = 0;
++/* command line option defaults */
++static char *default_device_name = "/dev/gps";
++static char *default_latitude = "3600.000";
++static char *default_longitude = "-12300.000";
++
++static int dsock; /* socket to dpgs server */
++
++/* If set, close (and reopen?) the serial interface. Triggered by SIGUSR1. */
++static int reopen = 0;
++
+
+ static int handle_input (int input, fd_set * afds, fd_set * nmea_fds);
+-extern int handle_EMinput (int input, fd_set * afds, fd_set * nmea_fds);
+ static int handle_request (int fd, fd_set * fds);
+-int connectsock (char *host, char *service, char *protocol);
+-void em_send_rtcm (unsigned short *rtcmbuf, int rtcmbytes);
++
++extern int handle_EMinput (int input, fd_set * afds, fd_set * nmea_fds);
++extern int connectsock (char *host, char *service, char *protocol);
++extern void em_send_rtcm (unsigned short *rtcmbuf, int rtcmbytes);
++
+
+ static void
+ onsig (int sig)
+@@ -164,16 +168,17 @@
+ char *default_service = "gpsd";
+ char *default_dgpsserver = "dgps.wsrcc.com";
+ char *default_dgpsport = "rtcm-sc104";
+- char *service = 0;
++ char *service = 0; /* port number to listen to */
+ char *dgpsport = 0;
+ char *dgpsserver = 0;
+ struct sockaddr_in fsin;
+- int msock;
++ int msock; /* listening socket fd */
+ fd_set rfds;
+ fd_set afds;
+ fd_set nmea_fds;
+ int alen;
+- int fd, input;
++ int fd;
++ int input; /* GPS device fd */
+ int need_gps, need_dgps = 0, need_init = 1;
+ extern char *optarg;
+ int option;
+@@ -273,17 +278,18 @@
+ default:
+ fputs ("usage: gpsd [options] \n\
+ options include: \n\
+- -D integer [ set debug level ] \n\
++ -D level [ set debug level. If >= 2, remain in foreground ] \n\
+ -L longitude [ set longitude ] \n\
+- -S integer [ set port for daemon ] \n\
+- -T e [ earthmate flag ] \n\
+- -h [ help message ] \n\
+ -l latitude [ set latitude ] \n\
+- -p string [ set gps device name ] \n\
++ -S port [ set gpsd listening port ] \n\
++ -T type [ set DeLorme models. e = Earthmate, t = Tripmate ] \n\
++ -h [ help message ] \n\
++ -p path [ set gps device pathname ] \n\
+ -s baud_rate [ set baud rate on gps device ] \n\
+ -c [ use dgps service for corrections ] \n\
+- -d host [ set dgps server ] \n\
+- -r port [ set dgps rtcm-sc104 port ] \n\
++ -d host [ set dgps server hostname] \n\
++ -r port [ set dgps server port ] \n\
++ -n [ disable setting default values for longitute and latitute ] \n\
+ ", stderr);
+ exit (0);
+ }
+@@ -354,8 +360,11 @@
+ need_dgps = 0;
+ }
+ }
+-
+- nfds = getdtablesize ();
++#ifndef min
++#define min(a, b) (((a) < (b)) ? (a) : (b))
++#endif
++ /* still wrong, but at least do not coredump */
++ nfds = min (getdtablesize (), FD_SETSIZE);
+
+ FD_ZERO (&afds);
+ FD_ZERO (&nmea_fds);
+@@ -375,10 +384,9 @@
+
+ while (1)
+ {
+- memcpy ((char *) &rfds, (char *) &afds, sizeof (rfds));
++ memcpy (&rfds, &afds, sizeof (rfds));
+
+- if (select (nfds, &rfds, (fd_set *) 0, (fd_set *) 0,
+- (struct timeval *) 0) < 0)
++ if (select (nfds, &rfds, NULL, NULL, NULL) < 0)
+ {
+ if (errno == EINTR)
+ continue;
+@@ -599,6 +607,7 @@
+ {
+ static unsigned char buf[BUFSIZE]; /* that is more then a sentence */
+ static int offset = 0;
++ static int bincount;
+ int fd;
+
+ while (offset < BUFSIZE)
diff --git a/astro/gpsdrive/files/patch-src-tm.c b/astro/gpsdrive/files/patch-src-tm.c
new file mode 100644
index 000000000000..a9ba3fe7fe37
--- /dev/null
+++ b/astro/gpsdrive/files/patch-src-tm.c
@@ -0,0 +1,12 @@
+--- src/tm.c~ Fri Apr 5 19:59:45 2002
++++ src/tm.c Wed Jun 26 13:35:52 2002
+@@ -19,6 +19,9 @@
+ extern char latd;
+ extern char lond;
+
++void do_eminit ();
++
++
+ void process_message(char *sentence)
+ {
+ if (checksum(sentence)) {
diff --git a/astro/gpsdrive/pkg-descr b/astro/gpsdrive/pkg-descr
index 539ae6cc59ae..a6f0e2fe7c24 100644
--- a/astro/gpsdrive/pkg-descr
+++ b/astro/gpsdrive/pkg-descr
@@ -6,7 +6,7 @@ the position and prefered scale. Speech output is supported if the "festival"
software is running. GpsDrive is written in C with use of the GTK+ graphic
toolkit.
-WWW: http://ganter.quant-x.at/software/
+WWW: http://gpsdrive.kraftvoll.at/
- Marco
molter@gufi.org
diff --git a/astro/gpsdrive/pkg-message b/astro/gpsdrive/pkg-message
new file mode 100644
index 000000000000..260088bb890f
--- /dev/null
+++ b/astro/gpsdrive/pkg-message
@@ -0,0 +1,6 @@
+
+NOTES:
+
+Support for Garmin format input is disabled because buggy.
+Set your GPS device to NMEA mode and start gpsd before gpsdrive.
+
diff --git a/astro/gpsdrive/pkg-plist b/astro/gpsdrive/pkg-plist
index 12b7e8f3fe5b..6cfdc405c49a 100644
--- a/astro/gpsdrive/pkg-plist
+++ b/astro/gpsdrive/pkg-plist
@@ -1,18 +1,25 @@
bin/friendsd
-bin/garble
bin/gpsd
bin/gpsdrive
bin/gpsfetchmap
+bin/gpsfetchmap.pl
+bin/mb2gpsdrive.pl
bin/wpcvt
bin/wpget
lib/libfly.a
lib/libfly.so
-lib/libfly.so.1
+lib/libfly.so.2
+lib/libnautic.a
+lib/libnautic.so
+lib/libnautic.so.2
share/gpsdrive/friendsicon.png
share/gpsdrive/gpsdrive/AUTHORS
share/gpsdrive/gpsdrive/GPS-receivers
share/gpsdrive/gpsdrive/LEEME
+share/gpsdrive/gpsdrive/LISEZMOI
share/gpsdrive/gpsdrive/README
+share/gpsdrive/gpsdrive/README.FreeBSD
+share/gpsdrive/gpsdrive/README.mb2gpsdrive
share/gpsdrive/gpsdrive/TODO
share/gpsdrive/gpsdrivesplash.png
share/locale/da/LC_MESSAGES/gpsdrive.mo
@@ -25,6 +32,8 @@ share/locale/it/LC_MESSAGES/gpsdrive.mo
share/locale/nl/LC_MESSAGES/gpsdrive.mo
share/locale/pt/LC_MESSAGES/gpsdrive.mo
share/locale/ru/LC_MESSAGES/gpsdrive.mo
+share/locale/sk/LC_MESSAGES/gpsdrive.mo
+share/locale/sv/LC_MESSAGES/gpsdrive.mo
share/locale/tr/LC_MESSAGES/gpsdrive.mo
share/locale/xx/LC_MESSAGES/gpsdrive.mo
@dirrm share/gpsdrive/gpsdrive