aboutsummaryrefslogtreecommitdiff
path: root/audio/libbs2b/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-22 04:42:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-22 04:42:32 +0000
commitd38d75133ae104aa976990329feebb6ed291cfe9 (patch)
treea7b9854cbcd72d4735f54817e46e39d94e9ea254 /audio/libbs2b/Makefile
parent43cc26ad977af5d5c13e9d98b35f3c92f88213ed (diff)
downloadports-d38d75133ae104aa976990329feebb6ed291cfe9.tar.gz
ports-d38d75133ae104aa976990329feebb6ed291cfe9.zip
The Bauer stereophonic-to-binaural DSP (bs2b) is designed
to improve headphone listening of stereo audio records. WWW: http://bs2b.sourceforge.net/ PR: ports/146814 Submitted by: SimaMoto,RyoTa <liangtai.s4 at gmail.com>
Notes
Notes: svn path=/head/; revision=254785
Diffstat (limited to 'audio/libbs2b/Makefile')
-rw-r--r--audio/libbs2b/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/libbs2b/Makefile b/audio/libbs2b/Makefile
new file mode 100644
index 000000000000..85ed66867a08
--- /dev/null
+++ b/audio/libbs2b/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libbs2b
+# Date created: 22 May 2010
+# Whom: SimaMoto,RyoTa <liangtai.s4@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbs2b
+PORTVERSION= 3.1.0
+CATEGORIES= audio
+MASTER_SITES= SF/bs2b/bs2b/${PORTVERSION}
+
+MAINTAINER= liangtai.s4@gmail.com
+COMMENT= Bauer Stereophonic-to-Binaural DSP
+
+LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
+
+USE_PKGCONFIG= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= CFLAGS=`pkg-config --cflags sndfile` \
+ LDFLAGS=`pkg-config --libs-only-L sndfile`
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's@^\(pkgconfigdir = \).*@\1$${prefix}/libdata/pkgconfig@' \
+ ${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>