aboutsummaryrefslogtreecommitdiff
path: root/audio/streamripper/Makefile
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2007-09-20 21:14:24 +0000
committerLars Engels <lme@FreeBSD.org>2007-09-20 21:14:24 +0000
commit11ed3c722f7b65e3f5446df8c2300f628bd08f1f (patch)
tree3355ddff29393b16e21ee4433871738820659bf5 /audio/streamripper/Makefile
parentb22b4945e3de0a3713bd30ab70b97870281a515e (diff)
downloadports-11ed3c722f7b65e3f5446df8c2300f628bd08f1f.tar.gz
ports-11ed3c722f7b65e3f5446df8c2300f628bd08f1f.zip
Update to 1.62.1
PR: 114736 Submitted by: KATO Tsuguru <tkato432 (at) yahoo.com> Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=199840
Diffstat (limited to 'audio/streamripper/Makefile')
-rw-r--r--audio/streamripper/Makefile50
1 files changed, 34 insertions, 16 deletions
diff --git a/audio/streamripper/Makefile b/audio/streamripper/Makefile
index dfc298f28f6e..e46891ba4a31 100644
--- a/audio/streamripper/Makefile
+++ b/audio/streamripper/Makefile
@@ -6,36 +6,54 @@
#
PORTNAME= streamripper
-PORTVERSION= 1.61.27
-PORTREVISION= 1
+PORTVERSION= 1.62.1
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= streamripper
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Splits SHOUTcast stream into tracks
-LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad
+LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
+ tre.6:${PORTSDIR}/textproc/libtre
+OPTIONS= FAAD "Include FAAD mpeg4 codec support" on \
+ VORBIS "Include Ogg Vorbis codec support" on
+
+USE_GNOME= gnometarget
USE_ICONV= yes
-OPTIONS= VORBIS "Include Ogg Vorbis codec support" on
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --without-included-libmad \
+ --without-included-tre \
+ --with-included-argv
+CFLAGS+= -DANSI_PROTOTYPES -DHAVE_LANGINFO_CODESET
+
+MAN1= streamripper.1
+PLIST_FILES= bin/cstreamripper bin/streamripper
.include <bsd.port.pre.mk>
-.ifdef(WITH_VORBIS)
-LIB_DEPENDS+= ogg.5:${PORTSDIR}/audio/libogg \
- vorbis.4:${PORTSDIR}/audio/libvorbis
+.if defined(WITHOUT_FAAD)
+CONFIGURE_ARGS+= ac_cv_lib_faad_NeAACDecDecode2=no
+.else
+LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
.endif
-GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITHOUT_VORBIS)
+CONFIGURE_ARGS+= --without-ogg
+.else
+LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.endif
-PLIST_FILES= bin/streamripper
-MAN1= streamripper.1
+post-patch:
+ @${REINPLACE_CMD} -e '/if test/s|==|=|g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-pre-install:
- @${CHMOD} +x ${WRKSRC}/install-sh
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cstreamripper ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/streamripper ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/streamripper.1 ${MANPREFIX}/man/man1
.include <bsd.port.post.mk>