aboutsummaryrefslogtreecommitdiff
path: root/biology/bwa
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2015-09-25 18:39:36 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2015-09-25 18:39:36 +0000
commit164e1138b86d9d5bf75a6047a99fa1e3ea9838e1 (patch)
tree1816a81c2b39ffba1cfe73f7b10c31039dd0ef40 /biology/bwa
parente20b08bbfc9e31ec7e94169dffc0abe1ed290e66 (diff)
downloadports-164e1138b86d9d5bf75a6047a99fa1e3ea9838e1.tar.gz
ports-164e1138b86d9d5bf75a6047a99fa1e3ea9838e1.zip
BWA is a program for aligning sequencing reads against a large reference
genome (e.g. human genome). It has two major components, one for read shorter than 150bp and the other for longer reads. WWW: http://sourceforge.net/projects/bio-bwa/ PR: 203158 Submitted by: Jason Bacon <jwbacon@tds.net>
Notes
Notes: svn path=/head/; revision=397851
Diffstat (limited to 'biology/bwa')
-rw-r--r--biology/bwa/Makefile28
-rw-r--r--biology/bwa/distinfo2
-rw-r--r--biology/bwa/files/patch-Makefile11
-rw-r--r--biology/bwa/files/patch-bwt_lite.c11
-rw-r--r--biology/bwa/files/patch-bwtgap.c11
-rw-r--r--biology/bwa/files/patch-bwtgap.h15
-rw-r--r--biology/bwa/pkg-descr5
7 files changed, 83 insertions, 0 deletions
diff --git a/biology/bwa/Makefile b/biology/bwa/Makefile
new file mode 100644
index 000000000000..c2678e0f6c76
--- /dev/null
+++ b/biology/bwa/Makefile
@@ -0,0 +1,28 @@
+# Created by: Jason Bacon <jwbacon@tds.net>
+# $FreeBSD$
+
+PORTNAME= bwa
+PORTVERSION= 0.7.9a
+CATEGORIES= biology
+MASTER_SITES= SF/bio-bwa/
+
+MAINTAINER= jwbacon@tds.net
+COMMENT= Burrows-Wheeler sequence aligner
+
+LICENSE= GPLv3
+
+USES= perl5 shebangfix tar:bzip2
+SHEBANG_FILES= qualfa2fq.pl xa2multi.pl
+USE_PERL5= run
+
+PLIST_FILES= bin/bwa bin/qualfa2fq.pl bin/xa2multi.pl man/man1/bwa.1.gz
+
+# Avoid #error in emmintrin.h
+CFLAGS+= -msse2
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bwa ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.pl ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/biology/bwa/distinfo b/biology/bwa/distinfo
new file mode 100644
index 000000000000..70c5bb90053e
--- /dev/null
+++ b/biology/bwa/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bwa-0.7.9a.tar.bz2) = f5ad30e4e5ea86a8dcd6febcb6f620a75c82b03024f64a572017c295a962eadc
+SIZE (bwa-0.7.9a.tar.bz2) = 166193
diff --git a/biology/bwa/files/patch-Makefile b/biology/bwa/files/patch-Makefile
new file mode 100644
index 000000000000..e7d704d5e0b3
--- /dev/null
+++ b/biology/bwa/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2014-05-19 13:11:41 UTC
++++ Makefile
+@@ -1,6 +1,6 @@
+-CC= gcc
++CC?= gcc
+ #CC= clang --analyze
+-CFLAGS= -g -Wall -Wno-unused-function -O2
++CFLAGS?= -g -Wall -Wno-unused-function -O2
+ WRAP_MALLOC=-DUSE_MALLOC_WRAPPERS
+ AR= ar
+ DFLAGS= -DHAVE_PTHREAD $(WRAP_MALLOC)
diff --git a/biology/bwa/files/patch-bwt_lite.c b/biology/bwa/files/patch-bwt_lite.c
new file mode 100644
index 000000000000..e5059bc744a9
--- /dev/null
+++ b/biology/bwa/files/patch-bwt_lite.c
@@ -0,0 +1,11 @@
+--- bwt_lite.c.orig 2014-05-19 13:11:41 UTC
++++ bwt_lite.c
+@@ -48,7 +48,7 @@ bwtl_t *bwtl_seq2bwtl(int len, const uin
+ }
+ { // generate cnt_table
+ for (i = 0; i != 256; ++i) {
+- u_int32_t j, x = 0;
++ uint32_t j, x = 0;
+ for (j = 0; j != 4; ++j)
+ x |= (((i&3) == j) + ((i>>2&3) == j) + ((i>>4&3) == j) + (i>>6 == j)) << (j<<3);
+ b->cnt_table[i] = x;
diff --git a/biology/bwa/files/patch-bwtgap.c b/biology/bwa/files/patch-bwtgap.c
new file mode 100644
index 000000000000..2ede8889940b
--- /dev/null
+++ b/biology/bwa/files/patch-bwtgap.c
@@ -0,0 +1,11 @@
+--- bwtgap.c.orig 2014-02-25 21:20:01 UTC
++++ bwtgap.c
+@@ -58,7 +58,7 @@ static inline void gap_push(gap_stack_t
+ q->stack = (gap_entry_t*)realloc(q->stack, sizeof(gap_entry_t) * q->m_entries);
+ }
+ p = q->stack + q->n_entries;
+- p->info = (u_int32_t)score<<21 | i; p->k = k; p->l = l;
++ p->info = (uint32_t)score<<21 | i; p->k = k; p->l = l;
+ p->n_mm = n_mm; p->n_gapo = n_gapo; p->n_gape = n_gape;
+ p->n_ins = n_ins; p->n_del = n_del;
+ p->state = state;
diff --git a/biology/bwa/files/patch-bwtgap.h b/biology/bwa/files/patch-bwtgap.h
new file mode 100644
index 000000000000..f00ed0f7509f
--- /dev/null
+++ b/biology/bwa/files/patch-bwtgap.h
@@ -0,0 +1,15 @@
+--- bwtgap.h.orig 2014-02-25 21:20:01 UTC
++++ bwtgap.h
+@@ -5,9 +5,9 @@
+ #include "bwtaln.h"
+
+ typedef struct { // recursion stack
+- u_int32_t info; // score<<21 | i
+- u_int32_t n_mm:8, n_gapo:8, n_gape:8, state:2, n_seed_mm:6;
+- u_int32_t n_ins:16, n_del:16;
++ uint32_t info; // score<<21 | i
++ uint32_t n_mm:8, n_gapo:8, n_gape:8, state:2, n_seed_mm:6;
++ uint32_t n_ins:16, n_del:16;
+ int last_diff_pos;
+ bwtint_t k, l; // (k,l) is the SA region of [i,n-1]
+ } gap_entry_t;
diff --git a/biology/bwa/pkg-descr b/biology/bwa/pkg-descr
new file mode 100644
index 000000000000..2e40ad084670
--- /dev/null
+++ b/biology/bwa/pkg-descr
@@ -0,0 +1,5 @@
+BWA is a program for aligning sequencing reads against a large reference
+genome (e.g. human genome). It has two major components, one for read shorter
+than 150bp and the other for longer reads.
+
+WWW: http://sourceforge.net/projects/bio-bwa/