aboutsummaryrefslogtreecommitdiff
path: root/biology/hhsuite
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-05-11 19:33:32 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-05-11 19:33:32 +0000
commit2b54b2632d1a77069f95754baea4fe9ad2c3f156 (patch)
treea6fece3af0db704662e098686e3d5041f728fae8 /biology/hhsuite
parent45a49764db900028bc709e8b6b45083c4f9439b9 (diff)
downloadports-2b54b2632d1a77069f95754baea4fe9ad2c3f156.tar.gz
ports-2b54b2632d1a77069f95754baea4fe9ad2c3f156.zip
biology/hhsuite: fix build on powerpc64 elfv2
Use GCC instead of Clang: /usr/lib/clang/10.0.0/include/mmintrin.h:216:19: error: use of undeclared identifier '__builtin_ia32_punpckhbw' return (__m64)__builtin_ia32_punpckhbw((__v8qi)__m1, (__v8qi)__m2);
Notes
Notes: svn path=/head/; revision=534934
Diffstat (limited to 'biology/hhsuite')
-rw-r--r--biology/hhsuite/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/biology/hhsuite/Makefile b/biology/hhsuite/Makefile
index 988e946f66b5..218559d27a65 100644
--- a/biology/hhsuite/Makefile
+++ b/biology/hhsuite/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libmpi.so:net/openmpi
-USES= cmake compiler:c++11-lang perl5 python shebangfix
+USES= cmake perl5 python shebangfix
SHEBANG_GLOB= *.pl *.py
USE_GITHUB= yes
GH_ACCOUNT= soedinglab
@@ -29,8 +29,11 @@ CMAKE_ON= HAVE_SSE2
.endif
.if ${ARCH} == powerpc64
+USES+= compiler:gcc-c++11-lib
post-patch:
${REINPLACE_CMD} -e 's/-msse -msse2/-D_ARCH_PWR8 -DNO_WARN_X86_INTRINSICS -maltivec -mpower8-vector -mvsx/g' ${WRKSRC}/src/CMakeLists.txt
+.else
+USES+= compiler:c++11-lang
.endif
.include <bsd.port.mk>