aboutsummaryrefslogtreecommitdiff
path: root/biology/hhsuite
diff options
context:
space:
mode:
Diffstat (limited to 'biology/hhsuite')
-rw-r--r--biology/hhsuite/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/biology/hhsuite/Makefile b/biology/hhsuite/Makefile
index 988e946f66b5..218559d27a65 100644
--- a/biology/hhsuite/Makefile
+++ b/biology/hhsuite/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libmpi.so:net/openmpi
-USES= cmake compiler:c++11-lang perl5 python shebangfix
+USES= cmake perl5 python shebangfix
SHEBANG_GLOB= *.pl *.py
USE_GITHUB= yes
GH_ACCOUNT= soedinglab
@@ -29,8 +29,11 @@ CMAKE_ON= HAVE_SSE2
.endif
.if ${ARCH} == powerpc64
+USES+= compiler:gcc-c++11-lib
post-patch:
${REINPLACE_CMD} -e 's/-msse -msse2/-D_ARCH_PWR8 -DNO_WARN_X86_INTRINSICS -maltivec -mpower8-vector -mvsx/g' ${WRKSRC}/src/CMakeLists.txt
+.else
+USES+= compiler:c++11-lang
.endif
.include <bsd.port.mk>