aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-01-12 18:53:03 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-01-16 14:35:21 +0000
commit02b24eeb0152df74d1c5c949cd5eebbf7a8a6495 (patch)
tree67972d0e2d09cdce73993b03115e04a59e275c32 /biology
parent08a9c4db98f7c91176d8ccfffc00ff225f6ab3b0 (diff)
downloadports-02b24eeb0152df74d1c5c949cd5eebbf7a8a6495.tar.gz
ports-02b24eeb0152df74d1c5c949cd5eebbf7a8a6495.zip
biology/metaeuk: fix build on powerpc64le by disabling openmp until libomp is fixed
Diffstat (limited to 'biology')
-rw-r--r--biology/metaeuk/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/biology/metaeuk/Makefile b/biology/metaeuk/Makefile
index 86e2d6b98b04..c165e0aa717f 100644
--- a/biology/metaeuk/Makefile
+++ b/biology/metaeuk/Makefile
@@ -13,7 +13,6 @@ LICENSE_FILE= ${WRKSRC}/LICENCE.md
NOT_FOR_ARCHS= armv6 armv7 i386 mips powerpc # 32-bit platforms produce wrong results based on https://github.com/soedinglab/metaeuk/issues/85#issuecomment-1888379107
NOT_FOR_ARCHS+= powerpc64 # many modules produce wrong results on big-endian architectures
-BROKEN_powerpc64le= clang fails, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=276268
BUILD_DEPENDS= xxd:editors/vim
TEST_DEPENDS= bash:shells/bash
@@ -34,7 +33,9 @@ OPTIONS_DEFINE= NATIVE
NATIVE_CMAKE_BOOL= NATIVE_ARCH
-.if !exists(/usr/include/omp.h)
+.include <bsd.port.options.mk>
+
+.if !exists(/usr/include/omp.h) || ${ARCH} == powerpc64le # https://github.com/soedinglab/metaeuk/issues/85, https://github.com/llvm/llvm-project/issues/63807
CMAKE_ARGS+= -DREQUIRE_OPENMP:BOOL=OFF
post-patch: # workaround for https://github.com/soedinglab/metaeuk/issues/55